aboutsummaryrefslogtreecommitdiff
path: root/japanese/scim-mozc
diff options
context:
space:
mode:
authorDaichi GOTO <daichi@FreeBSD.org>2011-12-04 14:02:11 +0000
committerDaichi GOTO <daichi@FreeBSD.org>2011-12-04 14:02:11 +0000
commit0bba7c15b9683e74b438c04a8cf0ac8103b8ac9f (patch)
tree98ed6907f81f2f9a5981356c0ce81737646ecdb5 /japanese/scim-mozc
parentc67b5680669fc1fa63c3c6ce6b15b1d72fb11791 (diff)
downloadports-0bba7c15b9683e74b438c04a8cf0ac8103b8ac9f.tar.gz
ports-0bba7c15b9683e74b438c04a8cf0ac8103b8ac9f.zip
Notes
Diffstat (limited to 'japanese/scim-mozc')
-rw-r--r--japanese/scim-mozc/Makefile13
-rw-r--r--japanese/scim-mozc/distinfo4
-rw-r--r--japanese/scim-mozc/files/patch-base_iconv.cc4
-rw-r--r--japanese/scim-mozc/files/patch-base_logging.cc21
-rw-r--r--japanese/scim-mozc/files/patch-base_mutex.h4
-rw-r--r--japanese/scim-mozc/files/patch-base_process.cc6
-rw-r--r--japanese/scim-mozc/files/patch-base_util.cc8
-rw-r--r--japanese/scim-mozc/files/patch-build_mozc.py6
-rw-r--r--japanese/scim-mozc/files/patch-build_tools_mozc_version.py8
-rw-r--r--japanese/scim-mozc/files/patch-gui_about_dialog_about_dialog.cc6
-rw-r--r--japanese/scim-mozc/files/patch-gyp_common.gypi16
-rw-r--r--japanese/scim-mozc/files/patch-handwriting_zinnia_handwriting.cc19
-rw-r--r--japanese/scim-mozc/files/patch-ipc_ipc_path_manager.cc6
-rw-r--r--japanese/scim-mozc/files/patch-ipc_unix_ipc.cc14
-rw-r--r--japanese/scim-mozc/files/patch-server_mozc_server.cc16
-rw-r--r--japanese/scim-mozc/files/patch-unix_ibus_gen_mozc_xml.py6
-rw-r--r--japanese/scim-mozc/files/patch-unix_ibus_mozc.xml4
-rw-r--r--japanese/scim-mozc/files/patch-unix_ibus_path_util.cc4
-rw-r--r--japanese/scim-mozc/files/patch-unix_scim_scim.gyp10
19 files changed, 108 insertions, 67 deletions
diff --git a/japanese/scim-mozc/Makefile b/japanese/scim-mozc/Makefile
index 1cb1ad81857a..f5fae4156ccb 100644
--- a/japanese/scim-mozc/Makefile
+++ b/japanese/scim-mozc/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= scim-mozc
-PORTVERSION= 0.13.523.102
-PORTREVISION= 1
+PORTVERSION= 1.3.911.102
+PORTREVISION= 0
CATEGORIES= japanese
-MASTER_SITES= http://people.freebsd.org/~daichi/distfiles/
+MASTER_SITES= http://mozc.googlecode.com/files/
DISTNAME= mozc-${PORTVERSION}
DISTFILES= ${DISTNAME}.tar.bz2
@@ -52,7 +52,8 @@ REPLACE_FILES= ${WRKSRC}/build_mozc.py \
${WRKSRC}/base/util.cc \
${WRKSRC}/base/process.cc \
${WRKSRC}/unix/scim/scim.gyp \
- ${WRKSRC}/unix/scim/scim_mozc.cc
+ ${WRKSRC}/unix/scim/scim_mozc.cc \
+ ${WRKSRC}/handwriting/zinnia_handwriting.cc
post-patch:
@for FILE in ${REPLACE_FILES}; \
@@ -66,9 +67,9 @@ do-build:
export BUILD_COMMAND=${GMAKE}; \
${PYTHON_CMD} build_mozc.py gyp --gypdir=${LOCALBASE}/bin; \
${PYTHON_CMD} build_mozc.py build_tools \
- -c ${BUILD_MODE} --qtdir=${QT_LIBDIR}; \
+ -c ${BUILD_MODE}; \
${PYTHON_CMD} build_mozc.py build \
- -c ${BUILD_MODE} --qtdir=${QT_LIBDIR} \
+ -c ${BUILD_MODE} \
unix/scim/scim.gyp:scim_mozc \
unix/scim/scim.gyp:scim_mozc_setup
diff --git a/japanese/scim-mozc/distinfo b/japanese/scim-mozc/distinfo
index e403a6074a72..3c6903f8ca22 100644
--- a/japanese/scim-mozc/distinfo
+++ b/japanese/scim-mozc/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mozc-0.13.523.102.tar.bz2) = e83a6fa874ac27cd5f15c014f22a5c03c749e9009a078fb812d4e127892abbe2
-SIZE (mozc-0.13.523.102.tar.bz2) = 39269824
+SHA256 (mozc-1.3.911.102.tar.bz2) = da27945d6732e4fc70c08534cc8d10cd23d6fba5ebc52e6b31cac5d04ba1588a
+SIZE (mozc-1.3.911.102.tar.bz2) = 39180652
diff --git a/japanese/scim-mozc/files/patch-base_iconv.cc b/japanese/scim-mozc/files/patch-base_iconv.cc
index d7dae90d339f..a51ccec8e65b 100644
--- a/japanese/scim-mozc/files/patch-base_iconv.cc
+++ b/japanese/scim-mozc/files/patch-base_iconv.cc
@@ -1,5 +1,5 @@
---- base/iconv.cc.org 2010-11-06 10:43:30.936188326 +0900
-+++ base/iconv.cc 2010-11-06 11:22:34.282186490 +0900
+--- base/iconv.cc.orig 2011-12-04 16:22:26.109606820 +0900
++++ base/iconv.cc 2011-12-04 16:46:50.884607344 +0900
@@ -52,7 +52,11 @@
size_t olen_org = olen;
iconv(ic, 0, &ilen, 0, &olen); // reset iconv state
diff --git a/japanese/scim-mozc/files/patch-base_logging.cc b/japanese/scim-mozc/files/patch-base_logging.cc
new file mode 100644
index 000000000000..69d7783587ff
--- /dev/null
+++ b/japanese/scim-mozc/files/patch-base_logging.cc
@@ -0,0 +1,21 @@
+--- base/logging.cc.orig 2011-12-04 16:22:26.116610643 +0900
++++ base/logging.cc 2011-12-04 19:57:28.052770432 +0900
+@@ -212,7 +212,7 @@
+ char buf[512];
+ snprintf(buf, sizeof(buf),
+ "%4.4d-%2.2d-%2.2d %2.2d:%2.2d:%2.2d %u "
+-#ifndef OS_LINUX // = OS_WINDOWS or OS_MACOSX
++#if !defined(OS_LINUX) && !defined(__FreeBSD__) // = OS_WINDOWS or OS_MACOSX
+ "%u",
+ #else
+ "%lu",
+@@ -229,6 +229,9 @@
+ #elif defined(OS_MACOSX)
+ ::getpid(),
+ reinterpret_cast<uint32>(pthread_self())
++#elif defined(__FreeBSD__)
++ ::getpid(),
++ (uint64_t)pthread_self()
+ #else // = OS_LINUX
+ ::getpid(),
+ pthread_self() // returns unsigned long.
diff --git a/japanese/scim-mozc/files/patch-base_mutex.h b/japanese/scim-mozc/files/patch-base_mutex.h
index 85cf9e037e95..8d52c97c3594 100644
--- a/japanese/scim-mozc/files/patch-base_mutex.h
+++ b/japanese/scim-mozc/files/patch-base_mutex.h
@@ -1,5 +1,5 @@
---- base/mutex.h.org 2010-11-06 10:44:01.433194789 +0900
-+++ base/mutex.h 2010-11-06 10:44:28.939186472 +0900
+--- base/mutex.h.orig 2011-12-04 16:22:26.106606369 +0900
++++ base/mutex.h 2011-12-04 16:46:50.658605855 +0900
@@ -82,11 +82,11 @@
// PTHREAD_MUTEX_RECURSIVE_NP and PTHREAD_MUTEX_RECURSIVE seem to be
// variants. For example, Mac OS X 10.4 had
diff --git a/japanese/scim-mozc/files/patch-base_process.cc b/japanese/scim-mozc/files/patch-base_process.cc
index 2deec58c1720..0bdaff0a1847 100644
--- a/japanese/scim-mozc/files/patch-base_process.cc
+++ b/japanese/scim-mozc/files/patch-base_process.cc
@@ -1,6 +1,6 @@
---- base/process.cc.org 2010-11-06 10:44:33.530187843 +0900
-+++ base/process.cc 2010-11-06 10:45:08.765186704 +0900
-@@ -194,13 +194,18 @@
+--- base/process.cc.orig 2011-12-04 16:22:26.103607664 +0900
++++ base/process.cc 2011-12-04 16:46:51.045606717 +0900
+@@ -120,13 +120,18 @@
return ShellExecuteInSystemDir(L"open", wurl.c_str(), NULL, SW_SHOW);
#endif
diff --git a/japanese/scim-mozc/files/patch-base_util.cc b/japanese/scim-mozc/files/patch-base_util.cc
index 1f5bdabf7ba8..5e7abf37af9c 100644
--- a/japanese/scim-mozc/files/patch-base_util.cc
+++ b/japanese/scim-mozc/files/patch-base_util.cc
@@ -1,6 +1,6 @@
---- base/util.cc.org 2010-11-06 10:45:14.448193623 +0900
-+++ base/util.cc 2010-11-06 10:46:11.717188704 +0900
-@@ -1629,9 +1629,13 @@
+--- base/util.cc.orig 2011-12-04 16:22:26.112610903 +0900
++++ base/util.cc 2011-12-04 16:46:50.958606064 +0900
+@@ -2592,9 +2592,13 @@
return MacUtil::GetServerDirectory();
#endif // OS_MACOSX
@@ -14,4 +14,4 @@
+#endif
}
- string Util::GetServerPath() {
+ string Util::GetDocumentDirectory() {
diff --git a/japanese/scim-mozc/files/patch-build_mozc.py b/japanese/scim-mozc/files/patch-build_mozc.py
index d3504fffc41c..cf77ec55146c 100644
--- a/japanese/scim-mozc/files/patch-build_mozc.py
+++ b/japanese/scim-mozc/files/patch-build_mozc.py
@@ -1,6 +1,6 @@
---- build_mozc.py.org 2010-11-06 10:46:16.225188464 +0900
-+++ build_mozc.py 2010-11-06 10:46:35.213186660 +0900
-@@ -69,7 +69,7 @@
+--- build_mozc.py.orig 2011-12-04 16:22:26.517605881 +0900
++++ build_mozc.py 2011-12-04 16:46:51.189606024 +0900
+@@ -70,7 +70,7 @@
def IsLinux():
"""Returns true if the platform is Linux."""
diff --git a/japanese/scim-mozc/files/patch-build_tools_mozc_version.py b/japanese/scim-mozc/files/patch-build_tools_mozc_version.py
index df3a35cc7d0a..c2d3263872f4 100644
--- a/japanese/scim-mozc/files/patch-build_tools_mozc_version.py
+++ b/japanese/scim-mozc/files/patch-build_tools_mozc_version.py
@@ -1,6 +1,6 @@
---- build_tools/mozc_version.py.org 2010-11-06 10:46:40.900188220 +0900
-+++ build_tools/mozc_version.py 2010-11-06 10:47:03.466651555 +0900
-@@ -55,7 +55,7 @@
+--- build_tools/mozc_version.py.orig 2011-12-04 16:22:26.211608471 +0900
++++ build_tools/mozc_version.py 2011-12-04 16:35:15.156605950 +0900
+@@ -56,7 +56,7 @@
def IsLinux():
"""Returns true if the platform is Linux."""
@@ -8,4 +8,4 @@
+ return os.name == 'posix' and ( os.uname()[0] == 'Linux' or os.uname()[0] == 'FreeBSD' )
- def CalculateRevisionForPlatform(revision):
+ def CalculateRevisionForPlatform(revision, target_platform):
diff --git a/japanese/scim-mozc/files/patch-gui_about_dialog_about_dialog.cc b/japanese/scim-mozc/files/patch-gui_about_dialog_about_dialog.cc
index 3e9ed169b980..30454a4930ef 100644
--- a/japanese/scim-mozc/files/patch-gui_about_dialog_about_dialog.cc
+++ b/japanese/scim-mozc/files/patch-gui_about_dialog_about_dialog.cc
@@ -1,6 +1,6 @@
---- gui/about_dialog/about_dialog.cc.org 2010-11-06 10:47:08.291193501 +0900
-+++ gui/about_dialog/about_dialog.cc 2010-11-06 10:48:08.940188276 +0900
-@@ -106,7 +106,11 @@
+--- gui/about_dialog/about_dialog.cc.orig 2011-12-04 16:22:26.291606976 +0900
++++ gui/about_dialog/about_dialog.cc 2011-12-04 16:44:21.340606780 +0900
+@@ -119,7 +119,11 @@
SetLabelText(label_terms);
SetLabelText(label_credits);
diff --git a/japanese/scim-mozc/files/patch-gyp_common.gypi b/japanese/scim-mozc/files/patch-gyp_common.gypi
index 75a5ddb8921a..b1a1fa6c3bc5 100644
--- a/japanese/scim-mozc/files/patch-gyp_common.gypi
+++ b/japanese/scim-mozc/files/patch-gyp_common.gypi
@@ -1,8 +1,8 @@
---- gyp/common.gypi.org 2010-11-06 10:50:16.532187538 +0900
-+++ gyp/common.gypi 2010-11-06 10:50:37.769189168 +0900
-@@ -436,6 +436,12 @@
- '-lz',
- '<@(extra_linux_libs)',
+--- gyp/common.gypi.orig 2011-12-04 16:22:26.257607334 +0900
++++ gyp/common.gypi 2011-12-04 16:46:48.756621873 +0900
+@@ -512,6 +512,12 @@
+ # <unordered_map> and <unordered_set>.
+ '-Wno-deprecated',
],
+ 'include_dirs': [
+ '@@LOCALBASE@@/include'
@@ -10,6 +10,6 @@
+ 'ldflags': [
+ '-L@@LOCALBASE@@/lib'
+ ],
- 'conditions': [
- ['use_libgtest==0', {
- 'include_dirs': [
+ 'link_settings': {
+ 'libraries': [
+ '<@(linux_libs)',
diff --git a/japanese/scim-mozc/files/patch-handwriting_zinnia_handwriting.cc b/japanese/scim-mozc/files/patch-handwriting_zinnia_handwriting.cc
new file mode 100644
index 000000000000..672a5e0afd1c
--- /dev/null
+++ b/japanese/scim-mozc/files/patch-handwriting_zinnia_handwriting.cc
@@ -0,0 +1,19 @@
+--- handwriting/zinnia_handwriting.cc.orig 2011-12-04 22:26:40.226138013 +0900
++++ handwriting/zinnia_handwriting.cc 2011-12-04 22:27:01.145136587 +0900
+@@ -49,10 +49,16 @@
+ const char kModelFile[] = "handwriting-light-ja.model";
+ return Util::JoinPath(MacUtil::GetResourcesDirectory(), kModelFile);
+ #elif defined(USE_LIBZINNIA)
++#if defined(__FreeBSD__)
++ const char kModelFile[] =
++ "@@LOCALBASE@@/share/tegaki/models/zinnia/handwriting-ja.model";
++ return kModelFile;
++#else
+ // On Linux, use the model for tegaki-zinnia.
+ const char kModelFile[] =
+ "/usr/share/tegaki/models/zinnia/handwriting-ja.model";
+ return kModelFile;
++#endif
+ #else
+ const char kModelFile[] = "handwriting-ja.model";
+ return Util::JoinPath(Util::GetServerDirectory(), kModelFile);
diff --git a/japanese/scim-mozc/files/patch-ipc_ipc_path_manager.cc b/japanese/scim-mozc/files/patch-ipc_ipc_path_manager.cc
index d1e6b742e4a1..2221123cc15f 100644
--- a/japanese/scim-mozc/files/patch-ipc_ipc_path_manager.cc
+++ b/japanese/scim-mozc/files/patch-ipc_ipc_path_manager.cc
@@ -1,6 +1,6 @@
---- ipc/ipc_path_manager.cc.org 2010-11-06 10:50:41.620188667 +0900
-+++ ipc/ipc_path_manager.cc 2010-11-06 10:51:04.912186952 +0900
-@@ -265,7 +265,7 @@
+--- ipc/ipc_path_manager.cc.orig 2011-12-04 16:22:26.515606954 +0900
++++ ipc/ipc_path_manager.cc 2011-12-04 16:46:51.134605388 +0900
+@@ -274,7 +274,7 @@
*ipc_name = kIPCPrefix;
#endif // OS_WINDOWS
diff --git a/japanese/scim-mozc/files/patch-ipc_unix_ipc.cc b/japanese/scim-mozc/files/patch-ipc_unix_ipc.cc
index a437b149c50b..48407580903a 100644
--- a/japanese/scim-mozc/files/patch-ipc_unix_ipc.cc
+++ b/japanese/scim-mozc/files/patch-ipc_unix_ipc.cc
@@ -1,5 +1,5 @@
---- ipc/unix_ipc.cc.org 2010-11-06 10:51:14.204190823 +0900
-+++ ipc/unix_ipc.cc 2010-11-06 10:54:18.096187153 +0900
+--- ipc/unix_ipc.cc.orig 2011-12-04 16:22:26.515606954 +0900
++++ ipc/unix_ipc.cc 2011-12-04 16:46:51.120605285 +0900
@@ -41,7 +41,7 @@
#include <sys/time.h>
#include <sys/types.h>
@@ -24,10 +24,10 @@
-#ifdef OS_LINUX
+#if defined(OS_LINUX) && !defined(__FreeBSD__)
- struct ucred peer_cred;
- int peer_cred_len = sizeof(peer_cred);
- if (getsockopt(socket, SOL_SOCKET, SO_PEERCRED,
-@@ -303,7 +303,7 @@
+ // On ARM Linux, we do nothing and just return true since the platform
+ // sometimes doesn't support the getsockopt(sock, SOL_SOCKET, SO_PEERCRED)
+ // system call.
+@@ -309,7 +309,7 @@
address.sun_family = AF_UNIX;
::memcpy(address.sun_path, server_address.data(), server_address_length);
address.sun_path[server_address_length] = '\0';
@@ -36,7 +36,7 @@
address.sun_len = SUN_LEN(&address);
const size_t sun_len = sizeof(address);
#else
-@@ -423,21 +423,21 @@
+@@ -429,21 +429,21 @@
SO_REUSEADDR,
reinterpret_cast<char *>(&on),
sizeof(on));
diff --git a/japanese/scim-mozc/files/patch-server_mozc_server.cc b/japanese/scim-mozc/files/patch-server_mozc_server.cc
index 4ad2a7be1db7..a5465a103c38 100644
--- a/japanese/scim-mozc/files/patch-server_mozc_server.cc
+++ b/japanese/scim-mozc/files/patch-server_mozc_server.cc
@@ -1,6 +1,6 @@
---- server/mozc_server.cc.org 2010-11-06 10:54:20.721190331 +0900
-+++ server/mozc_server.cc 2010-11-06 10:55:39.283188573 +0900
-@@ -30,6 +30,9 @@
+--- server/mozc_server.cc.orig 2011-12-04 16:22:26.174607330 +0900
++++ server/mozc_server.cc 2011-12-04 16:43:55.914606129 +0900
+@@ -32,6 +32,9 @@
#ifdef OS_WINDOWS
#include <windows.h>
#endif
@@ -10,7 +10,7 @@
#include "base/base.h"
#include "base/process.h"
-@@ -46,6 +49,23 @@
+@@ -50,6 +53,23 @@
mozc::SessionServer *g_session_server = NULL;
}
@@ -34,7 +34,7 @@
namespace mozc {
namespace {
-@@ -122,6 +142,12 @@
+@@ -132,6 +152,12 @@
return -1;
}
@@ -44,6 +44,6 @@
+ ::signal(SIGTERM, sig_func);
+#endif
+
- // Create a new thread.
- // We can't call Loop() as Loop() doesn't make a thread.
- // We have to make a thread here so that ShutdownSessionCallback()
+ #if defined(OS_WINDOWS)
+ // On Windows, ShutdownSessionCallback is not called intentionally in order
+ // to avoid crashes oritinates from it. See b/2696087.
diff --git a/japanese/scim-mozc/files/patch-unix_ibus_gen_mozc_xml.py b/japanese/scim-mozc/files/patch-unix_ibus_gen_mozc_xml.py
index d10874b052ee..dab9c8e72334 100644
--- a/japanese/scim-mozc/files/patch-unix_ibus_gen_mozc_xml.py
+++ b/japanese/scim-mozc/files/patch-unix_ibus_gen_mozc_xml.py
@@ -1,5 +1,5 @@
---- unix/ibus/gen_mozc_xml.py.org 2010-11-06 10:55:42.821186000 +0900
-+++ unix/ibus/gen_mozc_xml.py 2010-11-06 10:56:59.661189967 +0900
+--- unix/ibus/gen_mozc_xml.py.orig 2011-12-04 16:22:26.122609031 +0900
++++ unix/ibus/gen_mozc_xml.py 2011-12-04 16:35:15.333604982 +0900
@@ -39,6 +39,7 @@
import optparse
@@ -9,7 +9,7 @@
# Information to generate <component> part of mozc.xml. %s will be replaced with
# a product name, 'Mozc' or 'Google Japanese Input'.
@@ -64,6 +65,24 @@
- 'rank': '0',
+ 'rank': '80',
}
+if os.uname()[0] == 'FreeBSD':
diff --git a/japanese/scim-mozc/files/patch-unix_ibus_mozc.xml b/japanese/scim-mozc/files/patch-unix_ibus_mozc.xml
index 624ff45d68ab..436519119edc 100644
--- a/japanese/scim-mozc/files/patch-unix_ibus_mozc.xml
+++ b/japanese/scim-mozc/files/patch-unix_ibus_mozc.xml
@@ -1,5 +1,5 @@
---- unix/ibus/mozc.xml.org 2010-11-06 10:57:06.006187725 +0900
-+++ unix/ibus/mozc.xml 2010-11-06 10:57:28.462186463 +0900
+--- unix/ibus/mozc.xml.orig 1970-01-01 09:00:00.000000000 +0900
++++ unix/ibus/mozc.xml 2011-12-04 16:04:42.283606379 +0900
@@ -0,0 +1,21 @@
+<component>
+ <name>com.google.IBus.Mozc</name>
diff --git a/japanese/scim-mozc/files/patch-unix_ibus_path_util.cc b/japanese/scim-mozc/files/patch-unix_ibus_path_util.cc
index 532d5c92b0a0..fc83f75e8883 100644
--- a/japanese/scim-mozc/files/patch-unix_ibus_path_util.cc
+++ b/japanese/scim-mozc/files/patch-unix_ibus_path_util.cc
@@ -1,5 +1,5 @@
---- unix/ibus/path_util.cc.org 2010-11-06 10:57:33.500187940 +0900
-+++ unix/ibus/path_util.cc 2010-11-06 10:58:12.395186886 +0900
+--- unix/ibus/path_util.cc.orig 2011-12-04 16:22:26.124607888 +0900
++++ unix/ibus/path_util.cc 2011-12-04 16:35:15.354607302 +0900
@@ -30,14 +30,22 @@
#include "unix/ibus/path_util.h"
diff --git a/japanese/scim-mozc/files/patch-unix_scim_scim.gyp b/japanese/scim-mozc/files/patch-unix_scim_scim.gyp
index 128dc6b98854..566e9d8bb1dd 100644
--- a/japanese/scim-mozc/files/patch-unix_scim_scim.gyp
+++ b/japanese/scim-mozc/files/patch-unix_scim_scim.gyp
@@ -1,10 +1,10 @@
---- unix/scim/scim.gyp.org 2010-11-06 10:58:16.438187044 +0900
-+++ unix/scim/scim.gyp 2010-11-06 10:58:34.829186459 +0900
-@@ -44,7 +44,7 @@
- '../../session/session.gyp:session',
+--- unix/scim/scim.gyp.orig 2011-12-04 16:22:26.127609806 +0900
++++ unix/scim/scim.gyp 2011-12-04 16:39:02.023609368 +0900
+@@ -39,7 +39,7 @@
+ 'gtk+-2.0',
],
'scim_defines': [
-- 'SCIM_ICONDIR="<!@(pkg-config --variable=icondir scim)"',
+- 'SCIM_ICONDIR="<!@(<(pkg_config_command) --variable=icondir scim)"',
+ 'SCIM_ICONDIR="@@LOCALBASE@@/share/scim-mozc/icons/"',
]
},