aboutsummaryrefslogtreecommitdiff
path: root/japanese/scim-uim
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2004-11-30 16:25:27 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2004-11-30 16:25:27 +0000
commit8d74077c0bc81eb2c6ea9cb8b2b87254d21bd6a7 (patch)
treea866d22bbeef96cdc15c050fb36d9d994d36b94f /japanese/scim-uim
parent4e47717150981721e957a170f706fa006993ff00 (diff)
downloadports-8d74077c0bc81eb2c6ea9cb8b2b87254d21bd6a7.tar.gz
ports-8d74077c0bc81eb2c6ea9cb8b2b87254d21bd6a7.zip
Notes
Diffstat (limited to 'japanese/scim-uim')
-rw-r--r--japanese/scim-uim/Makefile50
-rw-r--r--japanese/scim-uim/distinfo2
-rw-r--r--japanese/scim-uim/files/extra-patch-4-stable10
-rw-r--r--japanese/scim-uim/pkg-descr10
-rw-r--r--japanese/scim-uim/pkg-message11
-rw-r--r--japanese/scim-uim/pkg-plist6
6 files changed, 89 insertions, 0 deletions
diff --git a/japanese/scim-uim/Makefile b/japanese/scim-uim/Makefile
new file mode 100644
index 000000000000..436b83410071
--- /dev/null
+++ b/japanese/scim-uim/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: ja-scim-uim
+# Date created: 15 Nov 2004
+# Whom: Seiya Yanagita <s_yanagita@ybb.ne.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= scim-uim
+PORTVERSION= 0.1.3
+CATEGORIES= japanese
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://freedesktop.org/~suzhe/sources/
+MASTER_SITE_SUBDIR=scim
+
+MAINTAINER= s_yanagita@ybb.ne.jp
+COMMENT= SCIM IMEngine module using UIM input method library
+
+BUILD_DEPENDS= scim:${PORTSDIR}/textproc/scim
+LIB_DEPENDS= uim.0:${PORTSDIR}/japanese/uim
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_GNOME= lthack
+USE_X_PREFIX= yes
+USE_ICONV= yes
+USE_GMAKE= yes
+USE_LIBTOOL_VER= 15
+
+CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
+ PTHREAD_LIBS="${PTHREAD_LIBS}"
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500035
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
+RUN_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include -I${LOCALBASE}/include/stlport" \
+ LDFLAGS="-L${LOCALBASE}/lib -lstlport_gcc -lintl ${PTHREAD_LIBS}"
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-4-stable
+.else
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include -D__STDC_ISO_10646__" \
+ LDFLAGS="-L${LOCALBASE}/lib -lintl"
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO}
+ @${ECHO} To display this message again, type \`pkg_info -D ${PKGNAME}\'
+ @${ECHO}
+
+.include <bsd.port.post.mk>
diff --git a/japanese/scim-uim/distinfo b/japanese/scim-uim/distinfo
new file mode 100644
index 000000000000..9e470f99d652
--- /dev/null
+++ b/japanese/scim-uim/distinfo
@@ -0,0 +1,2 @@
+MD5 (scim-uim-0.1.3.tar.gz) = 81bf69029dbde289258cd6f881b552be
+SIZE (scim-uim-0.1.3.tar.gz) = 321608
diff --git a/japanese/scim-uim/files/extra-patch-4-stable b/japanese/scim-uim/files/extra-patch-4-stable
new file mode 100644
index 000000000000..13cb124a4283
--- /dev/null
+++ b/japanese/scim-uim/files/extra-patch-4-stable
@@ -0,0 +1,10 @@
+--- src/scim_uim_imengine.cpp.orig Thu Nov 11 20:27:26 2004
++++ src/scim_uim_imengine.cpp Thu Nov 11 20:28:09 2004
+@@ -36,6 +36,7 @@
+
+ #include <scim.h>
+ #include "scim_uim_imengine.h"
++#include <cstdio>
+
+ #define scim_module_init uim_LTX_scim_module_init
+ #define scim_module_exit uim_LTX_scim_module_exit
diff --git a/japanese/scim-uim/pkg-descr b/japanese/scim-uim/pkg-descr
new file mode 100644
index 000000000000..63ea0100fd74
--- /dev/null
+++ b/japanese/scim-uim/pkg-descr
@@ -0,0 +1,10 @@
+scim-uim is the SCIM IMEngine module using the uim input method library.
+
+Smart Common Input Method platform, in short SCIM, is a development platform to
+make Input Method developers live easier.
+
+WWW: http://scim.freedesktop.org
+
+Uim is a multilingual input method library.
+
+WWW: http://uim.freedesktop.org
diff --git a/japanese/scim-uim/pkg-message b/japanese/scim-uim/pkg-message
new file mode 100644
index 000000000000..316515697de1
--- /dev/null
+++ b/japanese/scim-uim/pkg-message
@@ -0,0 +1,11 @@
+--------------------------------------------------------------------
+Remember to set environment variables XMODIFIERS and LANG:
+
+ csh/tcsh: setenv XMODIFIERS @im=SCIM ; setenv LANG ja_JP.eucJP
+ sh/bash: export XMODIFIERS='@im=SCIM'; export LANG=ja_JP.eucJP
+
+To start the SCIM input method daemon, use command:
+
+ scim -d
+
+--------------------------------------------------------------------
diff --git a/japanese/scim-uim/pkg-plist b/japanese/scim-uim/pkg-plist
new file mode 100644
index 000000000000..b661e099d3e5
--- /dev/null
+++ b/japanese/scim-uim/pkg-plist
@@ -0,0 +1,6 @@
+lib/scim-1.0/IMEngine/uim.so
+lib/scim-1.0/IMEngine/uim.la
+lib/scim-1.0/IMEngine/uim.a
+share/scim/icons/scim-uim.png
+@unexec rmdir %D/lib/scim-1.0/IMEngine 2>/dev/null || true
+@unexec rmdir %D/lib/scim-1.0/icons 2>/dev/null || true