aboutsummaryrefslogtreecommitdiff
path: root/japanese/skk-tools/Makefile
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>1998-12-15 15:22:46 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>1998-12-15 15:22:46 +0000
commit9f9e9d2d5037cbe5dd1a54ee060bca620bf8a5b5 (patch)
tree6413de70edf3f68fef0ff2bf856fdb584ce9ecef /japanese/skk-tools/Makefile
parent7091c3a40e8a6953c5f34f2b358848ac2a7f6e04 (diff)
Notes
Diffstat (limited to 'japanese/skk-tools/Makefile')
-rw-r--r--japanese/skk-tools/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/japanese/skk-tools/Makefile b/japanese/skk-tools/Makefile
new file mode 100644
index 000000000000..f1ed7aa2587c
--- /dev/null
+++ b/japanese/skk-tools/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: skk-tools
+# Version required: 9.6
+# Date created: 31 Oct 1998
+# Whom: Shigeyuki FUKUSHIMA <shige@kuis.kyoto-u.ac.jp>
+#
+# $Id$
+#
+
+DISTNAME= skk9.6
+PKGNAME= ja-skk-tools-9.6
+CATEGORIES= japanese
+MASTER_SITES= ftp://skk.kuis.kyoto-u.ac.jp/skk/9.6/
+
+MAINTAINER= matusita@jp.freebsd.org
+
+SKK_MASTERDIR= ${.CURDIR}/../../japanese/skk-jisyo
+WRKSRC= ${SKK_MASTERDIR}/work/skk-9.6
+MAKE_ARGS= SUBDIRS='jisyo-tools'
+
+do-extract:
+ @echo "===> Extracting depends on ${SKK_MASTERDIR}"
+ @[ -d ${WRKDIR} ] || ${MKDIR} ${WRKDIR}
+ @if [ ! -f ${SKK_MASTERDIR}/work/.extract_done ]; then \
+ (cd ${SKK_MASTERDIR}; make extract) ;\
+ fi
+ @if [ ! -f ${SKK_MASTERDIR}/work/.configure_done ]; then \
+ (cd ${SKK_MASTERDIR}; PREFIX=${PREFIX} make configure) ;\
+ fi
+
+.include <bsd.port.mk>