aboutsummaryrefslogtreecommitdiff
path: root/japanese/suicavalue/Makefile
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2007-01-21 14:43:06 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2007-01-21 14:43:06 +0000
commit405556f393711bac3fce77dfa5f903e0dc7e1e18 (patch)
treecd1002a44da16965b00edd260190257bafa6f939 /japanese/suicavalue/Makefile
parent88c5aa0bbe43934cdd73a5c5d5a7791e8a0b8ef9 (diff)
downloadports-405556f393711bac3fce77dfa5f903e0dc7e1e18.tar.gz
ports-405556f393711bac3fce77dfa5f903e0dc7e1e18.zip
Notes
Diffstat (limited to 'japanese/suicavalue/Makefile')
-rw-r--r--japanese/suicavalue/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/japanese/suicavalue/Makefile b/japanese/suicavalue/Makefile
new file mode 100644
index 000000000000..aac51234e6e0
--- /dev/null
+++ b/japanese/suicavalue/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: suicavalue
+# Date created: 18 January 2007
+# Whom: Yoshihiko Sarumaru <mistral@imasy.or.jp>
+#
+# $FreeBSD$
+
+PORTNAME= suicavalue
+PORTVERSION= 2007.01.06
+CATEGORIES= japanese
+MASTER_SITES= http://www.imfj.net/people/nomura/soft/PaSoRi/
+DISTNAME= SuicaValue
+EXTRACT_SUFX= .c
+DIST_SUBDIR= ${PORTNAME}/${PORTVERSION}
+EXTRACT_ONLY=
+
+MAINTAINER= mistral@imasy.or.jp
+COMMENT= Utility to print a statement of Suica
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libpasori.a:${PORTSDIR}/devel/libpasori
+
+PLIST_FILES= bin/SuicaValue
+
+post-extract:
+ @${MKDIR} ${WRKSRC}
+ @${CP} -f ${DISTDIR}/${DISTFILES} ${WRKSRC}
+ @${CP} -f ${FILESDIR}/Makefile ${WRKSRC}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>