aboutsummaryrefslogtreecommitdiff
path: root/japanese/suikyo
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2005-05-10 15:36:55 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2005-05-10 15:36:55 +0000
commiteed3f4823b0dfca8ca6550dcd288a8336109746a (patch)
treecc64718b78a76ce63bdb1d0285975939688e9bd9 /japanese/suikyo
parent5ed99fc7f9eacc41ac54784d512f5c9127c80cc8 (diff)
downloadports-eed3f4823b0dfca8ca6550dcd288a8336109746a.tar.gz
ports-eed3f4823b0dfca8ca6550dcd288a8336109746a.zip
Notes
Diffstat (limited to 'japanese/suikyo')
-rw-r--r--japanese/suikyo/Makefile33
-rw-r--r--japanese/suikyo/distinfo2
-rw-r--r--japanese/suikyo/files/patch-Makefile.am15
-rw-r--r--japanese/suikyo/files/patch-elisp-Makefile.am8
-rw-r--r--japanese/suikyo/files/patch-elisp-etc-Makefile.am8
-rw-r--r--japanese/suikyo/files/patch-ruby-Makefile.am8
-rw-r--r--japanese/suikyo/pkg-descr7
-rw-r--r--japanese/suikyo/pkg-plist48
8 files changed, 129 insertions, 0 deletions
diff --git a/japanese/suikyo/Makefile b/japanese/suikyo/Makefile
new file mode 100644
index 000000000000..74246bc6b1a6
--- /dev/null
+++ b/japanese/suikyo/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: ja-suikyo
+# Date created: 6 Jun 2003
+# Whom: Gen Otsuji<otsuji@users.sourceforge.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= suikyo
+PORTVERSION= 2.1.0
+CATEGORIES= japanese
+MASTER_SITES= http://prime.sourceforge.jp/src/
+
+MAINTAINER= otsuji@users.sourceforge.jp
+COMMENT= Romaji-Kana conversion Library for the prime
+
+USE_RUBY= yes
+USE_GNOME= pkgconfig
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-rubydir=${RUBY_SITELIBDIR}
+USE_AUTOMAKE_VER= 19
+USE_AUTOCONF_VER= 259
+
+pre-configure:
+ @(cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${ACLOCAL})
+
+post-install:
+.if !defined(NOPORTDOCS)
+ cd ${WRKSRC}/doc; ${MAKE} ${INSTALL_TARGET}
+ cd ${WRKSRC}/elisp/doc; ${MAKE} ${INSTALL_TARGET}
+ cd ${WRKSRC}/ruby/doc; ${MAKE} ${INSTALL_TARGET}
+.endif
+
+.include <bsd.port.mk>
diff --git a/japanese/suikyo/distinfo b/japanese/suikyo/distinfo
new file mode 100644
index 000000000000..35c6831c630f
--- /dev/null
+++ b/japanese/suikyo/distinfo
@@ -0,0 +1,2 @@
+MD5 (suikyo-2.1.0.tar.gz) = d33d713c57522f5c28323e19b3f635b2
+SIZE (suikyo-2.1.0.tar.gz) = 202155
diff --git a/japanese/suikyo/files/patch-Makefile.am b/japanese/suikyo/files/patch-Makefile.am
new file mode 100644
index 000000000000..3aceccf96366
--- /dev/null
+++ b/japanese/suikyo/files/patch-Makefile.am
@@ -0,0 +1,15 @@
+--- Makefile.am.orig Tue Jan 11 23:51:49 2005
++++ Makefile.am Sat May 7 14:32:48 2005
+@@ -8,10 +8,10 @@
+ # You can redistribute it and/or modify it under the terms of
+ # the GNU General Public License version 2.
+
+-SUBDIRS = contrib conv-table doc elisp ruby
++SUBDIRS = contrib conv-table elisp ruby
+ EXTRA_DIST = autogen.sh suikyo.spec suikyo.spec.in suikyo.pc.in
+
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = $(prefix)/libdata/pkgconfig
+ pkgconfig_DATA = suikyo.pc
+
+ rpm:
diff --git a/japanese/suikyo/files/patch-elisp-Makefile.am b/japanese/suikyo/files/patch-elisp-Makefile.am
new file mode 100644
index 000000000000..58db7fb32628
--- /dev/null
+++ b/japanese/suikyo/files/patch-elisp-Makefile.am
@@ -0,0 +1,8 @@
+--- elisp/Makefile.am.orig Tue Jun 3 02:36:20 2003
++++ elisp/Makefile.am Sat May 7 14:33:22 2005
+@@ -8,4 +8,4 @@
+ # You can redistribute it and/or modify it under the terms of
+ # the GNU General Public License version 2.
+
+-SUBDIRS = doc src etc
++SUBDIRS = src etc
diff --git a/japanese/suikyo/files/patch-elisp-etc-Makefile.am b/japanese/suikyo/files/patch-elisp-etc-Makefile.am
new file mode 100644
index 000000000000..a1d3afdf65c8
--- /dev/null
+++ b/japanese/suikyo/files/patch-elisp-etc-Makefile.am
@@ -0,0 +1,8 @@
+--- elisp/etc/Makefile.am.orig Wed Jun 4 02:04:30 2003
++++ elisp/etc/Makefile.am Sat May 7 14:35:09 2005
+@@ -14,4 +14,4 @@
+ etc_DATA = $(SUIKYOEL_INIT_FILE)
+
+ $(SUIKYOEL_INIT_FILE): _init-suikyo.el
+- cp -p _init-suikyo.el $(SUIKYOEL_INIT_FILE)
++ cp _init-suikyo.el $(SUIKYOEL_INIT_FILE)
diff --git a/japanese/suikyo/files/patch-ruby-Makefile.am b/japanese/suikyo/files/patch-ruby-Makefile.am
new file mode 100644
index 000000000000..68330b7c7613
--- /dev/null
+++ b/japanese/suikyo/files/patch-ruby-Makefile.am
@@ -0,0 +1,8 @@
+--- ruby/Makefile.am.orig Tue Jun 3 02:36:22 2003
++++ ruby/Makefile.am Sat May 7 14:33:56 2005
+@@ -8,4 +8,4 @@
+ # You can redistribute it and/or modify it under the terms of
+ # the GNU General Public License version 2.
+
+-SUBDIRS = doc src test
++SUBDIRS = src test
diff --git a/japanese/suikyo/pkg-descr b/japanese/suikyo/pkg-descr
new file mode 100644
index 000000000000..0a1670199084
--- /dev/null
+++ b/japanese/suikyo/pkg-descr
@@ -0,0 +1,7 @@
+Suikyo is Romaji-Kana conversion Library.
+There are two language bindings for Ruby
+and ELisp. For more detail, please see
+the following web page.
+
+Author: Hiroyuki Komatsu <komatsu@taiyaki.org>
+WWW: http://taiyaki.org/suikyo/
diff --git a/japanese/suikyo/pkg-plist b/japanese/suikyo/pkg-plist
new file mode 100644
index 000000000000..a8a8772baa9c
--- /dev/null
+++ b/japanese/suikyo/pkg-plist
@@ -0,0 +1,48 @@
+%%DATADIR%%/conv-table/ascii-wideascii
+%%DATADIR%%/conv-table/azik
+%%DATADIR%%/conv-table/azik-all
+%%DATADIR%%/conv-table/azik-all_reverse
+%%DATADIR%%/conv-table/azik_reverse
+%%DATADIR%%/conv-table/egg-mark
+%%DATADIR%%/conv-table/egg-mark_reverse
+%%DATADIR%%/conv-table/halfkatakana-hiragana
+%%DATADIR%%/conv-table/halfkatakana-katakana
+%%DATADIR%%/conv-table/hiragana-halfkatakana
+%%DATADIR%%/conv-table/hiragana-katakana
+%%DATADIR%%/conv-table/kana
+%%DATADIR%%/conv-table/kana-romaji
+%%DATADIR%%/conv-table/kana_reverse
+%%DATADIR%%/conv-table/katakana-halfkatakana
+%%DATADIR%%/conv-table/katakana-hiragana
+%%DATADIR%%/conv-table/kuten
+%%DATADIR%%/conv-table/kuten_reverse
+%%DATADIR%%/conv-table/romaji
+%%DATADIR%%/conv-table/romaji-hepburn_reverse
+%%DATADIR%%/conv-table/romaji-kana
+%%DATADIR%%/conv-table/romaji_reverse
+%%DATADIR%%/conv-table/skk-mark
+%%DATADIR%%/conv-table/skk-mark_reverse
+%%DATADIR%%/conv-table/tcode
+%%DATADIR%%/conv-table/tcode-dvorak
+%%DATADIR%%/conv-table/tcode-dvorak_reverse
+%%DATADIR%%/conv-table/tcode_reverse
+%%DATADIR%%/conv-table/tutcode
+%%DATADIR%%/conv-table/tutcode_reverse
+%%DATADIR%%/conv-table/wideascii-ascii
+@unexec rmdir %D/%%DATADIR%%/conv-table 2>/dev/null || true
+@unexec rmdir %D/%%DATADIR%% 2>/dev/null || true
+share/emacs/site-lisp/init-suikyo.el
+share/emacs/site-lisp/suikyo/suikyo.el
+share/emacs/site-lisp/suikyo/suikyo-config.el
+@unexec rmdir %D/share/emacs/site-lisp/suikyo 2>/dev/null || true
+libdata/pkgconfig/suikyo.pc
+%%RUBY_SITELIBDIR%%/suikyo/suikyo-composer.rb
+%%RUBY_SITELIBDIR%%/suikyo/suikyo-config.rb
+%%RUBY_SITELIBDIR%%/suikyo/suikyo.rb
+@unexec rmdir %D/%%RUBY_SITELIBDIR%%/suikyo 2>/dev/null || true
+%%PORTDOCS%%%%DOCSDIR%%/elisp/index.html
+%%PORTDOCS%%%%DOCSDIR%%/ruby/index.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%@unexec rmdir %D/%%DOCSDIR%%/elisp 2>/dev/null || true
+%%PORTDOCS%%@unexec rmdir %D/%%DOCSDIR%%/ruby 2>/dev/null || true
+%%PORTDOCS%%@unexec rmdir %D/%%DOCSDIR%% 2>/dev/null || true