aboutsummaryrefslogtreecommitdiff
path: root/japanese/tk42/Makefile
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>1998-09-27 08:24:37 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>1998-09-27 08:24:37 +0000
commit8f7ae93769b355e3725bda1869b23bc8784bff1b (patch)
tree0e30ba373916b8361c9b40b6e3693cc60c013285 /japanese/tk42/Makefile
parenta1455aa4f6dc98e30f09ba793d6602f03c8bc6a0 (diff)
downloadports-8f7ae93769b355e3725bda1869b23bc8784bff1b.tar.gz
ports-8f7ae93769b355e3725bda1869b23bc8784bff1b.zip
Notes
Diffstat (limited to 'japanese/tk42/Makefile')
-rw-r--r--japanese/tk42/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/japanese/tk42/Makefile b/japanese/tk42/Makefile
index ae85cb62e780..36966ba4e688 100644
--- a/japanese/tk42/Makefile
+++ b/japanese/tk42/Makefile
@@ -3,7 +3,7 @@
# Date created:
# Whom: taguchi@tohoku.iij.ad.jp
#
-# $Id: Makefile,v 1.4 1998/07/03 23:06:36 steve Exp $
+# $Id: Makefile,v 1.5 1998/08/07 23:55:45 asami Exp $
#
DISTNAME= tk4.2p2
@@ -16,10 +16,11 @@ PATCHFILES= tk4.2jp-patch.gz
MAINTAINER= taguchi@tohoku.iij.ad.jp
-BUILD_DEPENDS= ${LOCALBASE}/lib/libtcl76jp.so\.1\.0:${PORTSDIR}/japanese/tcl76
+LIB_DEPENDS= tcl76jp.1:${PORTSDIR}/japanese/tcl76
WRKSRC= ${WRKDIR}/${DISTNAME}/unix
-GNU_CONFIGURE= yes
+USE_AUTOCONF= yes
+USE_XLIB= yes
CONFIGURE_ARGS= --enable-shared
CONFIGURE_ENV= PORTSDIR=${PORTSDIR}
@@ -48,7 +49,7 @@ pre-install:
post-install:
cd ${WRKSRC} && ${MAKE} -f Makefile.lib PREFIX=${PREFIX} VERSION=${VERSION} install
- ${LDCONFIG} -m ${PREFIX}/lib
+ ${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
@echo "**********"
@echo "IMPORTANT:"
@echo "**********"
@@ -59,6 +60,9 @@ post-install:
@echo "conflicting with another version of Tcl/Tks."
test:
- cd ${WRKSRC}; make test
+ cd ${WRKSRC}; ${SETENV} PORTOBJFORMAT=${PORTOBJFORMAT} ${MAKE} test
+
+install-man:
+ cd ${WRKSRC} && ${SETENV} PORTOBJFORMAT=${PORTOBJFORMAT} ${MAKE} install-man
.include <bsd.port.mk>