aboutsummaryrefslogtreecommitdiff
path: root/japanese/tomoe
diff options
context:
space:
mode:
authorHajimu UMEMOTO <ume@FreeBSD.org>2007-10-15 15:00:03 +0000
committerHajimu UMEMOTO <ume@FreeBSD.org>2007-10-15 15:00:03 +0000
commit3b9eacf7de65b8acbc23948875e921fea2be8e07 (patch)
treeb3f991a1156f6e8b05a799ab478fb622b3fd2170 /japanese/tomoe
parent2c7f71c1dc2fb57ef7fae5ea730680a00ddddee3 (diff)
downloadports-3b9eacf7de65b8acbc23948875e921fea2be8e07.tar.gz
ports-3b9eacf7de65b8acbc23948875e921fea2be8e07.zip
Notes
Diffstat (limited to 'japanese/tomoe')
-rw-r--r--japanese/tomoe/Makefile18
1 files changed, 16 insertions, 2 deletions
diff --git a/japanese/tomoe/Makefile b/japanese/tomoe/Makefile
index e03282f6b3e0..05d46cb678cb 100644
--- a/japanese/tomoe/Makefile
+++ b/japanese/tomoe/Makefile
@@ -30,14 +30,25 @@ BUILD_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/glib2.so:${PORTSDIR}/devel/ruby-glib2 \
RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/glib2.so:${PORTSDIR}/devel/ruby-glib2
# We cannot use ${ARCH} nor ${UNAME} which are defined in bsd.port.mk, here.
-UNAME= /usr/bin/uname
+UNAME?= /usr/bin/uname
ARCH!= ${UNAME} -p
+.if !defined(OSVERSION)
+AWK?= /usr/bin/awk
+SYSCTL?= /sbin/sysctl
+.if exists(/usr/include/sys/param.h)
+OSVERSION!= ${AWK} '/^\#define __FreeBSD_version/ {print $$3}' < /usr/include/sys/param.h
+.elif exists(/usr/src/sys/sys/param.h)
+OSVERSION!= ${AWK} '/^\#define __FreeBSD_version/ {print $$3}' < /usr/src/sys/sys/param.h
+.else
+OSVERSION!= ${SYSCTL} -n kern.osreldate
+.endif
+.endif
OPTIONS=DICT_RUBY "Enable Ruby based dictionary module" off \
EST "Enable Hyper Estraier dictionary module" off \
MYSQL "Enable MySQL dictionary module" off \
PYTHON "Enable Python module" on
-.if ${ARCH} == "sparc64"
+.if ${ARCH} == "sparc64" || ${OSVERSION} >= 700042
OPTIONS+=UNIHAN "Enable Unihan database dictionary module" off
.else
OPTIONS+=UNIHAN "Enable Unihan database dictionary module" on
@@ -78,6 +89,9 @@ PLIST_SUB+= PYTHON=""
.endif
.if defined(WITH_UNIHAN)
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with Unihan with gcc 4.2
+.endif
.if ${ARCH} == "sparc64"
BROKEN= Not buildable with Unihan on sparc64
.endif