aboutsummaryrefslogtreecommitdiff
path: root/japanese/tomoe
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-04-24 18:21:56 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-04-24 18:21:56 +0000
commit99fcbb24846a63d8e9d7361820e5d965da6af28a (patch)
tree38aefa44d423a9f6c408def8cdde615e590985fe /japanese/tomoe
parent687cff984dc04095f969b80e67a40349956686de (diff)
downloadports-99fcbb24846a63d8e9d7361820e5d965da6af28a.tar.gz
ports-99fcbb24846a63d8e9d7361820e5d965da6af28a.zip
Notes
Diffstat (limited to 'japanese/tomoe')
-rw-r--r--japanese/tomoe/Makefile40
-rw-r--r--japanese/tomoe/pkg-plist12
2 files changed, 12 insertions, 40 deletions
diff --git a/japanese/tomoe/Makefile b/japanese/tomoe/Makefile
index 9ea8763b4420..54614fabc51c 100644
--- a/japanese/tomoe/Makefile
+++ b/japanese/tomoe/Makefile
@@ -3,7 +3,7 @@
PORTNAME= tomoe
PORTVERSION= 0.6.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= japanese
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
@@ -12,35 +12,20 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= ume@FreeBSD.org
COMMENT= Tegaki Online MOji-ninshiki Engine
-USE_GNOME= lthack gnomehack
+BUILD_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
+
GNU_CONFIGURE= yes
-USES= gettext pkgconfig gmake perl5
+USES= gettext gmake libtool pathfix perl5 pkgconfig
USE_LDCONFIG= yes
-USE_RUBY= yes
USE_PERL5= build
-BUILD_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
-
-# We cannot use ${ARCH} nor ${UNAME} which are defined in bsd.port.mk, here.
-UNAME?= /usr/bin/uname
-ARCH!= ${UNAME} -p
-.if !defined(OSVERSION)
-AWK?= /usr/bin/awk
-SYSCTL?= /sbin/sysctl
-.if exists(/usr/include/sys/param.h)
-OSVERSION!= ${AWK} '/^\#define __FreeBSD_version/ {print $$3}' < /usr/include/sys/param.h
-.elif exists(/usr/src/sys/sys/param.h)
-OSVERSION!= ${AWK} '/^\#define __FreeBSD_version/ {print $$3}' < /usr/src/sys/sys/param.h
-.else
-OSVERSION!= ${SYSCTL} -n kern.osreldate
-.endif
-.endif
+CONFIGURE_ENV= PYTHON_VERSION=${PYTHON_VERSION:S;python;;} \
+ pyexecdir=${PYTHON_SITELIBDIR} \
+ GMSGFMT="${LOCALBASE}/bin/msgfmt"
+CFLAGS+= -I${LOCALBASE}/include
OPTIONS_DEFINE= DICT_RUBY EST MYSQL PYTHON RUBY UNIHAN
OPTIONS_DEFAULT= PYTHON
-.if ${ARCH} != "sparc64" && ${OSVERSION} < 700042
-OPTIONS_DEFAULT+= UNIHAN
-.endif
OPTIONS_SUB= yes
DICT_RUBY_DESC= Enable Ruby based dictionary module
DICT_RUBY_CONFIGURE_ENABLE= dict-ruby
@@ -62,7 +47,7 @@ RUBY_CFLAGS= -I${LOCALBASE}/include/ruby-${RUBY_VER} \
UNIHAN_DESC= Enable Unihan database dictionary module
UNIHAN_CONFIGURE_ENABLE= unihan
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MRUBY}
BROKEN= Broken with gem version of glib2
@@ -83,11 +68,6 @@ BUILD_DEPENDS+= \
${RUBY_SITELIBDIR}/suikyo/suikyo.rb:${PORTSDIR}/japanese/suikyo
.endif
-CONFIGURE_ENV+= PYTHON_VERSION=${PYTHON_VERSION:S;python;;} \
- pyexecdir=${PYTHON_SITELIBDIR} \
- GMSGFMT="${LOCALBASE}/bin/msgfmt"
-CFLAGS+= -I${LOCALBASE}/include
-
.if ${PORT_OPTIONS:MUNIHAN}
post-extract:
cd ${WRKSRC}/module/dict && \
@@ -101,4 +81,4 @@ post-patch:
${WRKSRC}/lib/tomoe.c \
${WRKSRC}/lib/glib-utils.h
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/japanese/tomoe/pkg-plist b/japanese/tomoe/pkg-plist
index 315a8d3217f8..587a7a69af7c 100644
--- a/japanese/tomoe/pkg-plist
+++ b/japanese/tomoe/pkg-plist
@@ -17,30 +17,23 @@ include/tomoe/tomoe-writing.h
include/tomoe/tomoe.h
@dirrmtry include/tomoe
lib/libtomoe.a
-lib/libtomoe.la
lib/libtomoe.so
-lib/libtomoe.so.1
+lib/libtomoe.so.0
+lib/libtomoe.so.0.1.0
%%PYTHON%%%%PYTHON_SITELIBDIR%%/tomoe.a
-%%PYTHON%%%%PYTHON_SITELIBDIR%%/tomoe.la
%%PYTHON%%%%PYTHON_SITELIBDIR%%/tomoe.so
%%EST%%lib/tomoe/module/dict/est.a
-%%EST%%lib/tomoe/module/dict/est.la
%%EST%%lib/tomoe/module/dict/est.so
%%MYSQL%%lib/tomoe/module/dict/mysql.a
-%%MYSQL%%lib/tomoe/module/dict/mysql.la
%%MYSQL%%lib/tomoe/module/dict/mysql.so
%%DICT_RUBY%%lib/tomoe/module/dict/ruby.a
-%%DICT_RUBY%%lib/tomoe/module/dict/ruby.la
%%DICT_RUBY%%lib/tomoe/module/dict/ruby.so
%%UNIHAN%%lib/tomoe/module/dict/unihan.a
-%%UNIHAN%%lib/tomoe/module/dict/unihan.la
%%UNIHAN%%lib/tomoe/module/dict/unihan.so
lib/tomoe/module/dict/xml.a
-lib/tomoe/module/dict/xml.la
lib/tomoe/module/dict/xml.so
@dirrm lib/tomoe/module/dict
lib/tomoe/module/recognizer/simple.a
-lib/tomoe/module/recognizer/simple.la
lib/tomoe/module/recognizer/simple.so
@dirrm lib/tomoe/module/recognizer
@dirrm lib/tomoe/module
@@ -84,6 +77,5 @@ share/tomoe/xml2est.rb
@dirrm share/tomoe
%%RUBY%%%%RUBY_SITEARCHLIBDIR%%/rbtomoe.h
%%RUBY%%%%RUBY_SITEARCHLIBDIR%%/tomoe.a
-%%RUBY%%%%RUBY_SITEARCHLIBDIR%%/tomoe.la
%%RUBY%%%%RUBY_SITEARCHLIBDIR%%/tomoe.so
%%RUBY%%%%RUBY_SITELIBDIR%%/tomoe.rb