aboutsummaryrefslogtreecommitdiff
path: root/japanese/tomoe
diff options
context:
space:
mode:
authorHajimu UMEMOTO <ume@FreeBSD.org>2006-12-17 08:00:23 +0000
committerHajimu UMEMOTO <ume@FreeBSD.org>2006-12-17 08:00:23 +0000
commit57f6de19bde48650c8283b7203cbd8e156e00b80 (patch)
tree1f5644a65a0bfa576ceb29707eb6ff1a7cbe2114 /japanese/tomoe
parentae24171e8a2e486add72fda67e7e719f9266aee1 (diff)
Notes
Diffstat (limited to 'japanese/tomoe')
-rw-r--r--japanese/tomoe/Makefile15
-rw-r--r--japanese/tomoe/distinfo6
-rw-r--r--japanese/tomoe/files/patch-lib::tomoe.c41
-rw-r--r--japanese/tomoe/files/patch-src::match.c17
-rw-r--r--japanese/tomoe/pkg-plist61
5 files changed, 69 insertions, 71 deletions
diff --git a/japanese/tomoe/Makefile b/japanese/tomoe/Makefile
index d3f511047989..a38c60d2e483 100644
--- a/japanese/tomoe/Makefile
+++ b/japanese/tomoe/Makefile
@@ -6,24 +6,19 @@
#
PORTNAME= tomoe
-PORTVERSION= 0.2.1
-PORTREVISION= 1
+PORTVERSION= 0.4.0
+#PORTREVISION= 0
CATEGORIES= japanese
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_JP}
-MASTER_SITE_SUBDIR=tomoe/16048
+MASTER_SITE_SUBDIR=tomoe/22893
MAINTAINER= ume@FreeBSD.org
COMMENT= Tegaki Online MOji-ninshiki Engine
USE_GNOME= lthack gnomehack
USE_AUTOTOOLS= libtool:15
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
-PLIST_DIRS= include/tomoe share/tomoe
-PLIST_FILES= bin/tomoe bin/tomoe1 include/tomoe/tomoe.h \
- lib/libtomoe.a lib/libtomoe.la \
- lib/libtomoe.so lib/libtomoe.so.1 \
- libdata/pkgconfig/tomoe.pc \
- share/tomoe/all.tdic share/tomoe/hiragana.tdic
+CONFIGURE_ENV+= CFLAGS="${CFLAGS} -I${LOCALBASE}/include"
.include <bsd.port.mk>
diff --git a/japanese/tomoe/distinfo b/japanese/tomoe/distinfo
index a3aaea6ccb80..5eec779ecdf1 100644
--- a/japanese/tomoe/distinfo
+++ b/japanese/tomoe/distinfo
@@ -1,3 +1,3 @@
-MD5 (tomoe-0.2.1.tar.gz) = 95eca127a1d519ff4e836b3d00d7fa84
-SHA256 (tomoe-0.2.1.tar.gz) = 3942e0ff0a3b945d0464b69fcc01092a582f2c4e173bd8877572706e584e0e9e
-SIZE (tomoe-0.2.1.tar.gz) = 574453
+MD5 (tomoe-0.4.0.tar.gz) = 239a78420d35f107c5ec9edd2fcf474a
+SHA256 (tomoe-0.4.0.tar.gz) = eee687c7b9b54d3c2b7d856b66a15275e71b45f7bf58d04cca8494f26ea1edc6
+SIZE (tomoe-0.4.0.tar.gz) = 2422289
diff --git a/japanese/tomoe/files/patch-lib::tomoe.c b/japanese/tomoe/files/patch-lib::tomoe.c
deleted file mode 100644
index 3d19a4ef2215..000000000000
--- a/japanese/tomoe/files/patch-lib::tomoe.c
+++ /dev/null
@@ -1,41 +0,0 @@
-Index: lib/tomoe.c
-diff -u -p lib/tomoe.c.orig lib/tomoe.c
---- lib/tomoe.c.orig Thu Aug 11 11:34:32 2005
-+++ lib/tomoe.c Mon Dec 19 03:31:30 2005
-@@ -150,9 +150,9 @@ tomoe_get_matched (glyph *input, candida
- {
- candidate_private *cand;
- int_array *adapted;
-+ int pj;
- cand = cands->p[i];
- adapted = cand->adapted_strokes;
-- int pj;
-
- pj = match_stroke_num(cand->index, input->stroke_num, adapted);
-
-@@ -471,13 +471,14 @@ load_dictionaries (void)
- stroke *strk = NULL;
- point *pnt = NULL;
- char line_buf[LINE_BUF_SIZE];
-+ FILE *fp;
-
- if (g_dict) return;
-
- g_dict = calloc (1, sizeof(dictionary));
- dictionary_alloc_contents (g_dict, DICT_LETTER_INITIAL_SIZE);
-
-- FILE *fp = fopen (TOMOEDATADIR "/all.tdic", "r");
-+ fp = fopen (TOMOEDATADIR "/all.tdic", "r");
- while ((p = fgets (line_buf, LINE_BUF_SIZE, fp)) != NULL)
- {
- if (p[0] == '\n')
-@@ -766,8 +767,8 @@ get_candidates(stroke *input_stroke, poi
- for (cand_index = 0; cand_index < cands->len; cand_index++)
- {
- tomoe_bool match_flag;
-- match_flag = FALSE;
- int_array *adapted = NULL;
-+ match_flag = FALSE;
- cand = cands->p[cand_index];
-
- adapted = int_array_copy (cand->adapted_strokes);
diff --git a/japanese/tomoe/files/patch-src::match.c b/japanese/tomoe/files/patch-src::match.c
deleted file mode 100644
index 11778ad5a839..000000000000
--- a/japanese/tomoe/files/patch-src::match.c
+++ /dev/null
@@ -1,17 +0,0 @@
-Index: src/match.c
-diff -u -p src/match.c.orig src/match.c
---- src/match.c.orig Mon Dec 27 13:36:00 2004
-+++ src/match.c Mon Dec 19 03:33:58 2005
-@@ -547,10 +547,11 @@ load_data ()
- letter *lttr = NULL;
- stroke *strk = NULL;
- point *pnt = NULL;
-+ FILE *fp;
-
- dictionary_alloc_contents(&dict, DICT_LETTER_INITIAL_SIZE);
-
-- FILE *fp = fopen(TOMOEDATADIR "/all.tdic", "r");
-+ fp = fopen(TOMOEDATADIR "/all.tdic", "r");
- while ((p = fgets(line_buf, LINE_BUF_SIZE, fp)) != NULL)
- {
- if (p[0] == '\n')
diff --git a/japanese/tomoe/pkg-plist b/japanese/tomoe/pkg-plist
new file mode 100644
index 000000000000..6dfbe846aea1
--- /dev/null
+++ b/japanese/tomoe/pkg-plist
@@ -0,0 +1,61 @@
+etc/tomoe/config
+@dirrm etc/tomoe
+include/tomoe/tomoe-candidate.h
+include/tomoe/tomoe-char.h
+include/tomoe/tomoe-config.h
+include/tomoe/tomoe-context.h
+include/tomoe/tomoe-dict.h
+include/tomoe/tomoe-enum-types.h
+include/tomoe/tomoe-module-impl.h
+include/tomoe/tomoe-module.h
+include/tomoe/tomoe-query.h
+include/tomoe/tomoe-reading.h
+include/tomoe/tomoe-recognizer.h
+include/tomoe/tomoe-shelf.h
+include/tomoe/tomoe-writing.h
+include/tomoe/tomoe.h
+@dirrmtry include/tomoe
+lib/libtomoe.a
+lib/libtomoe.la
+lib/libtomoe.so
+lib/libtomoe.so.1
+lib/tomoe/dict/libxml.a
+lib/tomoe/dict/libxml.la
+lib/tomoe/dict/libxml.so
+lib/tomoe/dict/libxml.so.1
+@dirrm lib/tomoe/dict
+lib/tomoe/recognizer/libsimple.a
+lib/tomoe/recognizer/libsimple.la
+lib/tomoe/recognizer/libsimple.so
+lib/tomoe/recognizer/libsimple.so.1
+@dirrm lib/tomoe/recognizer
+@dirrm lib/tomoe
+libdata/pkgconfig/tomoe.pc
+share/gtk-doc/html/tomoe/TomoeCandidate.html
+share/gtk-doc/html/tomoe/TomoeChar.html
+share/gtk-doc/html/tomoe/TomoeConfig.html
+share/gtk-doc/html/tomoe/TomoeContext.html
+share/gtk-doc/html/tomoe/TomoeDict.html
+share/gtk-doc/html/tomoe/TomoeQuery.html
+share/gtk-doc/html/tomoe/TomoeReading.html
+share/gtk-doc/html/tomoe/TomoeShelf.html
+share/gtk-doc/html/tomoe/TomoeWriting.html
+share/gtk-doc/html/tomoe/home.png
+share/gtk-doc/html/tomoe/index.html
+share/gtk-doc/html/tomoe/index.sgml
+share/gtk-doc/html/tomoe/ix01.html
+share/gtk-doc/html/tomoe/left.png
+share/gtk-doc/html/tomoe/right.png
+share/gtk-doc/html/tomoe/style.css
+share/gtk-doc/html/tomoe/tomoe-tomoe.html
+share/gtk-doc/html/tomoe/tomoe.devhelp
+share/gtk-doc/html/tomoe/tomoe.devhelp2
+share/gtk-doc/html/tomoe/tomoe.html
+share/gtk-doc/html/tomoe/up.png
+@dirrm share/gtk-doc/html/tomoe
+@dirrmtry share/gtk-doc/html
+@dirrmtry share/gtk-doc
+share/tomoe/all.xml
+share/tomoe/kanjidic2.xml
+share/tomoe/tomoe-dict.dtd
+@dirrm share/tomoe