aboutsummaryrefslogtreecommitdiff
path: root/japanese/uim-anthy
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2006-06-12 17:45:54 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2006-06-12 17:45:54 +0000
commit89abb4bc3d764f8612073e05cb0e5d16433e3786 (patch)
tree5cba7e6e3ce1e5d3018f7c59ea6d2df416458343 /japanese/uim-anthy
parent831af5fc466c737116b030a1b4f31213c126137a (diff)
downloadports-89abb4bc3d764f8612073e05cb0e5d16433e3786.tar.gz
ports-89abb4bc3d764f8612073e05cb0e5d16433e3786.zip
Notes
Diffstat (limited to 'japanese/uim-anthy')
-rw-r--r--japanese/uim-anthy/Makefile18
-rw-r--r--japanese/uim-anthy/pkg-plist1
2 files changed, 15 insertions, 4 deletions
diff --git a/japanese/uim-anthy/Makefile b/japanese/uim-anthy/Makefile
index 2153c2a7c7e5..e0354edc3e7b 100644
--- a/japanese/uim-anthy/Makefile
+++ b/japanese/uim-anthy/Makefile
@@ -10,20 +10,30 @@ PKGNAMESUFFIX= -anthy
COMMENT= Uim plugin using Anthy input method
+USE_GNOME= gtk20
+
RUN_DEPENDS= uim-module-manager:${PORTSDIR}/textproc/uim
LIB_DEPENDS= anthy.1:${PORTSDIR}/japanese/anthy
MASTERDIR= ${.CURDIR}/../../textproc/uim
PKGDIR= ${.CURDIR}
-CONFIGURE_ARGS= --with-anthy
+CONFIGURE_ARGS= --with-anthy --with-gtk2 --enable-dict
UIM_SLAVE= yes
+EXTRA_PATCHES= ${PATCHDIR}/extra-patch-uim_Makefile.in \
+ ${PATCHDIR}/extra-patch-helper_Makefile.in
+
+do-build:
+ (cd ${WRKSRC}/uim && ${GMAKE} libuim-anthy.la)
+ (cd ${WRKSRC}/helper && ${GMAKE} LIBS="-luim" uim-dict-gtk)
+
do-install:
- cd ${WRKSRC}/uim && \
- ${GMAKE} uim_plugin_LTLIBRARIES=libuim-anthy.la install-uim_pluginLTLIBRARIES
+ (cd ${WRKSRC}/uim && \
+ ${GMAKE} uim_plugin_LTLIBRARIES=libuim-anthy.la install-uim_pluginLTLIBRARIES)
+ (cd ${WRKSRC}/helper && ${GMAKE} bin_PROGRAMS=uim-dict-gtk install-binPROGRAMS)
post-install:
- uim-module-manager --register anthy
+ ${X11BASE}/bin/uim-module-manager --register anthy
.include "${MASTERDIR}/Makefile"
diff --git a/japanese/uim-anthy/pkg-plist b/japanese/uim-anthy/pkg-plist
index 142c7dc68c43..c84f90800556 100644
--- a/japanese/uim-anthy/pkg-plist
+++ b/japanese/uim-anthy/pkg-plist
@@ -1,3 +1,4 @@
+bin/uim-dict-gtk
lib/uim/plugin/libuim-anthy.a
lib/uim/plugin/libuim-anthy.la
lib/uim/plugin/libuim-anthy.so