aboutsummaryrefslogtreecommitdiff
path: root/japanese/umefont
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2008-05-25 08:01:38 +0000
committerHiroki Sato <hrs@FreeBSD.org>2008-05-25 08:01:38 +0000
commit3b7c609a709489355dfe059a611f9acf91156289 (patch)
tree01c765fb55d0899c3c5a68a3415492e671162f5e /japanese/umefont
parentb93f152945ccabfd87b4a7fe37bea6483167e6f6 (diff)
downloadports-3b7c609a709489355dfe059a611f9acf91156289.tar.gz
ports-3b7c609a709489355dfe059a611f9acf91156289.zip
Notes
Diffstat (limited to 'japanese/umefont')
-rw-r--r--japanese/umefont/Makefile58
-rw-r--r--japanese/umefont/distinfo3
-rw-r--r--japanese/umefont/files/20-unhint-umefont.conf24
-rw-r--r--japanese/umefont/files/62-fonts-umefont.conf39
-rw-r--r--japanese/umefont/files/pkg-install.in97
-rw-r--r--japanese/umefont/pkg-descr3
-rw-r--r--japanese/umefont/pkg-plist51
7 files changed, 275 insertions, 0 deletions
diff --git a/japanese/umefont/Makefile b/japanese/umefont/Makefile
new file mode 100644
index 000000000000..fda5ba1ad808
--- /dev/null
+++ b/japanese/umefont/Makefile
@@ -0,0 +1,58 @@
+# New ports collection makefile for: umefont
+# Date created: 25 May 2008
+# Whom: hrs
+#
+# $FreeBSD$
+#
+
+PORTNAME= umefont
+PORTVERSION= 0.0.389
+CATEGORIES= japanese x11-fonts
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_JP}
+MASTER_SITE_SUBDIR= ume-font/22212
+DISTNAME= ${PORTNAME}-389
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= Ume Font, A Free Japanese TrueType font
+
+RUN_DEPENDS= fc-cache:${PORTSDIR}/x11-fonts/fontconfig
+
+NO_BUILD= yes
+PKGINSTALL= ${WRKDIR}/pkg-install
+PKGDEINSTALL= ${WRKDIR}/pkg-install
+SUB_FILES= pkg-install
+SUB_LIST= X_FONTSDIR=${PREFIX}/${X_FONTSDIR}
+PLIST_SUB= X_FONTSDIR=${X_FONTSDIR} \
+ LOCAL_FONTSDIR=${LOCAL_FONTSDIR}
+PORTDOCS= readme.html
+
+LOCAL_FONTSDIR= share/fonts
+X_FONTSDIR= lib/X11/fonts
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${WRKSRC}
+ ${INSTALL_DATA} ${WRKSRC}/*.ttf ${DATADIR}
+ ${MKDIR} ${LOCALBASE}/${LOCAL_FONTSDIR}/TrueType/
+ ${LN} -s -f \
+ ${DATADIR}/*.ttf ${LOCALBASE}/${LOCAL_FONTSDIR}/TrueType/
+ ${MKDIR} ${LOCALBASE}/${X_FONTSDIR}/TrueType
+ ${LN} -s -f \
+ ${DATADIR}/*.ttf ${LOCALBASE}/${X_FONTSDIR}/TrueType/
+ ${INSTALL_DATA} ${FILESDIR}/20-unhint-umefont.conf \
+ ${FILESDIR}/62-fonts-umefont.conf \
+ ${PREFIX}/etc/fonts/conf.avail
+ ${LN} -s -f ../conf.avail/20-unhint-umefont.conf \
+ ${PREFIX}/etc/fonts/conf.d/20-unhint-umefont.conf
+ ${LN} -s -f ../conf.avail/62-fonts-umefont.conf \
+ ${PREFIX}/etc/fonts/conf.d/62-fonts-umefont.conf
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${CP} -R ${PORTDOCS} ${DOCSDIR}
+.endif
+
+post-install:
+ ${LOCALBASE}/bin/fc-cache -f -v ${LOCALBASE}/${X_FONTSDIR}/TrueType
+ ${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+
+.include <bsd.port.mk>
diff --git a/japanese/umefont/distinfo b/japanese/umefont/distinfo
new file mode 100644
index 000000000000..d2cad37c5731
--- /dev/null
+++ b/japanese/umefont/distinfo
@@ -0,0 +1,3 @@
+MD5 (umefont-389.tar.gz) = 7ca0cf4581e4e84a94ab2dad193d79bc
+SHA256 (umefont-389.tar.gz) = 057cb1e62ab4e58db882f600d57c85a107b6678e4b4b72a8b5651ea1b6ee7f81
+SIZE (umefont-389.tar.gz) = 32571503
diff --git a/japanese/umefont/files/20-unhint-umefont.conf b/japanese/umefont/files/20-unhint-umefont.conf
new file mode 100644
index 000000000000..54b9796d27db
--- /dev/null
+++ b/japanese/umefont/files/20-unhint-umefont.conf
@@ -0,0 +1,24 @@
+<?xml version="1.0"?>
+<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
+<!-- $FreeBSD$ -->
+<fontconfig>
+ <match target="font">
+ <test name="family">
+ <string>Ume Mincho</string>
+ <string>Ume P Mincho</string>
+ <string>Ume Gothic</string>
+ <string>Ume Gothic C4</string>
+ <string>Ume Gothic C5</string>
+ <string>Ume Gothic O5</string>
+ <string>Ume P Gothic</string>
+ <string>Ume P Gothic C4</string>
+ <string>Ume P Gothic C5</string>
+ <string>Ume P Gothic O5</string>
+ <string>Ume UI Gothic</string>
+ <string>Ume UI Gothic O5</string>
+ </test>
+ <edit name="autohint">
+ <bool>false</bool>
+ </edit>
+ </match>
+</fontconfig>
diff --git a/japanese/umefont/files/62-fonts-umefont.conf b/japanese/umefont/files/62-fonts-umefont.conf
new file mode 100644
index 000000000000..a9a6feaf2365
--- /dev/null
+++ b/japanese/umefont/files/62-fonts-umefont.conf
@@ -0,0 +1,39 @@
+<?xml version="1.0"?>
+<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
+<!-- $FreeBSD$ -->
+<fontconfig>
+ <alias>
+ <family>serif</family>
+ <prefer>
+ <family>Ume Mincho</family>
+ <family>Ume P Mincho</family>
+ </prefer>
+ </alias>
+ <alias>
+ <family>sans-serif</family>
+ <prefer>
+ <family>Ume Gothic</family>
+ <family>Ume Gothic C4</family>
+ <family>Ume Gothic C5</family>
+ <family>Ume Gothic O5</family>
+ <family>Ume P Gothic</family>
+ <family>Ume P Gothic C4</family>
+ <family>Ume P Gothic C5</family>
+ <family>Ume P Gothic O5</family>
+ <family>Ume UI Gothic</family>
+ <family>Ume UI Gothic O5</family>
+ </prefer>
+ </alias>
+ <alias>
+ <family>monospace</family>
+ <prefer>
+ <family>Ume Mincho</family>
+ <family>Ume Gothic</family>
+ <family>Ume Gothic C4</family>
+ <family>Ume Gothic C5</family>
+ <family>Ume Gothic O5</family>
+ <family>Ume UI Gothic</family>
+ <family>Ume UI Gothic O5</family>
+ </prefer>
+ </alias>
+</fontconfig>
diff --git a/japanese/umefont/files/pkg-install.in b/japanese/umefont/files/pkg-install.in
new file mode 100644
index 000000000000..d213f8e72bc8
--- /dev/null
+++ b/japanese/umefont/files/pkg-install.in
@@ -0,0 +1,97 @@
+#!/bin/sh
+# $FreeBSD$
+
+X_FONTSDIR=%%X_FONTSDIR%%/TrueType
+
+catfontsdir ()
+{
+ while read _IN
+ do
+ case "${_IN}" in
+ *-ume-*|[0-9]*|"") ;;
+ *) echo ${_IN} ;;
+ esac
+ done
+}
+
+ROMA=""
+BOLD="ds=y"
+ITAL="ai=0.15"
+OBLI="ai=0.15"
+RITA="ai=0.08"
+ROBL="ai=0.08"
+
+make_xlfd()
+{
+ _enc=$1
+ _file=$2
+ _vendor=$3
+ _fname=$4
+ _poc=$5
+
+ case "${_poc}:${_enc}" in
+ p:jisx0201.1976-*) PFIX="fp=y:bw=0.5" ;;
+ c:jisx0201.1976-*) PFIX="fp=n:bw=0.5" ;;
+ p:*) PFIX="fp=y" ;;
+ c:*) PFIX="fp=n" ;;
+ esac
+
+ set -- "${ROMA}" medium-r \
+ ${BOLD} bold-r \
+ ${ITAL} medium-i \
+ ${ITAL}:${BOLD} bold-i \
+ ${OBLI} medium-o \
+ ${OBLI}:${BOLD} bold-o \
+ ${RITA} medium-ri \
+ ${RITA}:${BOLD} bold-ri \
+ ${ROBL} medium-ro \
+ ${ROBL}:${BOLD} bold-ro
+ while [ $# != 0 ]; do
+ _prefix="${PFIX}:$1"; shift
+ _variant=$1; shift
+ printf "%s:%s -%s-%s-%s-normal--0-0-0-0-%s-0-%s\n" \
+ $_prefix $_file $_vendor $_fname $_variant $_poc $_enc
+ done | sed -e 's,::,:,g' -e 's,^:,,'
+}
+
+addentries ()
+{
+ for ENC in iso8859-1 iso10646-1 jisx0201.1976-0 jisx0208.1983-0 jisx0208.1990-0
+ do
+ make_xlfd $ENC ume-pgc4.ttf ume gothic_c4 p
+ make_xlfd $ENC ume-pgc5.ttf ume gothic_c5 p
+ make_xlfd $ENC ume-pgo5.ttf ume gothic_o5 p
+ make_xlfd $ENC ume-pgo4.ttf ume gothic p
+ make_xlfd $ENC ume-tgc4.ttf ume gothic_c4 c
+ make_xlfd $ENC ume-tgc5.ttf ume gothic_c5 c
+ make_xlfd $ENC ume-tgo5.ttf ume gothic_o5 c
+ make_xlfd $ENC ume-tgo4.ttf ume gothic c
+ make_xlfd $ENC ume-ugo4.ttf ume ui_gothic c
+ make_xlfd $ENC ume-ugo5.ttf ume ui_gothic_o5 c
+ make_xlfd $ENC ume-tmo3.ttf ume mincho c
+ make_xlfd $ENC ume-pmo3.ttf ume mincho p
+ done
+}
+
+nfonts ()
+{
+ _L=0; while read _IN; do _L=$((${_L}+1)); done; echo ${_L}
+}
+
+case "$2" in
+POST-INSTALL)
+ cd ${X_FONTSDIR}
+ touch fonts.dir
+ (catfontsdir < fonts.dir; addentries) > fonts.dir.tmp
+ nfonts < fonts.dir.tmp > fonts.dir
+ cat fonts.dir.tmp >> fonts.dir
+ rm -f fonts.dir.tmp
+ ;;
+DEINSTALL)
+ cd ${X_FONTSDIR}
+ catfontsdir < fonts.dir > fonts.dir.tmp
+ nfonts < fonts.dir.tmp > fonts.dir
+ cat fonts.dir.tmp >> fonts.dir
+ rm -f fonts.dir.tmp
+ ;;
+esac
diff --git a/japanese/umefont/pkg-descr b/japanese/umefont/pkg-descr
new file mode 100644
index 000000000000..3903150c0d6f
--- /dev/null
+++ b/japanese/umefont/pkg-descr
@@ -0,0 +1,3 @@
+UmeFont is a free Japanese TrueType font.
+
+WWW: http://sourceforge.jp/projects/ume-font/wiki/FrontPage
diff --git a/japanese/umefont/pkg-plist b/japanese/umefont/pkg-plist
new file mode 100644
index 000000000000..2a02c72f553f
--- /dev/null
+++ b/japanese/umefont/pkg-plist
@@ -0,0 +1,51 @@
+@comment $FreeBSD$
+%%DATADIR%%/ume-pgc4.ttf
+%%DATADIR%%/ume-pgc5.ttf
+%%DATADIR%%/ume-pgo4.ttf
+%%DATADIR%%/ume-pgo5.ttf
+%%DATADIR%%/ume-pmo3.ttf
+%%DATADIR%%/ume-tgc4.ttf
+%%DATADIR%%/ume-tgc5.ttf
+%%DATADIR%%/ume-tgo4.ttf
+%%DATADIR%%/ume-tgo5.ttf
+%%DATADIR%%/ume-tmo3.ttf
+%%DATADIR%%/ume-ugo4.ttf
+%%DATADIR%%/ume-ugo5.ttf
+@dirrm %%DATADIR%%
+%%LOCAL_FONTSDIR%%/TrueType/ume-pgc4.ttf
+%%LOCAL_FONTSDIR%%/TrueType/ume-pgc5.ttf
+%%LOCAL_FONTSDIR%%/TrueType/ume-pgo4.ttf
+%%LOCAL_FONTSDIR%%/TrueType/ume-pgo5.ttf
+%%LOCAL_FONTSDIR%%/TrueType/ume-pmo3.ttf
+%%LOCAL_FONTSDIR%%/TrueType/ume-tgc4.ttf
+%%LOCAL_FONTSDIR%%/TrueType/ume-tgc5.ttf
+%%LOCAL_FONTSDIR%%/TrueType/ume-tgo4.ttf
+%%LOCAL_FONTSDIR%%/TrueType/ume-tgo5.ttf
+%%LOCAL_FONTSDIR%%/TrueType/ume-tmo3.ttf
+%%LOCAL_FONTSDIR%%/TrueType/ume-ugo4.ttf
+%%LOCAL_FONTSDIR%%/TrueType/ume-ugo5.ttf
+@dirrmtry %%LOCAL_FONTSDIR%%/TrueType
+@dirrmtry %%LOCAL_FONTSDIR%%
+etc/fonts/conf.avail/20-unhint-umefont.conf
+etc/fonts/conf.avail/62-fonts-umefont.conf
+@exec ln -s -f ../conf.avail/20-unhint-umefont.conf %D/etc/fonts/conf.d/20-unhint-umefont.conf
+@exec ln -s -f ../conf.avail/62-fonts-umefont.conf %D/etc/fonts/conf.d/62-fonts-umefont.conf
+@unexec rm -f %D/etc/fonts/conf.d/20-unhint-umefont.conf
+@unexec rm -f %D/etc/fonts/conf.d/62-fonts-umefont.conf
+%%X_FONTSDIR%%/TrueType/ume-pgc4.ttf
+%%X_FONTSDIR%%/TrueType/ume-pgc5.ttf
+%%X_FONTSDIR%%/TrueType/ume-pgo4.ttf
+%%X_FONTSDIR%%/TrueType/ume-pgo5.ttf
+%%X_FONTSDIR%%/TrueType/ume-pmo3.ttf
+%%X_FONTSDIR%%/TrueType/ume-tgc4.ttf
+%%X_FONTSDIR%%/TrueType/ume-tgc5.ttf
+%%X_FONTSDIR%%/TrueType/ume-tgo4.ttf
+%%X_FONTSDIR%%/TrueType/ume-tgo5.ttf
+%%X_FONTSDIR%%/TrueType/ume-tmo3.ttf
+%%X_FONTSDIR%%/TrueType/ume-ugo4.ttf
+%%X_FONTSDIR%%/TrueType/ume-ugo5.ttf
+@exec %%LOCALBASE%%/bin/fc-cache -f -v %D/%%X_FONTSDIR%%/TrueType || true
+@unexec %%LOCALBASE%%/bin/fc-cache -f -v %D/%%X_FONTSDIR%%/TrueType || true
+@unexec rm -f %D/%%X_FONTSDIR%%/TrueType/fonts.cache-1
+@dirrmtry %%X_FONTSDIR%%/TrueType
+@unexec if [ -d %D/%%X_FONTSDIR%%/TrueType ]; then %%LOCALBASE%%/bin/fc-cache -f -v %D/%%X_FONTSDIR%%/TrueType || true; fi