aboutsummaryrefslogtreecommitdiff
path: root/japanese/xchat
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-09-03 17:00:00 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-09-03 17:00:00 +0000
commit7ab6aae6ba7585d0b61828df1bdb314b74f918bb (patch)
tree869c1ee84791b42a067d763bd2485e2006226ba9 /japanese/xchat
parentb3277240096934e1544915d39fb949eadfa1dcf6 (diff)
downloadports-7ab6aae6ba7585d0b61828df1bdb314b74f918bb.tar.gz
ports-7ab6aae6ba7585d0b61828df1bdb314b74f918bb.zip
Notes
Diffstat (limited to 'japanese/xchat')
-rw-r--r--japanese/xchat/Makefile104
-rw-r--r--japanese/xchat/distinfo3
-rw-r--r--japanese/xchat/files/patch-aa10
-rw-r--r--japanese/xchat/pkg-plist18
4 files changed, 75 insertions, 60 deletions
diff --git a/japanese/xchat/Makefile b/japanese/xchat/Makefile
index 0d403439a6b3..1f2a20c598ff 100644
--- a/japanese/xchat/Makefile
+++ b/japanese/xchat/Makefile
@@ -6,81 +6,75 @@
#
PORTNAME= xchat
-PORTVERSION= 1.4.3
-PORTREVISION= 2
-CATEGORIES= japanese irc gnome
-MASTER_SITES= http://xchat.org/files/source/1.4/ \
- http://xchat.linuxpower.org/files/source/1.4/
-
-PATCH_SITES= http://northeye.org/~takuo/xchat-ja/
-PATCHFILES= ${PORTNAME}-${PORTVERSION}.ja.3.diff.gz
-PATCH_DIST_STRIP= -p1
+PORTVERSION= 1.8.2
+CATEGORIES+= irc gnome ipv6
+MASTER_SITES= http://xchat.org/files/source/1.8/ \
+ http://xchat.linuxpower.org/files/source/1.8/
MAINTAINER= knu@FreeBSD.org
-LIB_DEPENDS= iconv.2:${PORTSDIR}/converters/iconv
-RUN_DEPENDS= ${LOCALBASE}/libexec/iconv/iso-2022-jp.so:${PORTSDIR}/converters/iconv-extra
+BUILD_DEPENDS= msgfmt-new:${PORTSDIR}/devel/gettext-devel
+LIB_DEPENDS= giconv.2:${PORTSDIR}/converters/libiconv
+
+# <ja-specific>
+CATEGORIES:= japanese ${CATEGORIES}
-MASTERDIR= ${.CURDIR}/../../irc/xchat
-MD5_FILE= ${.CURDIR}/distinfo
-PLIST= ${.CURDIR}/pkg-plist
+#EXTRA_PATCHES= ${.CURDIR}/files/patch-aa
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --enable-japanese-conv
-MAKE_ARGS= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -liconv -lintl"
-# begin master part
-USE_X_PREFIX= yes
-USE_BZIP2= yes
-USE_GMAKE= yes
-USE_PERL5= yes
-USE_IMLIB= yes
-WANT_GNOME= yes
-GNU_CONFIGURE= yes
+COMMENT= ${.CURDIR}/../../irc/xchat/pkg-comment
+DESCR= ${.CURDIR}/../../irc/xchat/pkg-descr
+# </ja-specific>
+
+USE_X_PREFIX= yes
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_PERL5= yes
+USE_IMLIB= yes
+WANT_GNOME= yes
+GNU_CONFIGURE= yes
# Assign with `+=' for slave ports
-CONFIGURE_ARGS+=--disable-python
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib -lintl -lgiconv" \
+ MSGFMT=${LOCALBASE}/bin/msgfmt-new
+CONFIGURE_ARGS+= --disable-python \
+ --without-included-gettext \
+ --enable-nls \
+ --enable-ipv6
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 400014
-CATEGORIES+= ipv6
-CONFIGURE_ARGS+=--enable-ipv6
-.endif
-
.if defined(WITH_SOCKS)
# Assign with `+=' for slave ports
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libsocks5.a:${PORTSDIR}/net/socks5
-CONFIGURE_ARGS+=--enable-socks
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libsocks5.a:${PORTSDIR}/net/socks5
+CONFIGURE_ARGS+= --enable-socks
+.endif
+
+.if defined(WITH_SSL)
+USE_OPENSSL= YES
+CONFIGURE_ARGS+= --enable-openssl
.endif
.if defined(HAVE_GNOME)
-USE_GNOME= yes
-CONFIGURE_ARGS+=--enable-gnome --enable-panel --enable-gdk-pixbuf
+USE_GNOME= yes
+CONFIGURE_ARGS+= --enable-gnome --enable-panel --enable-gdk-pixbuf
.else
-CONFIGURE_ARGS+=--disable-gnome --disable-gdk-pixbuf
+CONFIGURE_ARGS+= --disable-gnome --disable-gdk-pixbuf
.endif
-# end master part
-pre-patch:
- ${PERL} -i -pe 's/-b&h-lucidatypewriter-medium-r-normal-\*-\*-120-\*-\*-m-\*-\*-\*/$$&,-default-*ng-medium-r-normal--14-*,*/' ${WRKSRC}/src/common/cfgfiles.c
-
-# begin master part
post-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
- s|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|g ; \
- s|\$$\(top_builddir\)/intl/libintl.a|-lintl|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$$\(datadir\)/gnome/|\$$\(datadir\)/|g ; \
- s|\$$\(datadir\)/locale|\$$\(prefix\)/share/locale|g'
-# end master part
-
-pre-build:
- ${TOUCH} ${WRKSRC}/aclocal.m4 ${WRKSRC}/Makefile.in ${WRKSRC}/configure ${WRKSRC}/config.status
+ @${PERL} -pi \
+ -e 's|-lpthread|${PTHREAD_LIBS}|g;' \
+ -e 's|DATADIRNAME=lib|DATADIRNAME=share|g;' \
+ -e 's|iconv|giconv|;' \
+ ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi \
+ -e 's|\$$\(datadir\)/gnome/|\$$\(datadir\)/|g;' \
+ -e 's|\$$\(datadir\)/locale|\$$\(prefix\)/share/locale|g;'
+ @${PERL} -pi -e 's|iconv\.h|giconv.h|;' \
+ ${WRKSRC}/src/common/jcode.c
-# begin master part
post-install:
.if !defined(NOPORTDOCS)
@${ECHO_MSG} "===> Installing xchat docs in ${PREFIX}/share/doc/xchat"
@@ -89,7 +83,5 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/xchat
${INSTALL_DATA} ${WRKSRC}/ChangeLog ${PREFIX}/share/doc/xchat
.endif
-# end master part
.include <bsd.port.post.mk>
-#.include "${MASTERDIR}/Makefile"
diff --git a/japanese/xchat/distinfo b/japanese/xchat/distinfo
index 9117eb8ccd02..576149e162a7 100644
--- a/japanese/xchat/distinfo
+++ b/japanese/xchat/distinfo
@@ -1,2 +1 @@
-MD5 (xchat-1.4.3.tar.bz2) = 268ee72a8a58c323e838f72ebfc58cd6
-MD5 (xchat-1.4.3.ja.3.diff.gz) = 06c66673eb980eb6a85e73679333f014
+MD5 (xchat-1.8.2.tar.bz2) = 51987e6e79d0e902e1928918fdd7b353
diff --git a/japanese/xchat/files/patch-aa b/japanese/xchat/files/patch-aa
new file mode 100644
index 000000000000..9fa5c4d95530
--- /dev/null
+++ b/japanese/xchat/files/patch-aa
@@ -0,0 +1,10 @@
+--- src/common/cfgfiles.c.orig Mon Jun 25 18:23:57 2001
++++ src/common/cfgfiles.c Mon Jul 2 20:25:35 2001
+@@ -17,6 +17,7 @@
+ */
+
+ #include <fcntl.h>
++#include <locale.h>
+ #include <unistd.h>
+ #include <stdlib.h>
+ #ifdef HAVE_STRINGS_H
diff --git a/japanese/xchat/pkg-plist b/japanese/xchat/pkg-plist
index e16c1de6a8b8..0629a4594d85 100644
--- a/japanese/xchat/pkg-plist
+++ b/japanese/xchat/pkg-plist
@@ -14,20 +14,34 @@ bin/xchat-text
%%PORTDOCS%%share/doc/xchat/xchat-9.html
%%PORTDOCS%%share/doc/xchat/xchat.html
%%PORTDOCS%%share/doc/xchat/xchat.sgml
-%%PORTDOCS%%@dirrm share/doc/xchat
%%GNOME:%%share/gnome/apps/Internet/xchat.desktop
%%GNOME:%%share/gnome/pixmaps/xchat.png
+%%PORTDOCS%%@dirrm share/doc/xchat
+share/locale/ca/LC_MESSAGES/xchat.mo
share/locale/cs/LC_MESSAGES/xchat.mo
share/locale/da/LC_MESSAGES/xchat.mo
share/locale/de/LC_MESSAGES/xchat.mo
share/locale/el/LC_MESSAGES/xchat.mo
share/locale/es/LC_MESSAGES/xchat.mo
+share/locale/fi/LC_MESSAGES/xchat.mo
share/locale/fr/LC_MESSAGES/xchat.mo
+share/locale/he/LC_MESSAGES/xchat.mo
share/locale/hu/LC_MESSAGES/xchat.mo
share/locale/it/LC_MESSAGES/xchat.mo
share/locale/ja/LC_MESSAGES/xchat.mo
share/locale/ko/LC_MESSAGES/xchat.mo
+share/locale/lt/LC_MESSAGES/xchat.mo
share/locale/nl/LC_MESSAGES/xchat.mo
+share/locale/no/LC_MESSAGES/xchat.mo
+share/locale/pt/LC_MESSAGES/xchat.mo
share/locale/pt_BR/LC_MESSAGES/xchat.mo
+share/locale/ro/LC_MESSAGES/xchat.mo
+share/locale/ru/LC_MESSAGES/xchat.mo
+share/locale/sk/LC_MESSAGES/xchat.mo
share/locale/sl/LC_MESSAGES/xchat.mo
-share/locale/sr_YU/LC_MESSAGES/xchat.mo
+share/locale/sr/LC_MESSAGES/xchat.mo
+share/locale/sv/LC_MESSAGES/xchat.mo
+share/locale/tr/LC_MESSAGES/xchat.mo
+share/locale/uk/LC_MESSAGES/xchat.mo
+share/locale/zh_CN/LC_MESSAGES/xchat.mo
+share/locale/zh_TW.Big5/LC_MESSAGES/xchat.mo