aboutsummaryrefslogtreecommitdiff
path: root/japanese/xdtp/Makefile
diff options
context:
space:
mode:
authorDaichi GOTO <daichi@FreeBSD.org>2005-10-12 12:36:04 +0000
committerDaichi GOTO <daichi@FreeBSD.org>2005-10-12 12:36:04 +0000
commit287116692e0bf451e38e41a6479735aafbcd446d (patch)
treec508b640fd427494cd3d36b833460d1d04eee7f4 /japanese/xdtp/Makefile
parent65afc0834022e7f5c972fc824055b55f62138a18 (diff)
downloadports-287116692e0bf451e38e41a6479735aafbcd446d.tar.gz
ports-287116692e0bf451e38e41a6479735aafbcd446d.zip
Notes
Diffstat (limited to 'japanese/xdtp/Makefile')
-rw-r--r--japanese/xdtp/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/japanese/xdtp/Makefile b/japanese/xdtp/Makefile
new file mode 100644
index 000000000000..6c0daa371b26
--- /dev/null
+++ b/japanese/xdtp/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: XDTP (XML Document Transfer Program)
+# Date created: 11 October 2005
+# Whom: Masanori OZAWA (ozawa@ongs.co.jp)
+#
+# $FreeBSD$
+#
+
+PORTNAME= xdtp
+PORTVERSION= 1.0.0
+CATEGORIES= japanese
+MASTER_SITES+= http://www.ongs.co.jp/projects/xdtp/
+DISTNAME= xdtp-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ozawa@ongs.co.jp
+COMMENT= XDTP (XML Document Transfer Program)
+
+LIB_DEPENDS= glibmm-2.4:${PORTSDIR}/devel/glibmm
+
+INSTALLS_SHLIB= yes
+USE_GNOME= libxml2 libxslt pkgconfig
+GNU_CONFIGURE= yes
+
+OPTIONS= GDK "Build with Gdk-Pixbuf" on \
+ DEBUG "Build with debug option" off \
+ INCLUDE "Install with XDTP include files" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_GDK)
+USE_GNOME+= gtk20
+.else
+CONFIGURE_ENV+= WITHOUT_GDK="yes"
+MAKE_ARGS+= -DWITHOUT_GDK
+.endif
+
+.if defined(WITH_DEBUG)
+MAKE_ARGS+= -DDEBUG
+.endif
+
+.if defined(WITH_INCLUDE)
+PLIST_SUB+= XDTP_INC=""
+.else
+MAKE_ARGS+= -DWITHOUT_INCLUDE
+PLIST_SUB+= XDTP_INC="@comment "
+.endif
+
+.include <bsd.port.post.mk>