aboutsummaryrefslogtreecommitdiff
path: root/japanese
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2007-05-26 12:34:33 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2007-05-26 12:34:33 +0000
commitf52c71910e168dd3b6bef63bc43849e036364002 (patch)
tree761225c464022b8bf6cdbcbe47559c56dc2f3b42 /japanese
parentdc01c54dfb465bf2c0f97600b9e1fe0e9ddd341b (diff)
Notes
Diffstat (limited to 'japanese')
-rw-r--r--japanese/p5-PDFJ/Makefile1
-rw-r--r--japanese/p5-PDFJ/files/patch-PDFJ.pm36
-rw-r--r--japanese/p5-PDFJ/files/patch-XPDFJ.pm11
3 files changed, 43 insertions, 5 deletions
diff --git a/japanese/p5-PDFJ/Makefile b/japanese/p5-PDFJ/Makefile
index e39199b0914d..dc69e0053141 100644
--- a/japanese/p5-PDFJ/Makefile
+++ b/japanese/p5-PDFJ/Makefile
@@ -7,6 +7,7 @@
PORTNAME= PDFJ
PORTVERSION= 0.90
+PORTREVISION= 1
CATEGORIES= japanese perl5
MASTER_SITES= http://hp1.jonex.ne.jp/%7Enakajima.yasushi/archives/
diff --git a/japanese/p5-PDFJ/files/patch-PDFJ.pm b/japanese/p5-PDFJ/files/patch-PDFJ.pm
index 8fd167cc91e0..792700120fa4 100644
--- a/japanese/p5-PDFJ/files/patch-PDFJ.pm
+++ b/japanese/p5-PDFJ/files/patch-PDFJ.pm
@@ -1,11 +1,37 @@
---- PDFJ.pm.orig Thu Oct 28 18:02:55 2004
-+++ PDFJ.pm Fri Nov 5 14:59:35 2004
-@@ -3750,7 +3750,7 @@
- my($self, $str) = @_;
+--- PDFJ.pm.orig Sun Oct 22 19:27:42 2006
++++ PDFJ.pm Fri Mar 30 15:15:27 2007
+@@ -1093,7 +1093,7 @@
+ return;
+ }
+ push @filters, @addfilters if @addfilters;
+- my $filter = @filters > 1 ? [map {PDFJ::Object::name($_)} @filters] :
++ $filter = @filters > 1 ? [map {PDFJ::Object::name($_)} @filters] :
+ PDFJ::Object::name($filters[0]);
+ ($encoded, $filter);
+ }
+@@ -1537,7 +1537,7 @@
+ unless( $self->{outlinetree} ) {
+ $self->{outlinetree} = [];
+ }
+- my $parent = $self->{outlinetree};
++ $parent = $self->{outlinetree};
+ for( my $j = 0; $j < $level; $j++ ) {
+ push @$parent, ['', undef, undef, undef, []] unless @$parent;
+ $parent = $$parent[$#$parent][4];
+@@ -4036,6 +4036,7 @@
+ $font->{subset_unicodes}{$unicode} = 1 if $unicode;
+ }
+ if( @$chunks ) {
++ no warnings 'deprecated';
+ my $lastchunk = $chunks->[$#$chunks];
+ my $lastmode = $lastchunk->{Mode};
+ my $lastclass = $lastchunk->{Class};
+@@ -4132,7 +4133,7 @@
+ my($self, $str, $noshift) = @_;
my $style = $self->style;
my $result = [];
- my @c = split('', $str);
+ my @c = split('', $str || "");
for( my $j = 0; $j <= $#c; $j++ ) {
my $c = $c[$j];
- if( $c ge "\x81" && $c le "\x9f" || $c ge "\xe0" && $c le "\xfc" ) {
+ next if $c eq "\x00";
diff --git a/japanese/p5-PDFJ/files/patch-XPDFJ.pm b/japanese/p5-PDFJ/files/patch-XPDFJ.pm
new file mode 100644
index 000000000000..bd9174d81348
--- /dev/null
+++ b/japanese/p5-PDFJ/files/patch-XPDFJ.pm
@@ -0,0 +1,11 @@
+--- XPDFJ.pm.orig Fri Mar 30 15:01:05 2007
++++ XPDFJ.pm Fri Mar 30 15:01:17 2007
+@@ -122,7 +122,7 @@
+ sub _method_parse {
+ my($self, $tree, $this, $args, $mode) = @_;
+ my @result;
+- my $mmode = $mode;
++ my $mmode = $mode || "";
+ my $mlevel = 0;
+ if( $mmode =~ s/:(\d+)$// ) {
+ $mlevel = $1;