aboutsummaryrefslogtreecommitdiff
path: root/japanese
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2019-03-13 16:22:10 +0000
committerKai Knoblich <kai@FreeBSD.org>2019-03-13 16:22:10 +0000
commit62241438ae63a34ab6c629162c006978b7a21a28 (patch)
tree8b8689031839b18c89b55340d2324f83d18d405a /japanese
parent0495b7330097dbad8cad50ea2fc504e1fa9371f6 (diff)
downloadports-62241438ae63a34ab6c629162c006978b7a21a28.tar.gz
ports-62241438ae63a34ab6c629162c006978b7a21a28.zip
Notes
Diffstat (limited to 'japanese')
-rw-r--r--japanese/Makefile1
-rw-r--r--japanese/sourcehansans-otf/Makefile49
-rw-r--r--japanese/sourcehansans-otf/distinfo3
-rw-r--r--japanese/sourcehansans-otf/files/pkg-message.in7
-rw-r--r--japanese/sourcehansans-otf/pkg-descr14
-rw-r--r--japanese/sourcehansans-otf/pkg-plist16
6 files changed, 90 insertions, 0 deletions
diff --git a/japanese/Makefile b/japanese/Makefile
index 247b3a7a7cee..7b85b43ee4cc 100644
--- a/japanese/Makefile
+++ b/japanese/Makefile
@@ -257,6 +257,7 @@
SUBDIR += skkserv
SUBDIR += slimeforest
SUBDIR += slrn
+ SUBDIR += sourcehansans-otf
SUBDIR += sourcehanserif-otf
SUBDIR += srd-fpw-package
SUBDIR += suicavalue
diff --git a/japanese/sourcehansans-otf/Makefile b/japanese/sourcehansans-otf/Makefile
new file mode 100644
index 000000000000..23d19fba95af
--- /dev/null
+++ b/japanese/sourcehansans-otf/Makefile
@@ -0,0 +1,49 @@
+# $FreeBSD$
+
+PORTNAME= sourcehansans
+PORTVERSION= 2.000
+DISTVERSIONSUFFIX= R
+CATEGORIES= japanese x11-fonts
+PKGNAMESUFFIX= -otf
+# Note: the following PKGNAMEPREFIX is here only for self-documenting purpose;
+# actual prefixing is done by the `japanese' category itself.
+#PKGNAMEPREFIX= ja-
+
+MAINTAINER= hyun@caffeinated.codes
+COMMENT= Japanese font by Adobe designed for user interfaces
+
+LICENSE= OFL11
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+USES= fonts
+USE_GITHUB= yes
+GH_ACCOUNT= adobe-fonts
+GH_PROJECT= source-han-sans
+
+NO_ARCH= yes
+NO_BUILD= yes
+SUB_FILES= pkg-message
+
+OPTIONS_DEFINE= HW
+OPTIONS_SINGLE= TYPE
+OPTIONS_SINGLE_TYPE= FULL SUBSET
+OPTIONS_DEFAULT= FULL
+OPTIONS_SUB= yes
+
+HW_DESC= Install the half-width font in addition to the full font
+FULL_DESC= Install the full font (can display all CJK)
+SUBSET_DESC= Install the subset font (can display Japanese only)
+SUBSET_PREVENTS= HW
+SUBSET_PREVENTS_MSG= Half-width can only be installed in addition to the full font
+
+FULL_VARS= FONTNAME=SourceHanSans SRCFONTSDIR=OTF/Japanese
+SUBSET_VARS= FONTNAME=SourceHanSansJP SRCFONTSDIR=SubsetOTF/JP
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${FONTSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${SRCFONTSDIR}/*.otf ${STAGEDIR}${FONTSDIR}
+
+post-install-HW-on:
+ ${INSTALL_DATA} ${WRKSRC}/OTF/JapaneseHW/*.otf ${STAGEDIR}${FONTSDIR}
+
+.include <bsd.port.mk>
diff --git a/japanese/sourcehansans-otf/distinfo b/japanese/sourcehansans-otf/distinfo
new file mode 100644
index 000000000000..e1a2d0c34143
--- /dev/null
+++ b/japanese/sourcehansans-otf/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1543452172
+SHA256 (adobe-fonts-source-han-sans-2.000R_GH0.tar.gz) = 3c4dae5225605a90f115570d1c6a86eea8e6b04057297a5566f72f4e48ed0aa8
+SIZE (adobe-fonts-source-han-sans-2.000R_GH0.tar.gz) = 2093662207
diff --git a/japanese/sourcehansans-otf/files/pkg-message.in b/japanese/sourcehansans-otf/files/pkg-message.in
new file mode 100644
index 000000000000..2e8f2addd159
--- /dev/null
+++ b/japanese/sourcehansans-otf/files/pkg-message.in
@@ -0,0 +1,7 @@
+
+You can start using the font by following this instruction:
+
+Add the following line to the "Files" section of your X.org configuration file:
+
+ FontPath "%%FONTSDIR%%/"
+
diff --git a/japanese/sourcehansans-otf/pkg-descr b/japanese/sourcehansans-otf/pkg-descr
new file mode 100644
index 000000000000..4f2d384005a6
--- /dev/null
+++ b/japanese/sourcehansans-otf/pkg-descr
@@ -0,0 +1,14 @@
+Source Han Sans: A new open source Pan-CJK typeface family from Adobe
+
+This is Source Han Sans (JP), which supports all four variants in this family
+but prioritizes Japanese Kanji over other three.
+
+"Source Han Sans, available in seven weights, is a typeface family which
+provides full support for Japanese, Korean, Traditional Chinese, and Simplified
+Chinese, all in one font. It also includes Latin, Greek, and Cyrillic glyphs
+from our popular Source Sans family. All told, each font weight in the family
+has a total of 65,535 glyphs (the maximum supported in the OpenType format), and
+the entire family rounds out at just under half a million total glyphs."
+--- The Typekit Blog, Adobe
+
+WWW: https://github.com/adobe-fonts/source-han-sans
diff --git a/japanese/sourcehansans-otf/pkg-plist b/japanese/sourcehansans-otf/pkg-plist
new file mode 100644
index 000000000000..f355b91ac4c0
--- /dev/null
+++ b/japanese/sourcehansans-otf/pkg-plist
@@ -0,0 +1,16 @@
+%%HW%%%%FONTSDIR%%/SourceHanSansHW-Bold.otf
+%%HW%%%%FONTSDIR%%/SourceHanSansHW-Regular.otf
+%%FULL%%%%FONTSDIR%%/SourceHanSans-Bold.otf
+%%FULL%%%%FONTSDIR%%/SourceHanSans-ExtraLight.otf
+%%FULL%%%%FONTSDIR%%/SourceHanSans-Heavy.otf
+%%FULL%%%%FONTSDIR%%/SourceHanSans-Light.otf
+%%FULL%%%%FONTSDIR%%/SourceHanSans-Medium.otf
+%%FULL%%%%FONTSDIR%%/SourceHanSans-Normal.otf
+%%FULL%%%%FONTSDIR%%/SourceHanSans-Regular.otf
+%%SUBSET%%%%FONTSDIR%%/SourceHanSansJP-Bold.otf
+%%SUBSET%%%%FONTSDIR%%/SourceHanSansJP-ExtraLight.otf
+%%SUBSET%%%%FONTSDIR%%/SourceHanSansJP-Heavy.otf
+%%SUBSET%%%%FONTSDIR%%/SourceHanSansJP-Light.otf
+%%SUBSET%%%%FONTSDIR%%/SourceHanSansJP-Medium.otf
+%%SUBSET%%%%FONTSDIR%%/SourceHanSansJP-Normal.otf
+%%SUBSET%%%%FONTSDIR%%/SourceHanSansJP-Regular.otf