aboutsummaryrefslogtreecommitdiff
path: root/japanese
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2015-04-15 08:20:27 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2015-04-15 08:20:27 +0000
commit074ea5282a00d556c73d86231bec5444990597dc (patch)
treeeec3d608e84e79f0187985e5a1e29cd4f04f13eb /japanese
parent522c152d1c7b0c92982e310110fa6d59f915ffeb (diff)
Notes
Diffstat (limited to 'japanese')
-rw-r--r--japanese/groff/files/patch-src:libs:libgroff:encoding.cc22
-rw-r--r--japanese/jd/Makefile4
-rw-r--r--japanese/jd/files/patch-configure.ac11
-rw-r--r--japanese/mozc-server/files/patch-base_iconv.cc14
4 files changed, 14 insertions, 37 deletions
diff --git a/japanese/groff/files/patch-src:libs:libgroff:encoding.cc b/japanese/groff/files/patch-src:libs:libgroff:encoding.cc
index 9c9bc2ceec17..4318fd07edc7 100644
--- a/japanese/groff/files/patch-src:libs:libgroff:encoding.cc
+++ b/japanese/groff/files/patch-src:libs:libgroff:encoding.cc
@@ -1,26 +1,6 @@
--- src/libs/libgroff/encoding.cc.bak Wed Sep 10 03:45:14 2003
+++ src/libs/libgroff/encoding.cc Wed Sep 10 11:31:11 2003
-@@ -179,7 +179,8 @@
- inline wchar make_wchar(unsigned char c0, encoding_istream& eis) {
- wchar wc = 0;
- char inbuf[8], outbuf[8];
-- char *inp, *outp;
-+ const char *inp;
-+ char *outp;
- size_t inbytesleft, outbytesleft;
- int i = 0;
-
-@@ -214,7 +215,8 @@
-
- inline int put_wchar(wchar wc, encoding_ostream& eos) {
- char inbuf[4], outbuf[4];
-- char *inp, *outp;
-+ const char *inp;
-+ char *outp;
- size_t inbytesleft, outbytesleft;
-
- if (!is_wchar_code(wc)) {
-@@ -382,6 +384,9 @@
+@@ -382,6 +382,9 @@
#if HAVE_LANGINFO_CODESET
charset = nl_langinfo(CODESET);
#else
diff --git a/japanese/jd/Makefile b/japanese/jd/Makefile
index 8a75986ca276..eba692ac68cc 100644
--- a/japanese/jd/Makefile
+++ b/japanese/jd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= jd
PORTVERSION= 2.8.8
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= japanese www
MASTER_SITES= SFJP
MASTER_SITE_SUBDIR= jd4linux/61281
@@ -18,7 +18,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libgnutls.so:${PORTSDIR}/security/gnutls \
libgcrypt.so:${PORTSDIR}/security/libgcrypt
-USES= autoreconf iconv libtool tar:tgz
+USES= autoreconf iconv:translit libtool tar:tgz
USE_GNOME= gtk20 gtkmm24 libgnomeui
GNU_CONFIGURE= yes
diff --git a/japanese/jd/files/patch-configure.ac b/japanese/jd/files/patch-configure.ac
new file mode 100644
index 000000000000..ba33e83222ef
--- /dev/null
+++ b/japanese/jd/files/patch-configure.ac
@@ -0,0 +1,11 @@
+--- configure.ac.orig 2013-02-10 11:38:45 UTC
++++ configure.ac
+@@ -30,7 +30,7 @@ dnl
+ case "${host_os}" in
+ freebsd*)
+ echo "os = freebsd"
+- AC_DEFINE(ICONV_CONST, const, "iconv_const")
++ AC_DEFINE(ICONV_CONST, , "iconv_const")
+ AC_DEFINE(USE_MKTIME, , "use mktime")
+ ;;
+ solaris*)
diff --git a/japanese/mozc-server/files/patch-base_iconv.cc b/japanese/mozc-server/files/patch-base_iconv.cc
deleted file mode 100644
index 4ac94c3a2f40..000000000000
--- a/japanese/mozc-server/files/patch-base_iconv.cc
+++ /dev/null
@@ -1,14 +0,0 @@
---- base/iconv.cc.orig 2013-03-29 13:33:43.000000000 +0900
-+++ base/iconv.cc 2013-04-27 15:36:30.000000000 +0900
-@@ -53,7 +53,11 @@
- size_t olen_org = olen;
- iconv(ic, 0, &ilen, 0, &olen); // reset iconv state
- while (ilen != 0) {
-+#ifdef OS_FREEBSD
-+ if (iconv(ic, (const char **)(&ibuf), &ilen, &obuf, &olen)
-+#else
- if (iconv(ic, reinterpret_cast<char **>(&ibuf), &ilen, &obuf, &olen)
-+#endif
- == static_cast<size_t>(-1)) {
- return false;
- }