aboutsummaryrefslogtreecommitdiff
path: root/japanese
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2020-02-19 22:04:16 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2020-02-19 22:04:16 +0000
commit6d3bf98887c22ef2ba10448d09e19282da1ef7d2 (patch)
tree5581c3d486e94dc621aeadd55815e133e54a3ae8 /japanese
parent753edd485569239e0a2e0af420012efb44222609 (diff)
downloadports-6d3bf98887c22ef2ba10448d09e19282da1ef7d2.tar.gz
ports-6d3bf98887c22ef2ba10448d09e19282da1ef7d2.zip
Remove optional dependency on pygtk2
With hat: portmgr
Notes
Notes: svn path=/head/; revision=526531
Diffstat (limited to 'japanese')
-rw-r--r--japanese/libtomoe-gtk/Makefile14
-rw-r--r--japanese/libtomoe-gtk/pkg-plist2
-rw-r--r--japanese/tomoe/Makefile17
-rw-r--r--japanese/tomoe/pkg-plist5
4 files changed, 9 insertions, 29 deletions
diff --git a/japanese/libtomoe-gtk/Makefile b/japanese/libtomoe-gtk/Makefile
index 7a656fdb5005..dfafba07106d 100644
--- a/japanese/libtomoe-gtk/Makefile
+++ b/japanese/libtomoe-gtk/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libtomoe-gtk
PORTVERSION= 0.6.0
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= japanese
MASTER_SITES= SF/tomoe/tomoe-gtk/tomoe-gtk-${PORTVERSION}
DISTNAME= tomoe-gtk-${DISTVERSIONPREFIX}${DISTVERSION}${DISTVERSIONSUFFIX}
@@ -14,7 +14,8 @@ COMMENT= TOMOE GTK+ library
LIB_DEPENDS= libtomoe.so:japanese/tomoe
GNU_CONFIGURE= yes
-USES= gmake gnome libtool pathfix pkgconfig python:2.7,build
+CONFIGURE_ARGS= --with-python=no
+USES= gmake gnome libtool pathfix pkgconfig
USE_GNOME= gtk20
USE_LDCONFIG= yes
@@ -30,13 +31,4 @@ PLIST_SUB+= GUCHARMAP="@comment "
#PLIST_SUB+= GUCHARMAP=""
#.endif
-.if exists(${LOCALBASE}/libdata/pkgconfig/pytomoe.pc)
-CONFIGURE_ENV+= PYTHON_VERSION=${PYTHON_VERSION:S;python;;} \
- pyexecdir=${PYTHON_SITELIBDIR}
-PLIST_SUB+= PYTHON=""
-.else
-CONFIGURE_ARGS+=--with-python=no
-PLIST_SUB+= PYTHON="@comment "
-.endif
-
.include <bsd.port.mk>
diff --git a/japanese/libtomoe-gtk/pkg-plist b/japanese/libtomoe-gtk/pkg-plist
index 979e04809861..3a115e9e3116 100644
--- a/japanese/libtomoe-gtk/pkg-plist
+++ b/japanese/libtomoe-gtk/pkg-plist
@@ -16,8 +16,6 @@ lib/libtomoe-gtk.a
lib/libtomoe-gtk.so
lib/libtomoe-gtk.so.0
lib/libtomoe-gtk.so.0.1.0
-%%PYTHON%%%%PYTHON_SITELIBDIR%%/gtk-2.0/tomoegtk.a
-%%PYTHON%%%%PYTHON_SITELIBDIR%%/gtk-2.0/tomoegtk.so
libdata/pkgconfig/tomoe-gtk.pc
share/tomoe-gtk/tomoe-data-view.png
share/tomoe-gtk/tomoe-dictionary.png
diff --git a/japanese/tomoe/Makefile b/japanese/tomoe/Makefile
index 73b956fe05af..1c879d862fc8 100644
--- a/japanese/tomoe/Makefile
+++ b/japanese/tomoe/Makefile
@@ -3,7 +3,7 @@
PORTNAME= tomoe
PORTVERSION= 0.6.0
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= japanese
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
@@ -15,17 +15,16 @@ COMMENT= Tegaki Online MOji-ninshiki Engine
BUILD_DEPENDS= p5-XML-Parser>=0:textproc/p5-XML-Parser
GNU_CONFIGURE= yes
-USES= gettext gmake libtool pathfix perl5 pkgconfig
+USES= gettext gmake gnome libtool pathfix perl5 pkgconfig
+USE_GNOME= glib20
USE_LDCONFIG= yes
USE_PERL5= build
-CONFIGURE_ENV= PYTHON_VERSION=${PYTHON_VERSION:S;python;;} \
- pyexecdir=${PYTHON_SITELIBDIR} \
- GMSGFMT="${LOCALBASE}/bin/msgfmt"
+CONFIGURE_ARGS= --with-python=no
+CONFIGURE_ENV= GMSGFMT="${LOCALBASE}/bin/msgfmt"
CFLAGS+= -I${LOCALBASE}/include
-OPTIONS_DEFINE= DICT_RUBY EST MYSQL PYTHON RUBY UNIHAN
-OPTIONS_DEFAULT= PYTHON
+OPTIONS_DEFINE= DICT_RUBY EST MYSQL RUBY UNIHAN
OPTIONS_SUB= yes
DICT_RUBY_DESC= Enable Ruby based dictionary module
DICT_RUBY_CONFIGURE_ENABLE= dict-ruby
@@ -34,10 +33,6 @@ EST_CONFIGURE_WITH= est
MYSQL_DESC= Enable MySQL dictionary module
MYSQL_USES= mysql
MYSQL_CONFIGURE_WITH= mysql
-PYTHON_DESC= Enable Python module
-PYTHON_USES= gnome python:2.7
-PYTHON_USE= GNOME=pygtk2
-PYTHON_CONFIGURE_OFF= --with-python=no
RUBY_DESC= Enable Ruby module
RUBY_BROKEN= Does not build
RUBY_USE= RUBY=yes
diff --git a/japanese/tomoe/pkg-plist b/japanese/tomoe/pkg-plist
index ea33488e679b..907aec841a34 100644
--- a/japanese/tomoe/pkg-plist
+++ b/japanese/tomoe/pkg-plist
@@ -1,5 +1,4 @@
etc/tomoe/config
-%%PYTHON%%include/tomoe/pytomoe-utils.h
include/tomoe/tomoe-candidate.h
include/tomoe/tomoe-char.h
include/tomoe/tomoe-config.h
@@ -18,8 +17,6 @@ lib/libtomoe.a
lib/libtomoe.so
lib/libtomoe.so.0
lib/libtomoe.so.0.1.0
-%%PYTHON%%%%PYTHON_SITELIBDIR%%/tomoe.a
-%%PYTHON%%%%PYTHON_SITELIBDIR%%/tomoe.so
%%EST%%lib/tomoe/module/dict/est.a
%%EST%%lib/tomoe/module/dict/est.so
%%MYSQL%%lib/tomoe/module/dict/mysql.a
@@ -32,7 +29,6 @@ lib/tomoe/module/dict/xml.a
lib/tomoe/module/dict/xml.so
lib/tomoe/module/recognizer/simple.a
lib/tomoe/module/recognizer/simple.so
-%%PYTHON%%libdata/pkgconfig/pytomoe.pc
libdata/pkgconfig/tomoe.pc
share/gtk-doc/html/tomoe/TomoeCandidate.html
share/gtk-doc/html/tomoe/TomoeChar.html
@@ -58,7 +54,6 @@ share/gtk-doc/html/tomoe/tomoe.html
share/gtk-doc/html/tomoe/up.png
share/locale/ja/LC_MESSAGES/tomoe.mo
share/tomoe/dict.dtd
-%%PYTHON%%share/tomoe/python/tomoe.defs
share/tomoe/recognizer/handwriting-ja.xml
share/tomoe/recognizer/handwriting-zh_CN.xml
share/tomoe/xml2est.rb