aboutsummaryrefslogtreecommitdiff
path: root/japanese
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-03-27 17:06:05 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-03-27 17:06:05 +0000
commit25aa8365788d59ea6169da11b41cc1303091e2f0 (patch)
tree91451260fd17770022a84d486c6267f5696fb81c /japanese
parent78cc170e2739c8255b455a2f53710ab39d1b4e10 (diff)
- Unbreak with gcc42
PR: ports/121637 Submitted by: TANAKA Hiroyuki <kattyo@abk.nu> (maintainer)
Notes
Notes: svn path=/head/; revision=209962
Diffstat (limited to 'japanese')
-rw-r--r--japanese/xtr/Makefile8
-rw-r--r--japanese/xtr/files/patch-str-xstring.c23
2 files changed, 24 insertions, 7 deletions
diff --git a/japanese/xtr/Makefile b/japanese/xtr/Makefile
index ec752c4e4bcc..04b562e504a8 100644
--- a/japanese/xtr/Makefile
+++ b/japanese/xtr/Makefile
@@ -23,12 +23,6 @@ GNU_CONFIGURE= yes
NO_CDROM= Need to obtain permission for commercial redistribution.
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042
-BROKEN= Does not compile with GCC 4.2
-.endif
-
post-extract:
@${ECHO_MSG} "===> Converting Kanji code for ${DISTNAME}"
@(cd ${WRKSRC} && $(SH) EUCsetup )
@@ -45,4 +39,4 @@ do-install:
@${MKDIR} ${PREFIX}/share/${PORTNAME}
${INSTALL_DATA} ${WRKSRC}/sample/*.xtr ${PREFIX}/share/${PORTNAME}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/japanese/xtr/files/patch-str-xstring.c b/japanese/xtr/files/patch-str-xstring.c
new file mode 100644
index 000000000000..5b5cb070bae7
--- /dev/null
+++ b/japanese/xtr/files/patch-str-xstring.c
@@ -0,0 +1,23 @@
+--- src/xstring.c.orig 2008-03-27 17:58:25.000000000 +0100
++++ src/xstring.c 2008-03-27 18:02:39.000000000 +0100
+@@ -351,10 +351,16 @@
+ uchar *dstp = dst;
+
+ while (*src) {
+- if (IsKanjiStr(src))
+- *((ushort*)dstp)++ = *((ushort*)src)++;
+- else
+- *dstp++ = (*func)(*src++);
++ if (IsKanjiStr(src)) {
++ *((ushort*)dstp) = *((ushort*)src);
++ (ushort*)src++;
++ (ushort*)dstp++;
++ }
++ else {
++ *dstp = (*func)(*src);
++ src++;
++ dstp++;
++ }
+ }
+ *dstp = 0;
+ return dstp - dst;