aboutsummaryrefslogtreecommitdiff
path: root/japanese
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2014-02-04 19:34:34 +0000
committerHiroki Sato <hrs@FreeBSD.org>2014-02-04 19:34:34 +0000
commit8ef101d9d6d63a8b00cc557284fa87fcfb2cdfa3 (patch)
treec727b973034640febda538779a51ce12457d06c8 /japanese
parentf086aa79488cabef39e05fe6c8756849d216a2fc (diff)
downloadports-8ef101d9d6d63a8b00cc557284fa87fcfb2cdfa3.tar.gz
ports-8ef101d9d6d63a8b00cc557284fa87fcfb2cdfa3.zip
Notes
Diffstat (limited to 'japanese')
-rw-r--r--japanese/nkf/Makefile12
-rw-r--r--japanese/nkf/distinfo4
-rw-r--r--japanese/nkf/files/patch-Makefile54
3 files changed, 35 insertions, 35 deletions
diff --git a/japanese/nkf/Makefile b/japanese/nkf/Makefile
index 66fcad86571c..8d3f1d826956 100644
--- a/japanese/nkf/Makefile
+++ b/japanese/nkf/Makefile
@@ -2,10 +2,10 @@
# $FreeBSD$
PORTNAME= nkf
-PORTVERSION= 2.1.2
+PORTVERSION= 2.1.3
PORTEPOCH= 1
CATEGORIES?= japanese
-MASTER_SITES= SFJP/${PORTNAME}/53171
+MASTER_SITES= SFJP/${PORTNAME}/59912
MAINTAINER= hrs@FreeBSD.org
COMMENT= Network Kanji code conversion Filter
@@ -13,11 +13,7 @@ COMMENT= Network Kanji code conversion Filter
LICENSE= ZLIB
LICENSE_FILE= ${WRKSRC}/nkf.c
-ALL_TARGET= nkf
-PLIST_FILES= bin/nkf
+MAKE_ENV= MKDIR="${MKDIR}"
+PLIST_FILES= bin/nkf man/man1/nkf.1.gz man/ja/man1/nkf.1.gz
-MAN1= nkf.1
-MANLANG= "" ja
-
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/japanese/nkf/distinfo b/japanese/nkf/distinfo
index 9640024830e9..88e067ada2d4 100644
--- a/japanese/nkf/distinfo
+++ b/japanese/nkf/distinfo
@@ -1,2 +1,2 @@
-SHA256 (nkf-2.1.2.tar.gz) = 034e8b676160fa7cfaf023ad130ce2d7a7309e917c8f41b308e9dc2f6218a0a6
-SIZE (nkf-2.1.2.tar.gz) = 158127
+SHA256 (nkf-2.1.3.tar.gz) = 8cb430ae69a1ad58b522eb4927b337b5b420bbaeb69df255919019dc64b72fc2
+SIZE (nkf-2.1.3.tar.gz) = 195020
diff --git a/japanese/nkf/files/patch-Makefile b/japanese/nkf/files/patch-Makefile
index 79e9e20fb514..ba6e271f1dff 100644
--- a/japanese/nkf/files/patch-Makefile
+++ b/japanese/nkf/files/patch-Makefile
@@ -1,38 +1,45 @@
---- Makefile.orig 2009-11-17 09:33:04.000000000 +0900
-+++ Makefile 2010-02-15 23:02:44.471546444 +0900
-@@ -1,18 +1,22 @@
+--- Makefile.orig 2013-11-22 14:17:36.000000000 +0900
++++ Makefile 2013-12-26 10:08:41.000000000 +0900
+@@ -1,21 +1,31 @@
-CC = cc
-CFLAGS = -g -O2 -Wall -pedantic
-+CC?= cc
-+CFLAGS?= -g -O2 -Wall -pedantic
++CC? = cc
++CFLAGS? = -g -O2 -Wall -pedantic
# CFLAGS = -O3
SHAR = shar
# SHAR = shar -T
--PERL = perl
--RM = rm -rf
-+PERL?= perl
-+RM?= rm -rf
- VERSION = 2.1.2
- MKDIR = mkdir
+ PERL = perl
+ RM = rm -rf
+ VERSION = 2.1.3
+-MKDIR = mkdir
-prefix = /usr/local
-+PREFIX?= /usr/local
-+INSTALL?= /usr/bin/install
++MKDIR? = mkdir
++prefix = $(DESTDIR)$(PREFIX)
++manprefix = $(DESTDIR)$(MANPREFIX)
+ PYTHON2 = python
+ PYTHON3 = python
+BSD_INSTALL_PROGRAM?= ${INSTALL} -s -o root -g wheel -m 555
+BSD_INSTALL_MAN?= ${INSTALL} -o root -g wheel -m 444
.PHONY: clean install test tar shar
++all: nkf man
++
nkf : nkf.o utf8tbl.o
$(CC) $(CFLAGS) -o nkf nkf.o utf8tbl.o
-+ ./nkf -e nkf.1j > nkf.1j.euc
++man: nkf.1j nkf.1j.euc
++
++nkf.1j.euc: nkf nkf.1j
++ ./nkf -e nkf.1j > nkf.1j.euc
++
nkf.o : nkf.c nkf.h utf8tbl.h config.h
$(CC) $(CFLAGS) -c nkf.c
-@@ -34,14 +38,14 @@
- make test )
+
+@@ -45,13 +55,11 @@
install:
-- -$(MKDIR) $(prefix)/bin
+ -$(MKDIR) $(prefix)/bin
- -$(MKDIR) $(prefix)/man
- -$(MKDIR) $(prefix)/man/man1
- -$(MKDIR) $(prefix)/man/ja
@@ -40,14 +47,11 @@
- cp -f nkf $(prefix)/bin/
- cp -f nkf.1 $(prefix)/man/man1/
- cp -f nkf.1j $(prefix)/man/ja/man1/nkf.1
-+ -$(MKDIR) -p $(PREFIX)/bin
-+ -$(MKDIR) -p $(PREFIX)/man
-+ -$(MKDIR) -p $(PREFIX)/man/man1
-+ -$(MKDIR) -p $(PREFIX)/man/ja
-+ -$(MKDIR) -p $(PREFIX)/man/ja/man1
-+ ${BSD_INSTALL_PROGRAM} nkf ${PREFIX}/bin/
-+ ${BSD_INSTALL_MAN} nkf.1 ${PREFIX}/man/man1/
-+ ${BSD_INSTALL_MAN} nkf.1j.euc ${PREFIX}/man/ja/man1/nkf.1
++ -$(MKDIR) $(manprefix)/man/man1
++ -$(MKDIR) $(manprefix)/man/ja/man1
++ ${BSD_INSTALL_PROGRAM} nkf $(prefix)/bin/
++ ${BSD_INSTALL_MAN} nkf.1 $(manprefix)/man/man1/
++ ${BSD_INSTALL_MAN} nkf.1j.euc $(manprefix)/man/ja/man1/nkf.1
shar:
-mkdir nkf-$(VERSION)