aboutsummaryrefslogtreecommitdiff
path: root/japanese
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2014-08-29 18:12:20 +0000
committerHiroki Sato <hrs@FreeBSD.org>2014-08-29 18:12:20 +0000
commit1ce38e6fcc138aa0cd74d68026019d4d39b28be1 (patch)
treeb344b897c36d2004de72bc07f9404ef3196bf8fb /japanese
parentc2acf6c258de6c8b9cc01bf9846e18f3628bc512 (diff)
downloadports-1ce38e6fcc138aa0cd74d68026019d4d39b28be1.tar.gz
ports-1ce38e6fcc138aa0cd74d68026019d4d39b28be1.zip
Notes
Diffstat (limited to 'japanese')
-rw-r--r--japanese/groff/Makefile18
-rw-r--r--japanese/groff/files/patch-Makefile.in24
-rw-r--r--japanese/groff/files/patch-contrib-eqn2graph-eqn2graph.sh8
-rw-r--r--japanese/groff/files/patch-contrib-mom-Makefile.sub6
-rw-r--r--japanese/groff/files/patch-contrib-pic2graph-pic2graph.sh8
-rw-r--r--japanese/groff/files/patch-doc-groff.texinfo11
-rw-r--r--japanese/groff/files/patch-doc:Makefile.sub35
-rw-r--r--japanese/groff/pkg-plist1
8 files changed, 97 insertions, 14 deletions
diff --git a/japanese/groff/Makefile b/japanese/groff/Makefile
index 73ed8fe3fef5..8b8764ffe4f7 100644
--- a/japanese/groff/Makefile
+++ b/japanese/groff/Makefile
@@ -4,7 +4,7 @@
PORTNAME= groff
PORTVERSION= 1.18.1
DISTVERSIONSUFFIX= .1
-PORTREVISION= 15
+PORTREVISION= 16
CATEGORIES= japanese print
MASTER_SITES= LOCAL/hrs
DISTFILES= ${DISTNAME:S,-,_,}.orig${EXTRACT_SUFX} ${TMAC_DISTNAME}.tar.gz
@@ -18,10 +18,10 @@ COMMENT= Japanese enhancement of GNU groff
LICENSE= GPLv2
-USE_GCC= any
+USES= iconv:wchar_t gmake makeinfo shebangfix
+SHEBANG_FILES= src/utils/afmtodit/afmtodit.pl \
+ contrib/mm/mmroff.pl
GNU_CONFIGURE= yes
-USES= iconv:wchar_t gmake makeinfo
-
CONFIGURE_ARGS= --enable-multibyte
CONFIGURE_ENV= INSTALL_MAN="${INSTALL_MAN}"
CPPFLAGS+= -I${LOCALBASE}/include
@@ -32,7 +32,9 @@ PLIST_SUB= GROFF_VERSION=${PORTVERSION}
SUB_FILES= mdoc.local
SUB_LIST= OSREL=${OSREL}
PORTDOCS= *
+PORTEXAMPLES= *
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}/${PORTVERSION}
+EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}/${PORTVERSION}
INFO= groff
CONFLICTS= groff-[0-9]* mdocml-[0-9]*
@@ -43,8 +45,6 @@ TMACFILES= tmac.orig_me tmac.vgrind \
MDOCFILES= ja.eucJP doc-common doc-syms
post-patch:
- ${REINPLACE_CMD} -e 's|\(install_data\)|\1 install_doc|g;' \
- ${WRKSRC}/Makefile.in
${REINPLACE_CMD} -E -e 's|^@setfilename +groff|&.info|g;' \
${WRKSRC}/doc/groff.texinfo
@@ -52,9 +52,9 @@ post-build:
${RM} -f ${WRKSRC}/doc/groff ${WRKSRC}/doc/groff-*
cd ${WRKSRC}/doc && makeinfo --no-split groff.texinfo
cd ${WRKSRC} && ${FIND} font -name DESC \
- | ${XARGS} ${REINPLACE_CMD} -E -e 's|pro +(gxditview)|pro ${LOCALBASE}/bin/\1|g;'
- cd ${WRKSRC} && ${FIND} font -name DESC \
- | ${XARGS} ${REINPLACE_CMD} -E -e 's|pro +([^/].*)|pro ${PREFIX}/bin/\1|g;'
+ | ${XARGS} ${REINPLACE_CMD} -E \
+ -e 's|pro +(gxditview)|pro ${LOCALBASE}/bin/\1|g;' \
+ -e 's|pro +([^/].*)|pro ${PREFIX}/bin/\1|g;'
post-install:
cd ${WRKDIR}/${TMAC_DISTNAME} && ${INSTALL_DATA} \
diff --git a/japanese/groff/files/patch-Makefile.in b/japanese/groff/files/patch-Makefile.in
new file mode 100644
index 000000000000..dc3b9e22ca84
--- /dev/null
+++ b/japanese/groff/files/patch-Makefile.in
@@ -0,0 +1,24 @@
+--- Makefile.in.orig 2014-08-30 02:06:03.000000000 +0900
++++ Makefile.in 2014-08-30 02:07:14.000000000 +0900
+@@ -102,10 +102,10 @@
+ infodir=@infodir@
+
+ # `docdir' says where to install documentation files.
+-docdir=$(datadir)/doc/groff/$(version)$(revision)
++docdir=$(prefix)/share/doc/groff/$(version)$(revision)
+
+ # `exampledir' says where to install example files.
+-exampledir=$(docdir)/examples
++exampledir=$(prefix)/share/examples/groff/$(version)$(revision)
+
+ # `htmldocdir' says where to install documentation in HTML format.
+ htmldocdir=$(docdir)/html
+@@ -482,7 +482,7 @@
+ DISTDIRS=\
+ $(INCDIRS) $(LIBDIRS) $(PROGDIRS) $(DEVDIRS) $(OTHERDEVDIRS) \
+ $(ALLTTYDEVDIRS) $(OTHERDIRS) $(EXTRADIRS) $(NOMAKEDIRS)
+-TARGETS=all install install_bin install_data clean distclean mostlyclean \
++TARGETS=all install install_bin install_doc clean distclean mostlyclean \
+ realclean extraclean distfiles TAGS depend uninstall_sub
+
+ # This ENVSETUP gork is required by the DJGPP build on Windows 9X,
diff --git a/japanese/groff/files/patch-contrib-eqn2graph-eqn2graph.sh b/japanese/groff/files/patch-contrib-eqn2graph-eqn2graph.sh
new file mode 100644
index 000000000000..416630c37826
--- /dev/null
+++ b/japanese/groff/files/patch-contrib-eqn2graph-eqn2graph.sh
@@ -0,0 +1,8 @@
+--- contrib/eqn2graph/eqn2graph.sh.orig 2014-08-30 03:07:55.000000000 +0900
++++ contrib/eqn2graph/eqn2graph.sh 2014-08-30 03:08:01.000000000 +0900
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/bin/sh
+ #
+ # eqn2graph -- compile EQN equation descriptions to bitmap images
+ #
diff --git a/japanese/groff/files/patch-contrib-mom-Makefile.sub b/japanese/groff/files/patch-contrib-mom-Makefile.sub
index 8298c035f293..9fce1c7611af 100644
--- a/japanese/groff/files/patch-contrib-mom-Makefile.sub
+++ b/japanese/groff/files/patch-contrib-mom-Makefile.sub
@@ -1,5 +1,5 @@
--- contrib/mom/Makefile.sub.orig 2002-07-29 14:22:05.000000000 +0900
-+++ contrib/mom/Makefile.sub 2014-02-07 14:11:58.000000000 +0900
++++ contrib/mom/Makefile.sub 2014-08-30 02:23:07.000000000 +0900
@@ -90,26 +90,27 @@
test -d examples || $(mkinstalldirs) examples
test -f penguin.ps || cp $(srcdir)/examples/penguin.ps .
@@ -31,13 +31,13 @@
- rm -f $(exampledir)/$$f; \
- $(INSTALL_DATA) $(srcdir)/$$f $(docdir)/$$f; \
+ rm -f $(DESTDIR)$(exampledir)/$$f; \
-+ $(INSTALL_DATA) $(srcdir)/$$f $(DESTDIR)$(docdir)/$$f; \
++ $(INSTALL_DATA) $(srcdir)/$$f $(DESTDIR)$(exampledir)/$$(f#examples/); \
done
for f in $(PROCESSEDEXAMPLEFILES); do \
- rm -f $(exampledir)/$$f; \
- $(INSTALL_DATA) $$f $(docdir)/$$f; \
+ rm -f $(DESTDIR)$(exampledir)/$$f; \
-+ $(INSTALL_DATA) $$f $(DESTDIR)$(docdir)/$$f; \
++ $(INSTALL_DATA) $$f $(DESTDIR)$(exampledir)/$$(f#examples/); \
done
uninstall_sub:
diff --git a/japanese/groff/files/patch-contrib-pic2graph-pic2graph.sh b/japanese/groff/files/patch-contrib-pic2graph-pic2graph.sh
new file mode 100644
index 000000000000..6b331a3e5ab7
--- /dev/null
+++ b/japanese/groff/files/patch-contrib-pic2graph-pic2graph.sh
@@ -0,0 +1,8 @@
+--- contrib/pic2graph/pic2graph.sh.orig 2014-08-30 03:06:55.000000000 +0900
++++ contrib/pic2graph/pic2graph.sh 2014-08-30 03:07:01.000000000 +0900
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/bin/sh
+ #
+ # pic2graph -- compile PIC image descriptions to bitmap images
+ #
diff --git a/japanese/groff/files/patch-doc-groff.texinfo b/japanese/groff/files/patch-doc-groff.texinfo
new file mode 100644
index 000000000000..7d5c7b5b8e0b
--- /dev/null
+++ b/japanese/groff/files/patch-doc-groff.texinfo
@@ -0,0 +1,11 @@
+--- doc/groff.texinfo.orig 2014-08-30 02:39:34.000000000 +0900
++++ doc/groff.texinfo 2014-08-30 02:40:07.000000000 +0900
+@@ -10204,7 +10204,7 @@
+ affected glyphs.
+ @endDefesc
+
+-@Defesc {\\z, , g, , }
++@Defesc {\\z, , g, }
+ @cindex zero-width printing (@code{\z}, @code{\Z})
+ @cindex printing, zero-width (@code{\z}, @code{\Z})
+ Print glyph @var{g} with zero width, i.e., without spacing. Use
diff --git a/japanese/groff/files/patch-doc:Makefile.sub b/japanese/groff/files/patch-doc:Makefile.sub
index c278a2d07c70..164d658f5ec0 100644
--- a/japanese/groff/files/patch-doc:Makefile.sub
+++ b/japanese/groff/files/patch-doc:Makefile.sub
@@ -1,5 +1,5 @@
--- doc/Makefile.sub.orig 2002-07-26 22:48:54.000000000 +0900
-+++ doc/Makefile.sub 2014-02-07 13:42:25.000000000 +0900
++++ doc/Makefile.sub 2014-08-30 02:28:42.000000000 +0900
@@ -110,7 +110,7 @@
$(GROFF) -Tps -ms -mwww >$@
@@ -9,7 +9,7 @@
$(PROCESSEDEXAMPLEFILES) $(make_html)
html: $(HTMLDOCFILES) $(HTMLEXAMPLEFILES)
-@@ -133,35 +133,25 @@
+@@ -133,54 +133,44 @@
distfiles: groff gnu.eps gnu.png
@@ -56,3 +56,34 @@
done
install_html: $(HTMLDOCFILES) $(HTMLEXAMPLEFILES)
+- -test -d $(htmldocdir) || $(mkinstalldirs) $(htmldocdir)
++ -test -d $(DESTDIR)$(htmldocdir) || $(mkinstalldirs) $(DESTDIR)$(htmldocdir)
+ for f in $(HTMLDOCFILES); do \
+- rm -f $(htmldocdir)/$$f; \
+- $(INSTALL_DATA) $$f $(htmldocdir)/$$f; \
++ rm -f $(DESTDIR)$(htmldocdir)/$$f; \
++ $(INSTALL_DATA) $$f $(DESTDIR)$(htmldocdir)/$$f; \
+ done
+- -test -d $(htmldocimagedir) || $(mkinstalldirs) $(htmldocimagedir)
+- rm -f $(htmldocimagedir)/$(HTMLDOCIMAGEFILES)
+- $(INSTALL_DATA) $(imagedir)/$(HTMLDOCIMAGEFILES) $(htmldocimagedir)
+- -test -d $(exampledir) || $(mkinstalldirs) $(exampledir)
++ -test -d $(DESTDIR)$(htmldocimagedir) || $(mkinstalldirs) $(DESTDIR)$(htmldocimagedir)
++ rm -f $(DESTDIR)$(htmldocimagedir)/$(HTMLDOCIMAGEFILES)
++ $(INSTALL_DATA) $(imagedir)/$(HTMLDOCIMAGEFILES) $(DESTDIR)$(htmldocimagedir)
++ -test -d $(DESTDIR)$(exampledir) || $(mkinstalldirs) $(DESTDIR)$(exampledir)
+ for f in $(HTMLEXAMPLEFILES); do \
+- rm -f $(exampledir)/$$f; \
+- $(INSTALL_DATA) $$f $(exampledir)/$$f; \
++ rm -f $(DESTDIR)$(exampledir)/$$f; \
++ $(INSTALL_DATA) $$f $(DESTDIR)$(exampledir)/$$f; \
+ done
+- -test -d $(exampleimagedir) || $(mkinstalldirs) $(exampleimagedir)
+- rm -f $(exampleimagedir)/$(HTMLEXAMPLEIMAGEFILES)
+- $(INSTALL_DATA) $(imagedir)/$(HTMLEXAMPLEIMAGEFILES) $(exampleimagedir)
++ -test -d $(DESTDIR)$(exampleimagedir) || $(mkinstalldirs) $(DESTDIR)$(exampleimagedir)
++ rm -f $(DESTDIR)$(exampleimagedir)/$(HTMLEXAMPLEIMAGEFILES)
++ $(INSTALL_DATA) $(imagedir)/$(HTMLEXAMPLEIMAGEFILES) $(DESTDIR)$(exampleimagedir)
+
+ uninstall_sub:
+ -for f in groff groff-*; do \
diff --git a/japanese/groff/pkg-plist b/japanese/groff/pkg-plist
index ee667920f18f..acb761cf491a 100644
--- a/japanese/groff/pkg-plist
+++ b/japanese/groff/pkg-plist
@@ -458,3 +458,4 @@ man/man7/roff.7.gz
@dirrm %%DATADIR%%/site-tmac
@dirrm %%DATADIR%%
@dirrmtry share/doc/groff
+@dirrmtry share/examples/groff