aboutsummaryrefslogtreecommitdiff
path: root/japanese
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-01-05 05:08:29 +0000
committerWen Heping <wen@FreeBSD.org>2010-01-05 05:08:29 +0000
commit6f139a47662994ec95e5f151dea6af10bd455209 (patch)
tree9d881c2141e8003f61d78ddb6e2f667a6dd7785f /japanese
parent9d2a74fe97b899f25505db0d83c565f6a3b779be (diff)
downloadports-6f139a47662994ec95e5f151dea6af10bd455209.tar.gz
ports-6f139a47662994ec95e5f151dea6af10bd455209.zip
Notes
Diffstat (limited to 'japanese')
-rw-r--r--japanese/Makefile1
-rw-r--r--japanese/ibus-skk/Makefile31
-rw-r--r--japanese/ibus-skk/distinfo3
-rw-r--r--japanese/ibus-skk/files/patch-engine__engine.py10
-rw-r--r--japanese/ibus-skk/pkg-descr3
-rw-r--r--japanese/ibus-skk/pkg-message35
-rw-r--r--japanese/ibus-skk/pkg-plist28
7 files changed, 111 insertions, 0 deletions
diff --git a/japanese/Makefile b/japanese/Makefile
index 7f0843a2ef87..b1dbf6ea31f4 100644
--- a/japanese/Makefile
+++ b/japanese/Makefile
@@ -102,6 +102,7 @@
SUBDIR += hex
SUBDIR += hns
SUBDIR += ibus-anthy
+ SUBDIR += ibus-skk
SUBDIR += ical
SUBDIR += icanna
SUBDIR += iiimf-le-canna
diff --git a/japanese/ibus-skk/Makefile b/japanese/ibus-skk/Makefile
new file mode 100644
index 000000000000..e4025f76436a
--- /dev/null
+++ b/japanese/ibus-skk/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: ibus-skk
+# Date created: 4 January 2010
+# Whom: Hiroto Kagotani <hiroto.kagotani@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ibus-skk
+PORTVERSION= 0.0.3
+CATEGORIES= japanese
+MASTER_SITES= http://cloud.github.com/downloads/ueno/ibus-skk/
+
+MAINTAINER= hiroto.kagotani@gmail.com
+COMMENT= SKK engine for IBus
+
+RUN_DEPENDS= ibus-daemon:${PORTSDIR}/textproc/ibus \
+ ${LOCALBASE}/share/skk/SKK-JISYO.L:${PORTSDIR}/japanese/skk-jisyo
+
+USE_PYTHON= yes
+USE_GETTEXT= yes
+
+USE_GMAKE= yes
+USE_GNOME= intltool
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= DATADIRNAME=share
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO} To display this message again, type ${PKG_INFO} -D ${PKGNAME}
+
+.include <bsd.port.mk>
diff --git a/japanese/ibus-skk/distinfo b/japanese/ibus-skk/distinfo
new file mode 100644
index 000000000000..a0118c429dc1
--- /dev/null
+++ b/japanese/ibus-skk/distinfo
@@ -0,0 +1,3 @@
+MD5 (ibus-skk-0.0.3.tar.gz) = 796219007b61b7756dc953d7fd07c4bd
+SHA256 (ibus-skk-0.0.3.tar.gz) = 93a2733a896a54aeb85bf37f53d27cb15b200f8e1abb2a7da5a83decf7c68978
+SIZE (ibus-skk-0.0.3.tar.gz) = 370588
diff --git a/japanese/ibus-skk/files/patch-engine__engine.py b/japanese/ibus-skk/files/patch-engine__engine.py
new file mode 100644
index 000000000000..16e25ca2f1f6
--- /dev/null
+++ b/japanese/ibus-skk/files/patch-engine__engine.py
@@ -0,0 +1,10 @@
+--- ./engine/engine.py.orig 2009-12-31 12:20:19.000000000 +0900
++++ ./engine/engine.py 2010-01-04 16:40:51.000000000 +0900
+@@ -126,7 +126,6 @@
+ skk.CandidateSelector.PAGINATION_START)
+ self.__lookup_table = ibus.LookupTable(page_size=page_size,
+ round=False,
+- orientation=0,
+ labels=labels)
+ self.__candidate_selector = CandidateSelector(self.__lookup_table,
+ self.__select_keys,
diff --git a/japanese/ibus-skk/pkg-descr b/japanese/ibus-skk/pkg-descr
new file mode 100644
index 000000000000..28b9494db2cc
--- /dev/null
+++ b/japanese/ibus-skk/pkg-descr
@@ -0,0 +1,3 @@
+SKK engine for IBus.
+
+WWW: http://github.com/ueno/ibus-skk
diff --git a/japanese/ibus-skk/pkg-message b/japanese/ibus-skk/pkg-message
new file mode 100644
index 000000000000..04d36bdbe15b
--- /dev/null
+++ b/japanese/ibus-skk/pkg-message
@@ -0,0 +1,35 @@
+ibus-skk installation finished. To use ibus-skk, please do the following:
+
+If you are using bash or zsh, please add following lines to your $HOME/.bashrc or
+$HOME/.zshrc:
+
+export XIM=ibus
+export GTK_IM_MODULE=ibus
+export QT_IM_MODULE=xim
+export XMODIFIERS=@im=ibus
+export XIM_PROGRAM="ibus-daemon"
+export XIM_ARGS="--daemonize --xim"
+
+If you are using tcsh, please add following lines to your $HOME/.cshrc:
+
+setenv XIM ibus
+setenv GTK_IM_MODULE ibus
+setenv QT_IM_MODULE xim
+setenv XMODIFIERS @im=ibus
+setenv XIM_PROGRAM ibus-daemon
+setenv XIM_ARGS "--daemonize --xim"
+
+If you are using KDE4, you may create a shell script in $HOME/.kde4/env,
+and add following lines:
+
+#!/bin/sh
+export XIM=ibus
+export GTK_IM_MODULE=ibus
+export QT_IM_MODULE=xim
+export XMODIFIERS=@im=ibus
+export XIM_PROGRAM="ibus-daemon"
+export XIM_ARGS="--daemonize --xim"
+
+If ibus cannot start or the panel does not appear, please ensure
+that you are using up-to-date python.
+There's a bug in python 2.5, which may prevent the panel from appearing.
diff --git a/japanese/ibus-skk/pkg-plist b/japanese/ibus-skk/pkg-plist
new file mode 100644
index 000000000000..af3c73d06039
--- /dev/null
+++ b/japanese/ibus-skk/pkg-plist
@@ -0,0 +1,28 @@
+libexec/ibus-engine-skk
+libexec/ibus-setup-skk
+share/ibus/component/skk.xml
+%%DATADIR%%/engine/engine.py
+%%DATADIR%%/engine/engine.pyc
+%%DATADIR%%/engine/engine.pyo
+%%DATADIR%%/engine/factory.py
+%%DATADIR%%/engine/factory.pyc
+%%DATADIR%%/engine/factory.pyo
+%%DATADIR%%/engine/main.py
+%%DATADIR%%/engine/main.pyc
+%%DATADIR%%/engine/main.pyo
+%%DATADIR%%/engine/skk.py
+%%DATADIR%%/engine/skk.pyc
+%%DATADIR%%/engine/skk.pyo
+%%DATADIR%%/icons/ibus-skk.png
+%%DATADIR%%/setup/config.py
+%%DATADIR%%/setup/config.pyc
+%%DATADIR%%/setup/config.pyo
+%%DATADIR%%/setup/ibus-skk-preferences.ui
+%%DATADIR%%/setup/main.py
+%%DATADIR%%/setup/main.pyc
+%%DATADIR%%/setup/main.pyo
+share/locale/ja/LC_MESSAGES/ibus-skk.mo
+@dirrm %%DATADIR%%/engine
+@dirrm %%DATADIR%%/icons
+@dirrm %%DATADIR%%/setup
+@dirrm %%DATADIR%%