aboutsummaryrefslogtreecommitdiff
path: root/japanese
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2009-01-02 23:09:51 +0000
committerHiroki Sato <hrs@FreeBSD.org>2009-01-02 23:09:51 +0000
commit2d3cbd926a459351dcc28f570e15a4264be1c848 (patch)
treee6d53fa53088d6b2b9f4e0dcf76fd86aabe9c198 /japanese
parent36ede78e2d0ed547be7b477db73a9b8f44071b0f (diff)
downloadports-2d3cbd926a459351dcc28f570e15a4264be1c848.tar.gz
ports-2d3cbd926a459351dcc28f570e15a4264be1c848.zip
Notes
Diffstat (limited to 'japanese')
-rw-r--r--japanese/Wnn6-lib/Makefile26
-rw-r--r--japanese/Wnn6-lib/files/patch-README14
-rw-r--r--japanese/Wnn6-lib/files/patch-Wnn-jlib-js.c29
-rw-r--r--japanese/Wnn6-lib/files/patch-ad15
-rw-r--r--japanese/Wnn6-lib/pkg-descr26
-rw-r--r--japanese/Wnn6-lib/pkg-plist3
6 files changed, 69 insertions, 44 deletions
diff --git a/japanese/Wnn6-lib/Makefile b/japanese/Wnn6-lib/Makefile
index bcb9020eb3f1..b6da9df3803c 100644
--- a/japanese/Wnn6-lib/Makefile
+++ b/japanese/Wnn6-lib/Makefile
@@ -7,19 +7,18 @@
PORTNAME= Wnn6-lib
PORTVERSION= 2000.9.1
+PORTREVISION= 1
CATEGORIES= japanese
MASTER_SITES= ftp://ftp.omronsoft.co.jp/pub/Wnn6/sdk_source/
DISTNAME= Wnn6-SDK
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Include files and a library of Wnn6
-
-BUILD_DEPENDS= imake:${PORTSDIR}/devel/imake
-
-WRKSRC= ${WRKDIR}/src/contrib/im/Xsi
-DOCDIR= ${PREFIX}/share/doc/ja-Wnn6-lib
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= Wnn6 client library
+USE_IMAKE= yes
USE_LDCONFIG= yes
+WRKSRC= ${WRKDIR}/src/contrib/im/Xsi
+PORTDOCS= README
post-patch:
@${REINPLACE_CMD} -e 's,/usr/X11R6,${LOCALBASE},g' \
@@ -27,15 +26,16 @@ post-patch:
${WRKSRC}/config/X11.tmpl \
${WRKSRC}/Makefile.ini
-# Warning: we cannot use USE_IMAKE.
do-build:
- ( cd ${WRKSRC} ; make World -f Makefile.ini )
+ cd ${WRKSRC} && make World -f Makefile.ini
post-install:
${LN} -sf libwnn6_fromsrc.a ${PREFIX}/lib/libwnn6.a
- @${MKDIR} ${PREFIX}/include/wnn6/wnn
- @${INSTALL_DATA} ${WRKSRC}/Wnn/include/*.h ${PREFIX}/include/wnn6/wnn
- @${MKDIR} ${DOCDIR}
- @${INSTALL_DATA} ${WRKSRC}/README ${DOCDIR}
+ ${MKDIR} ${PREFIX}/include/wnn6/wnn
+ ${INSTALL_DATA} ${WRKSRC}/Wnn/include/*.h ${PREFIX}/include/wnn6/wnn
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
.include <bsd.port.mk>
diff --git a/japanese/Wnn6-lib/files/patch-README b/japanese/Wnn6-lib/files/patch-README
new file mode 100644
index 000000000000..2bd4139ad06b
--- /dev/null
+++ b/japanese/Wnn6-lib/files/patch-README
@@ -0,0 +1,14 @@
+--- README.orig 2000-09-01 18:58:55.000000000 +0900
++++ README 2009-01-03 07:51:26.000000000 +0900
+@@ -129,6 +129,11 @@
+
+ Comments on Modifications:
+
++2008/12/29: hrs@FreeBSD.org
++ Add SUN_LEN() macro to fix calculation of length of sockaddr_un when
++ sun_len is included in the structure. This fixes the mangled unix
++ domain socket name issue; "/tmp/jd_sockV" is used instead of
++ "/tmp/jd_sockV6".
+
+
+ ***************************************************************************
diff --git a/japanese/Wnn6-lib/files/patch-Wnn-jlib-js.c b/japanese/Wnn6-lib/files/patch-Wnn-jlib-js.c
new file mode 100644
index 000000000000..c971df7b7186
--- /dev/null
+++ b/japanese/Wnn6-lib/files/patch-Wnn-jlib-js.c
@@ -0,0 +1,29 @@
+--- Wnn/jlib/js.c.orig 2000-09-01 18:58:55.000000000 +0900
++++ Wnn/jlib/js.c 2009-01-03 07:49:43.000000000 +0900
+@@ -342,18 +342,20 @@
+ } else {
+ sock_name = UNIX_SOCKET_NAME; /* Jserver */
+ }
+- strcpy(saddr.sun_path, sock_name);
+-#if ((defined AIXV3) || (defined FREEBSD) || (defined BSDOS) || (defined NETBSD))
+- strcat(saddr.sun_path, "=");
+-#endif
+-
++ strncpy(saddr.sun_path, sock_name, sizeof(saddr.sun_path) - 1);
++ saddr.sun_path[sizeof(saddr.sun_path) - 1] = '\0';
++
+ if ((sd = socket(AF_UNIX,SOCK_STREAM, 0)) == ERROR) {
+ #if DEBUG
+ xerror("jslib:Can't create socket.\n");
+ #endif
+ return -1;
+ }
+- if (connect(sd,(struct sockaddr *)&saddr,strlen(saddr.sun_path)+sizeof(saddr.sun_family)) == ERROR) {
++
++#if !defined(SUN_LEN)
++# define SUN_LEN(su) (sizeof(*(su)) - sizeof((su)->sun_path) + strlen((su)->sun_path))
++#endif
++ if (connect(sd,(struct sockaddr *)&saddr, SUN_LEN(&saddr)) == ERROR) {
+ #if DEBUG
+ xerror("jslib:Can't connect socket.\n");
+ #endif
diff --git a/japanese/Wnn6-lib/files/patch-ad b/japanese/Wnn6-lib/files/patch-ad
index 01622ee24979..509acfac755a 100644
--- a/japanese/Wnn6-lib/files/patch-ad
+++ b/japanese/Wnn6-lib/files/patch-ad
@@ -1,6 +1,6 @@
---- ../Xsi.org/Wnn/Imakefile Wed Oct 28 13:36:14 1998
-+++ ./Wnn/Imakefile Sun Nov 22 01:28:58 1998
-@@ -14,7 +14,11 @@
+--- Wnn/Imakefile.orig 2000-09-01 18:58:55.000000000 +0900
++++ Wnn/Imakefile 2009-01-03 08:02:08.000000000 +0900
+@@ -14,10 +14,14 @@
MakeSubdirs($(SUBDIRS))
DependSubdirs($(SUBDIRS))
@@ -10,5 +10,10 @@
install:: mkwnndir
+#endif
- MakeDirectory(mkwnndir, $(DESTDIR)$(WNNWNNDIR))
- MakeDirectory(mkwnndir, $(DESTDIR)$(JWNNWNNDIR))
+-MakeDirectory(mkwnndir, $(DESTDIR)$(WNNWNNDIR))
+-MakeDirectory(mkwnndir, $(DESTDIR)$(JWNNWNNDIR))
++MakeDirectories(mkwnndir, $(DESTDIR)$(WNNWNNDIR))
++MakeDirectories(mkwnndir, $(DESTDIR)$(JWNNWNNDIR))
+
+ checkwnnid::
+ @A=`egrep "^$(WNNOWNER):" /etc/passwd | cat` ;\
diff --git a/japanese/Wnn6-lib/pkg-descr b/japanese/Wnn6-lib/pkg-descr
index 6e3a794ac74d..45db0107020d 100644
--- a/japanese/Wnn6-lib/pkg-descr
+++ b/japanese/Wnn6-lib/pkg-descr
@@ -1,26 +1,4 @@
-This port has include files (e.g. wnn/commonhd.h) and a library file
-(e.g. libwnn.a) to build Wnn6 clients. The files are compiled from
-sources Wnn6-SDK-sources.tar.gz which you can get in
+This port is Wnn6 client library including header and library files
+for Wnn6 client development.
WWW: http://www.omronsoft.co.jp/
-
-The license of the sources is in
-
-/usr/local/share/doc/ja-Wnn6-lib/README
-
-By the way, you must buy the server of Wnn6, whose name is jserver,
-from Omron Software Co., Ltd.
-
-+------------------------------------------+
-| URL: http://www.omronsoft.co.jp |
-| E-mail: wnn-info@omronsoft.co.jp |
-| TEL: +81-44-246-6006 |
-| FAX: +81-44-246-6011 |
-+------------------------------------------+
-
-Wnn6 is one of Japanese input methods. 'Wnn6 for Linux/FreeBSD' is
-supported an only Japanese method. However, Wnn4.2 which is free is
-supported Chinese and Korean ones, too.
-
-- S. Taoka
-taoka@FreeBSD.org
diff --git a/japanese/Wnn6-lib/pkg-plist b/japanese/Wnn6-lib/pkg-plist
index 5d27a50cb8b8..c447d58bdc7d 100644
--- a/japanese/Wnn6-lib/pkg-plist
+++ b/japanese/Wnn6-lib/pkg-plist
@@ -1,3 +1,4 @@
+@comment $FreeBSD$
include/wnn6/wnn/commonhd.h
include/wnn6/wnn/config.h
include/wnn6/wnn/copyright.h
@@ -26,5 +27,3 @@ lib/libwnn6_fromsrc.a
lib/libwnn6.a
lib/libwnn6.so
lib/libwnn6.so.2
-share/doc/ja-Wnn6-lib/README
-@dirrm share/doc/ja-Wnn6-lib