aboutsummaryrefslogtreecommitdiff
path: root/japanese
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2006-07-02 12:51:09 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2006-07-02 12:51:09 +0000
commitb507acd1b66d94cb3a33ed022704606d5ca9099a (patch)
tree91e8df650f6033f435136ae06c0942e0d596b3b4 /japanese
parentf26c1976463b0d87979ad6e745765c0acd206e18 (diff)
downloadports-b507acd1b66d94cb3a33ed022704606d5ca9099a.tar.gz
ports-b507acd1b66d94cb3a33ed022704606d5ca9099a.zip
Notes
Diffstat (limited to 'japanese')
-rw-r--r--japanese/nkf/Makefile10
-rw-r--r--japanese/nkf/distinfo6
-rw-r--r--japanese/nkf/files/patch-aa12
-rw-r--r--japanese/nkf/files/patch-nkf.c43
4 files changed, 14 insertions, 57 deletions
diff --git a/japanese/nkf/Makefile b/japanese/nkf/Makefile
index c3638877e040..513459c68fa8 100644
--- a/japanese/nkf/Makefile
+++ b/japanese/nkf/Makefile
@@ -6,18 +6,18 @@
#
PORTNAME= nkf
-PORTVERSION= 2.06
-DISTVERSION= a
+PORTVERSION= 2.0.7
+PORTEPOCH= 1
CATEGORIES?= japanese
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_JP}
-MASTER_SITE_SUBDIR= ${PORTNAME}/19481
+MASTER_SITE_SUBDIR= ${PORTNAME}/20770
PKGNAMEPREFIX?= ja-
-DISTNAME= ${PORTNAME}${PORTVERSION:S/.//:S/./-/}${DISTVERSION}
+DISTNAME= ${PORTNAME}${PORTVERSION:S/.//g}
MAINTAINER= nork@FreeBSD.org
COMMENT?= Network Kanji code conversion Filter
-WRKSRC?= ${WRKDIR}/${PORTNAME}${PORTVERSION:S/.//:S/./-/}
+WRKSRC?= ${WRKDIR}/${PORTNAME}${PORTVERSION:S/.//g}
.if ${PKGNAMEPREFIX} != "ja-p5-"
MAN1= nkf.1
diff --git a/japanese/nkf/distinfo b/japanese/nkf/distinfo
index 953afd81ccbf..5f6c106f2814 100644
--- a/japanese/nkf/distinfo
+++ b/japanese/nkf/distinfo
@@ -1,3 +1,3 @@
-MD5 (nkf206a.tar.gz) = f4b07268b238ac85551e2777fa2c3836
-SHA256 (nkf206a.tar.gz) = 8b0e93dcc1270a13cd7fc74d65f636f036de554c1f46e93629cf5a932650ea49
-SIZE (nkf206a.tar.gz) = 244822
+MD5 (nkf207.tar.gz) = af11dcd3fe71d67831c020e3bfd5073b
+SHA256 (nkf207.tar.gz) = 71d2ba992df209a00bb1dca45e3336729dc16e51b71526bd20f897cc6127a275
+SIZE (nkf207.tar.gz) = 150501
diff --git a/japanese/nkf/files/patch-aa b/japanese/nkf/files/patch-aa
index 08798d31a662..8ce6c794964e 100644
--- a/japanese/nkf/files/patch-aa
+++ b/japanese/nkf/files/patch-aa
@@ -1,8 +1,8 @@
---- Makefile.orig Mon Mar 27 21:46:57 2006
-+++ Makefile Sat May 6 22:40:48 2006
+--- Makefile.orig Mon Jun 19 23:04:35 2006
++++ Makefile Sun Jul 2 21:44:28 2006
@@ -1,17 +1,27 @@
-CC = cc
--CFLAGS = -O -Wall
+-CFLAGS = -O
+PREFIX?= /usr/local
+CC?= cc
+CFLAGS?= -O -Wall
@@ -14,9 +14,9 @@
+PERL?= perl
+RM?= rm -rf
+INSTALL?= /usr/bin/install
-+BSD_INSTALL_PROGRAM?= ${INSTALL} -s -o root -g wheel -m 555
-+BSD_INSTALL_MAN?= ${INSTALL} -o root -g wheel -m 444
- VERSION = 206
++BSD_INSTALL_PROGRAM?= ${INSTALL} -s -o root -g wheel -m 555
++BSD_INSTALL_MAN?= ${INSTALL} -o root -g wheel -m 444
+ VERSION = 207
nkf : nkf.c config.h utf8tbl.o
$(CC) $(CFLAGS) -o nkf nkf.c utf8tbl.o
diff --git a/japanese/nkf/files/patch-nkf.c b/japanese/nkf/files/patch-nkf.c
deleted file mode 100644
index d47a5ff67cb0..000000000000
--- a/japanese/nkf/files/patch-nkf.c
+++ /dev/null
@@ -1,43 +0,0 @@
---- nkf.c.orig Mon Mar 27 21:46:58 2006
-+++ nkf.c Sun May 7 22:37:16 2006
-@@ -3323,9 +3323,9 @@
- void (*f)PROTO((int c2,int c1));
- int c;
- {
-+ int shift = 20;
- const char *hex = "0123456789ABCDEF";
- c &= 0x00FFFFFF;
-- int shift = 20;
- while(shift >= 0){
- if(c >= 1<<shift){
- while(shift >= 0){
-@@ -3417,6 +3417,7 @@
- c = unicode_subchar;
- (*oconv)((c>>8)&0xFF, c&0xFF);
- return;
-+#if 0
- int shift = 16;
- while(shift >= 0){
- if(c >= 1<<shift){
-@@ -3429,10 +3430,13 @@
- }
- }
- return;
-+#endif
- }
- #endif
-
- #ifdef UTF8_OUTPUT_ENABLE
-+extern const unsigned short *const x0212_to_utf8_2bytes[];
-+
- int
- e2w_conv(c2, c1)
- int c2, c1;
-@@ -3449,7 +3453,6 @@
- if(ms_ucs_map_f == UCS_MAP_ASCII&& c2 == 0x8F22 && c1 == 0x43){
- return 0xA6;
- }
-- extern const unsigned short *const x0212_to_utf8_2bytes[];
- c2 = (c2&0x7f) - 0x21;
- if (0<=c2 && c2<sizeof_euc_to_utf8_2bytes)
- p = x0212_to_utf8_2bytes[c2];