aboutsummaryrefslogtreecommitdiff
path: root/japanese
diff options
context:
space:
mode:
authorSatoshi Taoka <taoka@FreeBSD.org>2001-07-31 01:44:04 +0000
committerSatoshi Taoka <taoka@FreeBSD.org>2001-07-31 01:44:04 +0000
commit50952ed4252c50c6485f2e71e7d1c86305629683 (patch)
tree81fb8d169c1e28ab01d52b7eb323cdcb8ee4f9e1 /japanese
parent279f34e177850e262b9c89372b51e676fbfba3f6 (diff)
downloadports-50952ed4252c50c6485f2e71e7d1c86305629683.tar.gz
ports-50952ed4252c50c6485f2e71e7d1c86305629683.zip
Notes
Diffstat (limited to 'japanese')
-rw-r--r--japanese/Makefile1
-rw-r--r--japanese/bjfilter850/Makefile54
-rw-r--r--japanese/bjfilter850/files/filter_gui24
-rw-r--r--japanese/bjfilter850/pkg-comment1
-rw-r--r--japanese/bjfilter850/pkg-descr38
-rw-r--r--japanese/bjfilter850/pkg-plist2
6 files changed, 120 insertions, 0 deletions
diff --git a/japanese/Makefile b/japanese/Makefile
index bfe1917a82ec..612ad6499a1b 100644
--- a/japanese/Makefile
+++ b/japanese/Makefile
@@ -18,6 +18,7 @@
SUBDIR += balsa
SUBDIR += bible_names-fpw
SUBDIR += binder
+ SUBDIR += bjfilter850
SUBDIR += bookview
SUBDIR += cannadic
SUBDIR += canuum
diff --git a/japanese/bjfilter850/Makefile b/japanese/bjfilter850/Makefile
new file mode 100644
index 000000000000..559e86e449e2
--- /dev/null
+++ b/japanese/bjfilter850/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: bjfilter850 with Japanese
+# Date created: 01/07/27
+# Whom: Satoshi Taoka <taoka@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bjfilter${PRTYPE}${SUFIX_PRTYPE}
+PORTVERSION?= 1.1
+CATEGORIES= japanese print linux
+MASTER_SITES= # empty
+DISTFILES= # empty
+
+MAINTAINER= taoka@FreeBSD.org
+
+RUN_DEPENDS= ${LINUXBASE}/usr/share/locale/ja_JP/LC_COLLATE:${PORTSDIR}/japanese/linux_locale \
+ ${PREFIX}/libexec/bjfilter${PRTYPE}${SUFIX_PRTYPE}/filter${PRTYPE}${SUFIX_PRTYPE}:${PORTSDIR}/print/bjfilter${PRTYPE}${SUFIX_PRTYPE}
+
+ONLY_FOR_ARCHS= i386
+# for slave ports
+PLIST= ${.CURDIR}/pkg-plist
+COMMENT= ${.CURDIR}/pkg-comment
+DESCR= ${.CURDIR}/pkg-descr
+PRTYPE?= 850
+
+FILTER= ${FILESDIR}/filter
+
+do-build:
+ ${SED} -e 's,%%PRTYPE%%,${PRTYPE}${SUFIX_PRTYPE},' \
+ ${FILTER}_gui > ${WRKDIR}/filter${PRTYPE}${SUFIX_PRTYPE}_gui
+do-install:
+ ${MKDIR} ${PREFIX}/libexec/${PKGNAMEPREFIX}${PORTNAME}
+ ${INSTALL_SCRIPT} ${WRKDIR}/filter${PRTYPE}${SUFIX_PRTYPE}_gui \
+ ${PREFIX}/libexec/${PKGNAMEPREFIX}${PORTNAME}
+
+
+.include <bsd.port.mk>
+
+# a target for the maintainer
+_MAKE_COMMENT_DESCR:
+.if ${PORTNAME} != "bjfilter850"
+.for file in pkg-comment pkg-descr pkg-plist
+ ${SED} -e 's/850/${PRTYPE}${SUFIX_PRTYPE}/g' ../bjfilter850/${file} \
+ > ${.CURDIR}/${file}
+.endfor
+.if defined(SUFIX_PRTYPE) && ${SUFIX_PRTYPE} == "ug"
+ i=`cat ../bjfilter850/pkg-comment`; \
+ echo $$i "(supported BCI-6 inks)" > ${.CURDIR}/pkg-comment
+ echo "" >> ${.CURDIR}/pkg-descr
+ echo "Notice: This is supported BCI-6 inks." >> ${.CURDIR}/pkg-descr
+ echo "" >> ${.CURDIR}/pkg-descr
+ echo "Notice: bjfilter850 and bjfilter850ug cannot be installed simultaneously." >> ${.CURDIR}/pkg-descr
+.endif
+.endif
diff --git a/japanese/bjfilter850/files/filter_gui b/japanese/bjfilter850/files/filter_gui
new file mode 100644
index 000000000000..39667be64123
--- /dev/null
+++ b/japanese/bjfilter850/files/filter_gui
@@ -0,0 +1,24 @@
+#!/bin/sh
+
+PATH=${PATH}:/usr/bin:/usr/local/bin
+
+while [ "$1" != "-h" ] && [ "$1" != "" ]; do
+ shift
+done
+
+hostname=localhost
+if [ "$2" != "" ]; then
+ hostname=$2
+fi
+
+resolution=600
+papersize=a4
+printer=BJF%%PRTYPE%%
+
+GS="gs -q -r$resolution -dNOPROMPT -dSAFER \
+ -sPAPERSIZE=$papersize -sDEVICE=bmp16m -sOutputFile=- -"
+BJFILTER="env LANG=ja_JP bjfilter --display $hostname:0.0 \
+--gui --model $printer --imageres $resolution --fit"
+# --lgmon
+
+psselect -r | bjcmd "${GS} | ${BJFILTER}"
diff --git a/japanese/bjfilter850/pkg-comment b/japanese/bjfilter850/pkg-comment
new file mode 100644
index 000000000000..ee9c01594e7d
--- /dev/null
+++ b/japanese/bjfilter850/pkg-comment
@@ -0,0 +1 @@
+Canon Bubble Jet Print Filter for Linux -- BJ F850 (with Japanese messages)
diff --git a/japanese/bjfilter850/pkg-descr b/japanese/bjfilter850/pkg-descr
new file mode 100644
index 000000000000..00dd0fae30d6
--- /dev/null
+++ b/japanese/bjfilter850/pkg-descr
@@ -0,0 +1,38 @@
+This port is for a printer filter of Canon BJ F850. The filter is
+called Canon Bubble Jet Print Filter for Linux and there exist the
+filters for other Canon bubble jet printers. By using this driver you
+can print out as high quality as you use the Windows driver. See the
+below URLs:
+
+WWW: http://www.canon-sales.co.jp/drv-upd/linux/bjlinux100.html
+ file:/usr/local/share/doc/bjfiltercom-1.1_1/html/README.HTM
+ file:/usr/local/share/doc/bjfiltercom-1.1_1/html/INDEX.HTM
+ file:/usr/local/share/doc/bjfiltercom-1.1_1/html/FAQ.HTM
+
+And then this port has filters filter850 and filter850_gui which are
+useful to print out more than one page. If you use it and connect it
+via "ulpt", you add the next entry into /etc/printcap.
+
+bjfilter850|Canon BJ F850:\
+ :lp=/dev/ulpt0:\
+ :sh:\
+ :if=/usr/local/libexec/bjfilter850/filter850:\
+ :sd=/var/spool/lpd/bjfilter850:\
+ :mx#0:\
+ :lf=/var/log/lpd-errs
+bjfilter850_gui|Canon BJ F850 with GUI and Japanese messages:\
+ :lp=/dev/ulpt0:\
+ :sh:\
+ :if=/usr/local/libexec/ja-bjfilter850/filter850_gui:\
+ :sd=/var/spool/lpd/bjfilter850_gui:\
+ :mx#0:\
+ :lf=/var/log/lpd-errs
+
+Notice: If you use filter850_gui then the host which you are using
+have to run X and be the printer saver (connected the printer Canon BJ).
+
+*********************************************************************
+To run with Japanese messages, you should execute with "env LANG=ja_JP"
+in a command line. For example,
+ env LANG=ja_JP bjfilter --gui --model BJF850 sample.bmp > /dev/lpt0
+*********************************************************************
diff --git a/japanese/bjfilter850/pkg-plist b/japanese/bjfilter850/pkg-plist
new file mode 100644
index 000000000000..24ac9304298c
--- /dev/null
+++ b/japanese/bjfilter850/pkg-plist
@@ -0,0 +1,2 @@
+libexec/ja-bjfilter850/filter850_gui
+@dirrm libexec/ja-bjfilter850