aboutsummaryrefslogtreecommitdiff
path: root/japanese
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>2000-04-30 20:10:41 +0000
committerSteve Price <steve@FreeBSD.org>2000-04-30 20:10:41 +0000
commit83aef2804c7b705d1f70672ec7d822f1bf1b17cf (patch)
tree4a5f927cf5a1439b525b869ab0722d64caa45b9b /japanese
parenta94d68c6abe1def4b561aa190af4fae2e427bbea (diff)
downloadports-83aef2804c7b705d1f70672ec7d822f1bf1b17cf.tar.gz
ports-83aef2804c7b705d1f70672ec7d822f1bf1b17cf.zip
Notes
Diffstat (limited to 'japanese')
-rw-r--r--japanese/emacs-manual/Makefile16
-rw-r--r--japanese/emacs-manual/distinfo3
-rw-r--r--japanese/emacs-manual/files/Makefile.in2
-rw-r--r--japanese/emacs-manual/files/PORT_TEXIFMT.MK7
-rw-r--r--japanese/emacs-manual/files/patch-aa10
-rw-r--r--japanese/emacs-manual/pkg-descr2
6 files changed, 22 insertions, 18 deletions
diff --git a/japanese/emacs-manual/Makefile b/japanese/emacs-manual/Makefile
index 7791dc4e8768..6e0f9fd5cb0d 100644
--- a/japanese/emacs-manual/Makefile
+++ b/japanese/emacs-manual/Makefile
@@ -6,19 +6,19 @@
#
PORTNAME= emacs-manual
-PORTVERSION= 13.2000.01.13
+PORTVERSION= 13.20000303
CATEGORIES= japanese
MASTER_SITES= ftp://ftp.ascii.co.jp/pub/GNU/emacs-20.x/ \
${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= emacs
-DISTNAME= emacs-20.5-man-jp
+DISTNAME= emacs-20.6-man-jp
DISTFILES= ${DISTNAME}.tgz ${EMACS_ARC}
MAINTAINER= okazaki@be.to
BUILD_DEPENDS= ${EMACS}:${PORTSDIR}/editors/emacs20
-ERRATA_FILE= Errata-2000-01-13
+ERRATA_FILE=
EXTRACT_ONLY= ${DISTNAME}.tgz
EMACS_DISTNAME= emacs-20.6
@@ -42,12 +42,16 @@ EMACS= emacs-20.6
MAKE_ENV= EMACS="${EMACS}"
post-extract:
- @${CP} ${FILESDIR}/Makefile.in ${WRKSRC}/Makefile
- @${CP} ${FILESDIR}/PORT_TEXIFMT.MK ${WRKSRC}
+ ${CP} ${FILESDIR}/Makefile.in ${WRKSRC}/Makefile
+ ${CP} ${FILESDIR}/PORT_TEXIFMT.MK ${WRKSRC}
@(cd ${WRKDIR} && \
${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${DISTDIR}/${EMACS_ARC} ${EXTRACT_AFTER_ARGS} ${EXTRACT_FILES} ; \
${CP} ${EXTRACT_FILES} ${WRKSRC})
- @${MKDIR} ${WRKDIR}/info
+ ${MKDIR} ${WRKDIR}/info
+
+post-patch:
+ cd ${WRKSRC} && \
+ ${PERL} -pi -e 's/(@[^@]*ref{.*,.*,.*, *elisp),/$$1-ja,/;' *.texi
pre-build:
@${ECHO_MSG} "===> Now start formatting texinfo. Please wait."
diff --git a/japanese/emacs-manual/distinfo b/japanese/emacs-manual/distinfo
index 5d4824c84933..d97cbb2e838b 100644
--- a/japanese/emacs-manual/distinfo
+++ b/japanese/emacs-manual/distinfo
@@ -1,3 +1,2 @@
-MD5 (emacs-20.5-man-jp.tgz) = 087b8b3a5200d72f6f24bc6ec30d46cd
+MD5 (emacs-20.6-man-jp.tgz) = 4cd74247ebb493f385e41901ef33081f
MD5 (emacs-20.6.tar.gz) = cfcaa33b5fc7d64210d3428f13570f8d
-MD5 (Errata-2000-01-13.tgz) = 7b4fa4f0357b16c9a73352f402430688
diff --git a/japanese/emacs-manual/files/Makefile.in b/japanese/emacs-manual/files/Makefile.in
index ae123a322465..f6727b76474a 100644
--- a/japanese/emacs-manual/files/Makefile.in
+++ b/japanese/emacs-manual/files/Makefile.in
@@ -5,7 +5,7 @@ EMACS?= emacs
EMACS_ARGS= -batch -nw --multibyte -no-init-file -no-site-file
EMACS_LOADLIBS= --load=texinfmt.el --load=PORT_TEXIFMT.MK
-EMACS_FUNCALLS= --eval "(defconst PORT-TEXI \"${TEXIFILE}\")" -f port-texinfo-format
+EMACS_FUNCALLS= --eval "(port-texinfo-format \"${TEXIFILE}\" 'junet)"
all: ${INFOFILE}
diff --git a/japanese/emacs-manual/files/PORT_TEXIFMT.MK b/japanese/emacs-manual/files/PORT_TEXIFMT.MK
index 9443db0cbd56..a050d11992dd 100644
--- a/japanese/emacs-manual/files/PORT_TEXIFMT.MK
+++ b/japanese/emacs-manual/files/PORT_TEXIFMT.MK
@@ -2,13 +2,14 @@
;;; PORT_TEXIFMT.MK --- for texinfo-format
;;; Code:
-(defun port-texinfo-format ()
+(defun port-texinfo-format (file &optional coding-system)
(let (obuf)
- (find-file (expand-file-name PORT-TEXI))
+ (find-file (expand-file-name file))
(setq obuf (current-buffer))
(require 'texinfmt)
(texinfo-format-buffer t)
- (set-buffer-file-coding-system 'iso-2022-jp)
+ (if coding-system
+ (set-buffer-file-coding-system coding-system))
(save-buffer)
(kill-buffer (current-buffer))
(kill-buffer obuf)))
diff --git a/japanese/emacs-manual/files/patch-aa b/japanese/emacs-manual/files/patch-aa
index ba7a34aa2f95..1b426c743e0f 100644
--- a/japanese/emacs-manual/files/patch-aa
+++ b/japanese/emacs-manual/files/patch-aa
@@ -1,6 +1,6 @@
---- emacs.texi~ Mon Dec 13 16:50:47 1999
-+++ emacs.texi Sat Jan 8 01:55:18 2000
-@@ -12,7 +12,8 @@
+--- emacs.texi.~1~ Thu Mar 23 12:16:23 2000
++++ emacs.texi Mon Apr 3 22:38:11 2000
+@@ -14,7 +14,8 @@
@setchapternewpage odd
@c @settitle GNU Emacs Manual
@settitle GNU Emacsマニュアル
@@ -10,8 +10,8 @@
@synindex pg cp
@ifinfo
-@@ -22,9 +23,9 @@
- Emacs 20.5版対応に改訂した@cite{GNU Emacs Manual} 13版です。
+@@ -24,9 +25,9 @@
+ Emacs 20.6版対応に改訂した@cite{GNU Emacs Manual} 13版です。
@c Please REMEMBER to update edition number in *three* places in this file.
-@dircategory Editors
diff --git a/japanese/emacs-manual/pkg-descr b/japanese/emacs-manual/pkg-descr
index d658e0a252fb..c450ac80c96f 100644
--- a/japanese/emacs-manual/pkg-descr
+++ b/japanese/emacs-manual/pkg-descr
@@ -2,4 +2,4 @@ This is a Japanese translation of the GNU Emacs Manual.
Emacs is the extensible, customizable, self-documenting real-time
display editor. This Info file describes how to edit with Emacs and
-some of how to customize it; it corresponds to GNU Emacs version 20.5.
+some of how to customize it; it corresponds to GNU Emacs version 20.6.