aboutsummaryrefslogtreecommitdiff
path: root/japanese
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2005-04-03 13:30:04 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2005-04-03 13:30:04 +0000
commitec67b0dfea7d9ab56b06a633114ce793e9fe8f68 (patch)
treed0012b7e6324a3fd902b30d226ba02d35b57beb3 /japanese
parente541bcfae7098dd2f4eb4e071ef5433abe1c6644 (diff)
downloadports-ec67b0dfea7d9ab56b06a633114ce793e9fe8f68.tar.gz
ports-ec67b0dfea7d9ab56b06a633114ce793e9fe8f68.zip
Notes
Diffstat (limited to 'japanese')
-rw-r--r--japanese/Makefile1
-rw-r--r--japanese/scim-canna/Makefile44
-rw-r--r--japanese/scim-canna/distinfo2
-rw-r--r--japanese/scim-canna/pkg-descr3
-rw-r--r--japanese/scim-canna/pkg-message11
-rw-r--r--japanese/scim-canna/pkg-plist5
6 files changed, 66 insertions, 0 deletions
diff --git a/japanese/Makefile b/japanese/Makefile
index 7b55e1d4c8fc..61fe222cd982 100644
--- a/japanese/Makefile
+++ b/japanese/Makefile
@@ -342,6 +342,7 @@
SUBDIR += samba3
SUBDIR += sazanami-ttf
SUBDIR += scim-anthy
+ SUBDIR += scim-canna
SUBDIR += scim-tables
SUBDIR += scim-uim
SUBDIR += sed
diff --git a/japanese/scim-canna/Makefile b/japanese/scim-canna/Makefile
new file mode 100644
index 000000000000..ef5bcedf28ff
--- /dev/null
+++ b/japanese/scim-canna/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: ja-scim-canna
+# Date created: 2005-04-03
+# Whom: Norikatsu Shigemura <nork@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= scim-canna
+PORTVERSION= 0.0.0
+CATEGORIES= japanese
+MASTER_SITES= http://www.homa.ne.jp/~ashie/linux/files/
+
+MAINTAINER= nork@FreeBSD.org
+COMMENT= SCIM IMEngine module using Canna
+
+BUILD_DEPENDS= scim:${PORTSDIR}/textproc/scim
+LIB_DEPENDS+= canna.1:${PORTSDIR}/japanese/Canna
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_GNOME= lthack
+USE_X_PREFIX= yes
+USE_ICONV= yes
+USE_GMAKE= yes
+USE_LIBTOOL_VER=15
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500035
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
+RUN_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/stlport" \
+ LDFLAGS="-L${LOCALBASE}/lib -lstlport_gcc"
+.else
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -D__STDC_ISO_10646__" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO}
+ @${ECHO} To display this message again, type \`pkg_info -D ${PKGNAME}\'
+ @${ECHO}
+
+.include <bsd.port.post.mk>
diff --git a/japanese/scim-canna/distinfo b/japanese/scim-canna/distinfo
new file mode 100644
index 000000000000..6232de02845a
--- /dev/null
+++ b/japanese/scim-canna/distinfo
@@ -0,0 +1,2 @@
+MD5 (scim-canna-0.0.0.tar.gz) = 3049d8f26b423405828c79a31a5c0c0e
+SIZE (scim-canna-0.0.0.tar.gz) = 495703
diff --git a/japanese/scim-canna/pkg-descr b/japanese/scim-canna/pkg-descr
new file mode 100644
index 000000000000..7e508bd20334
--- /dev/null
+++ b/japanese/scim-canna/pkg-descr
@@ -0,0 +1,3 @@
+scim-canna is the SCIM IMEngine module using the Canna input method.
+
+WWW: http://sourceforge.jp/projects/scim-imengine/
diff --git a/japanese/scim-canna/pkg-message b/japanese/scim-canna/pkg-message
new file mode 100644
index 000000000000..316515697de1
--- /dev/null
+++ b/japanese/scim-canna/pkg-message
@@ -0,0 +1,11 @@
+--------------------------------------------------------------------
+Remember to set environment variables XMODIFIERS and LANG:
+
+ csh/tcsh: setenv XMODIFIERS @im=SCIM ; setenv LANG ja_JP.eucJP
+ sh/bash: export XMODIFIERS='@im=SCIM'; export LANG=ja_JP.eucJP
+
+To start the SCIM input method daemon, use command:
+
+ scim -d
+
+--------------------------------------------------------------------
diff --git a/japanese/scim-canna/pkg-plist b/japanese/scim-canna/pkg-plist
new file mode 100644
index 000000000000..46782d5bf05f
--- /dev/null
+++ b/japanese/scim-canna/pkg-plist
@@ -0,0 +1,5 @@
+lib/scim-1.0/IMEngine/canna.so
+lib/scim-1.0/SetupUI/canna-imengine-setup.so
+share/locale/ja/LC_MESSAGES/scim-canna.mo
+@unexec rmdir %D/lib/scim-1.0/IMEngine 2>/dev/null || true
+@unexec rmdir %D/lib/scim-1.0/SetupUI 2>/dev/null || true