aboutsummaryrefslogtreecommitdiff
path: root/japanese
diff options
context:
space:
mode:
authorOsamu Matsuda <omatsuda000@gmail.com>2021-06-24 16:00:53 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2021-06-25 00:56:31 +0000
commit17d313fe9d47b937e92f313631a4e72d34c90552 (patch)
tree09c60b4280ec1508a1402e3255ba47cf26574cba /japanese
parent6731277a343bfdf080453aa32047d39d5c53050f (diff)
downloadports-17d313fe9d47b937e92f313631a4e72d34c90552.tar.gz
ports-17d313fe9d47b937e92f313631a4e72d34c90552.zip
japanese/qolibri: (New) EPWING dictionary viewer
PR: 256715
Diffstat (limited to 'japanese')
-rw-r--r--japanese/Makefile1
-rw-r--r--japanese/qolibri/Makefile24
-rw-r--r--japanese/qolibri/distinfo3
-rw-r--r--japanese/qolibri/files/patch-CMakeLists.txt19
-rw-r--r--japanese/qolibri/files/patch-src_searchpage.cpp11
-rw-r--r--japanese/qolibri/pkg-descr3
6 files changed, 61 insertions, 0 deletions
diff --git a/japanese/Makefile b/japanese/Makefile
index 94afb19f7021..16d5df16bc83 100644
--- a/japanese/Makefile
+++ b/japanese/Makefile
@@ -213,6 +213,7 @@
SUBDIR += prn
SUBDIR += py-jaconv
SUBDIR += qkc
+ SUBDIR += qolibri
SUBDIR += quit
SUBDIR += roget-fpw
SUBDIR += rogue_s
diff --git a/japanese/qolibri/Makefile b/japanese/qolibri/Makefile
new file mode 100644
index 000000000000..81426a8b171b
--- /dev/null
+++ b/japanese/qolibri/Makefile
@@ -0,0 +1,24 @@
+# created by: Osamu Matsuda <omatsuda000@gmail.com>
+
+PORTNAME= qolibri
+DISTVERSION= 2.1.3
+CATEGORIES= japanese
+
+MAINTAINER= omatsuda000@gmail.com
+COMMENT= EPWING dictionary viewer
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libeb.so:japanese/eb
+
+USES= cmake qt:5
+USE_QT= buildtools core declarative gui linguisttools location \
+ multimedia network printsupport qmake webchannel webengine \
+ widgets
+
+USE_GITHUB= yes
+GH_ACCOUNT= ludios
+
+PLIST_FILES= bin/qolibri
+
+.include <bsd.port.mk>
diff --git a/japanese/qolibri/distinfo b/japanese/qolibri/distinfo
new file mode 100644
index 000000000000..0a96e1f9d84b
--- /dev/null
+++ b/japanese/qolibri/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1624181574
+SHA256 (ludios-qolibri-2.1.3_GH0.tar.gz) = 6954b9e86cbc70026361927b22bc9b0bd58a188646e35c4da68f99790790367e
+SIZE (ludios-qolibri-2.1.3_GH0.tar.gz) = 252092
diff --git a/japanese/qolibri/files/patch-CMakeLists.txt b/japanese/qolibri/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..a0af8111c22e
--- /dev/null
+++ b/japanese/qolibri/files/patch-CMakeLists.txt
@@ -0,0 +1,19 @@
+--- CMakeLists.txt.orig 2020-02-28 16:02:25 UTC
++++ CMakeLists.txt
+@@ -16,6 +16,8 @@ set(CMAKE_AUTOUIC ON)
+ set(CMAKE_AUTORCC ON)
+
+ find_package(Qt5 COMPONENTS LinguistTools Multimedia Network WebEngine WebEngineWidgets Widgets REQUIRED)
++find_library(EB_LIBRARY eb)
++find_library(Z_LIBRARY z)
+
+ add_executable(qolibri MACOSX_BUNDLE WIN32
+ images/qolibri.icns
+@@ -154,6 +156,6 @@ set_source_files_properties(${TS_FILES} PROPERTIES OUT
+ qt5_add_translation(QM_FILES ${TS_FILES})
+ target_sources(qolibri PRIVATE "${CMAKE_CURRENT_BINARY_DIR}/translations/translations.qrc" ${QM_FILES} ${TS_FILES})
+
+-target_link_libraries(qolibri Qt5::Multimedia Qt5::Network Qt5::WebEngine Qt5::WebEngineWidgets Qt5::Widgets eb z)
++target_link_libraries(qolibri Qt5::Multimedia Qt5::Network Qt5::WebEngine Qt5::WebEngineWidgets Qt5::Widgets ${EB_LIBRARY} ${Z_LIBRARY})
+
+ install(TARGETS qolibri DESTINATION "${CMAKE_INSTALL_BINDIR}")
diff --git a/japanese/qolibri/files/patch-src_searchpage.cpp b/japanese/qolibri/files/patch-src_searchpage.cpp
new file mode 100644
index 000000000000..9ce367592ab8
--- /dev/null
+++ b/japanese/qolibri/files/patch-src_searchpage.cpp
@@ -0,0 +1,11 @@
+--- src/searchpage.cpp.orig 2020-02-28 16:02:25 UTC
++++ src/searchpage.cpp
+@@ -17,7 +17,7 @@ RET_SEARCH SearchPage::search(const Query& query)
+ switch (query.method.direction) {
+ case ExactWordSearch:
+ case ForwardSearch:
+- queries << stemWords(query.query);
++/* queries << stemWords(query.query); */
+ break;
+ default:
+ break;
diff --git a/japanese/qolibri/pkg-descr b/japanese/qolibri/pkg-descr
new file mode 100644
index 000000000000..088250701f6b
--- /dev/null
+++ b/japanese/qolibri/pkg-descr
@@ -0,0 +1,3 @@
+EPWING dictionary reader originally developed at http://qolibri.osdn.jp/
+
+WWW: https://github.com/ludios/qolibri/