aboutsummaryrefslogtreecommitdiff
path: root/java/castor
diff options
context:
space:
mode:
authorHerve Quiroz <hq@FreeBSD.org>2005-05-14 17:05:49 +0000
committerHerve Quiroz <hq@FreeBSD.org>2005-05-14 17:05:49 +0000
commit50ed27ab740d928ee6979f958956b1eba57acf47 (patch)
tree0cea0bb75a3293310c557a4ee3955f0cc35961a0 /java/castor
parent4c42ee616358be3e59a993e569a16f8f487b9fb0 (diff)
downloadports-50ed27ab740d928ee6979f958956b1eba57acf47.tar.gz
ports-50ed27ab740d928ee6979f958956b1eba57acf47.zip
Notes
Diffstat (limited to 'java/castor')
-rw-r--r--java/castor/Makefile37
-rw-r--r--java/castor/distinfo2
-rw-r--r--java/castor/pkg-descr5
3 files changed, 44 insertions, 0 deletions
diff --git a/java/castor/Makefile b/java/castor/Makefile
new file mode 100644
index 000000000000..afd6e7167f64
--- /dev/null
+++ b/java/castor/Makefile
@@ -0,0 +1,37 @@
+# Ports collection makefile for: Castor
+# Date created: 2005/05/12
+# Whom: Adam VanderHook <acidos@bandwidth-junkies.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= castor
+PORTVERSION= 0.9.6
+CATEGORIES= java devel
+MASTER_SITES= http://dist.codehaus.org/castor/${PORTVERSION}/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= acidos@bandwidth-junkies.net
+COMMENT= Data binding for XML (JAXB) and SQL database (JDO)
+
+USE_JAVA= yes
+JAVA_VERSION= 1.4
+USE_ANT= yes
+USE_JIKES= no
+
+ALL_TARGET= jar
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+BUILD_WRKSRC= ${WRKSRC}/src
+
+JAVALIBNAME= ${PORTNAME}-${PORTVERSION}
+JARFILE= ${PORTNAME}.jar
+PLIST_FILES= %%JAVAJARDIR%%/${JARFILE}
+
+do-install:
+ @${ECHO_MSG} -n ">> Installing JAR as ${JAVAJARDIR}/${JARFILE}..."
+ @${INSTALL_DATA} ${WRKSRC}/dist/${JAVALIBNAME}.jar ${JAVAJARDIR}/${JARFILE}
+ @${ECHO_MSG} " [ DONE ]"
+
+.include <bsd.port.mk>
diff --git a/java/castor/distinfo b/java/castor/distinfo
new file mode 100644
index 000000000000..f1ab99a1e7fc
--- /dev/null
+++ b/java/castor/distinfo
@@ -0,0 +1,2 @@
+MD5 (castor-0.9.6-src.tgz) = 3ec1b9623f04b86f157738bd3f10a847
+SIZE (castor-0.9.6-src.tgz) = 5937173
diff --git a/java/castor/pkg-descr b/java/castor/pkg-descr
new file mode 100644
index 000000000000..db27d215f9b3
--- /dev/null
+++ b/java/castor/pkg-descr
@@ -0,0 +1,5 @@
+Castor is a data binding framework for Java. It's the shortest path
+between Java objects, XML documents, and relational tables. Castor
+provides Java-to-XML binding, Java-to-SQL persistence, and more.
+
+WWW: http://www.castor.org/