aboutsummaryrefslogtreecommitdiff
path: root/java/eclipse-log4e
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2004-09-03 21:06:27 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2004-09-03 21:06:27 +0000
commitc44aa1025fcba37a9681ff3c349fdad8085af0ef (patch)
treea0741f34d5df8792f8396a031bcfac68d05abfd5 /java/eclipse-log4e
parentca0b6f741ca38f9ebd6c1a308f95e56faa5a8e2a (diff)
downloadports-c44aa1025fcba37a9681ff3c349fdad8085af0ef.tar.gz
ports-c44aa1025fcba37a9681ff3c349fdad8085af0ef.zip
Notes
Diffstat (limited to 'java/eclipse-log4e')
-rw-r--r--java/eclipse-log4e/Makefile31
-rw-r--r--java/eclipse-log4e/distinfo2
-rw-r--r--java/eclipse-log4e/pkg-descr12
-rw-r--r--java/eclipse-log4e/pkg-plist26
4 files changed, 71 insertions, 0 deletions
diff --git a/java/eclipse-log4e/Makefile b/java/eclipse-log4e/Makefile
new file mode 100644
index 000000000000..1f2666421c36
--- /dev/null
+++ b/java/eclipse-log4e/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: eclipse-log4e
+# Date created: August 30, 2004
+# Whom: sugimura@jp.FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= log4e
+PORTVERSION= 0.7.6
+CATEGORIES= java
+MASTER_SITES= http://log4e.jayefem.de/download/eclipse3/
+PKGNAMEPREFIX= eclipse-
+DISTNAME= de.jayefem.${PORTNAME}_${PORTVERSION}
+EXTRACT_SUFX= .zip
+DIST_SUBDIR= eclipse
+
+MAINTAINER= sugimura@jp.FreeBSD.ORG
+COMMENT= Eclipse plugin to use logger easily in Java projects
+
+RUN_DEPENDS= ${LOCALBASE}/bin/eclipse:${PORTSDIR}/java/eclipse
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+USE_ZIP= yes
+
+do-install:
+ @${MKDIR} ${PREFIX}/eclipse
+ @${CP} -r ${WRKSRC}/plugins ${PREFIX}/eclipse
+ @${CP} -r ${WRKSRC}/features ${PREFIX}/eclipse
+
+.include <bsd.port.mk>
diff --git a/java/eclipse-log4e/distinfo b/java/eclipse-log4e/distinfo
new file mode 100644
index 000000000000..e844e3ecead6
--- /dev/null
+++ b/java/eclipse-log4e/distinfo
@@ -0,0 +1,2 @@
+MD5 (eclipse/de.jayefem.log4e_0.7.6.zip) = 64cd674a80da7d53a4f54b79fc125fea
+SIZE (eclipse/de.jayefem.log4e_0.7.6.zip) = 779542
diff --git a/java/eclipse-log4e/pkg-descr b/java/eclipse-log4e/pkg-descr
new file mode 100644
index 000000000000..a36016542723
--- /dev/null
+++ b/java/eclipse-log4e/pkg-descr
@@ -0,0 +1,12 @@
+Log4E
+
+Log4E is a free Eclipse Plugin which helps you to use your logger easily
+in Java Projects. The Plugin Log4E is not bound to any special logging
+framework. Thus you might be able to adapt to your own logger by defining
+your own templates using the preferences. It has active support for Log4j,
+Commons Logging and JDK 1.4 logging. Use the context menu of a java file
+or the context menu of an editor and get to the submenu "Log4".
+Notice that the editor submenu provides additional tasks.
+Every of the following tasks can be invoked either on class or on method level.
+
+WWW: http://log4e.jayefem.de
diff --git a/java/eclipse-log4e/pkg-plist b/java/eclipse-log4e/pkg-plist
new file mode 100644
index 000000000000..11751773c551
--- /dev/null
+++ b/java/eclipse-log4e/pkg-plist
@@ -0,0 +1,26 @@
+eclipse/features/de.jayefem.log4e.feature_0.7.6/eclipse_update_120.jpg
+eclipse/features/de.jayefem.log4e.feature_0.7.6/feature.properties
+eclipse/features/de.jayefem.log4e.feature_0.7.6/feature.xml
+eclipse/features/de.jayefem.log4e.feature_0.7.6/general.css
+eclipse/features/de.jayefem.log4e.feature_0.7.6/license.html
+eclipse/plugins/de.jayefem.log4e.help_0.7.6/doc.zip
+eclipse/plugins/de.jayefem.log4e.help_0.7.6/plugin.properties
+eclipse/plugins/de.jayefem.log4e.help_0.7.6/plugin.xml
+eclipse/plugins/de.jayefem.log4e.help_0.7.6/toc.xml
+eclipse/plugins/de.jayefem.log4e_0.7.6/about.html
+eclipse/plugins/de.jayefem.log4e_0.7.6/about.ini
+eclipse/plugins/de.jayefem.log4e_0.7.6/about.properties
+eclipse/plugins/de.jayefem.log4e_0.7.6/eclipse32.gif
+eclipse/plugins/de.jayefem.log4e_0.7.6/lib/commons-logging.jar
+eclipse/plugins/de.jayefem.log4e_0.7.6/lib/log4j-1.2.8.jar
+eclipse/plugins/de.jayefem.log4e_0.7.6/log4e.jar
+eclipse/plugins/de.jayefem.log4e_0.7.6/plugin.properties
+eclipse/plugins/de.jayefem.log4e_0.7.6/plugin.xml
+eclipse/plugins/de.jayefem.log4e_0.7.6/welcome.xml
+@dirrm eclipse/features/de.jayefem.log4e.feature_0.7.6
+@dirrm eclipse/plugins/de.jayefem.log4e_0.7.6/lib
+@dirrm eclipse/plugins/de.jayefem.log4e_0.7.6
+@dirrm eclipse/plugins/de.jayefem.log4e.help_0.7.6
+@unexec rmdir %D/eclipse/plugins 2>/dev/null || true
+@unexec rmdir %D/eclipse/features 2>/dev/null || true
+@unexec rmdir %D/eclipse 2>/dev/null || true