aboutsummaryrefslogtreecommitdiff
path: root/java/eclipse-ocl
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2010-07-25 07:05:41 +0000
committerGreg Lewis <glewis@FreeBSD.org>2010-07-25 07:05:41 +0000
commit8864791a158ced6c407bae3ee2112265c84dfcf5 (patch)
tree31d8995f2ceae0a0d4c08d04ec257221837211b8 /java/eclipse-ocl
parent744dba72964bfa0cb0ef5832111088f8d4bdb3a4 (diff)
downloadports-8864791a158ced6c407bae3ee2112265c84dfcf5.tar.gz
ports-8864791a158ced6c407bae3ee2112265c84dfcf5.zip
Notes
Diffstat (limited to 'java/eclipse-ocl')
-rw-r--r--java/eclipse-ocl/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/java/eclipse-ocl/Makefile b/java/eclipse-ocl/Makefile
index 0d91af743c0f..91c15f1f05e2 100644
--- a/java/eclipse-ocl/Makefile
+++ b/java/eclipse-ocl/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ocl
DISTVERSION= 1.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= java devel
MASTER_SITES= ${MASTER_SITE_ECLIPSE:S,/eclipse/downloads/drops/,/modeling/mdt/ocl/downloads/drops/,}
MASTER_SITE_SUBDIR=${DISTVERSION}.0/R200706201142
@@ -19,7 +19,7 @@ MAINTAINER= vj562001@yahoo.de
COMMENT= Implementation of the OCL OMG standard for EMF-based models
RUN_DEPENDS= eclipse:${PORTSDIR}/java/eclipse \
- ${LOCALBASE}/eclipse/features/org.eclipse.emf_2.3.2.v200802051830/feature.xml:${PORTSDIR}/java/eclipse-emf
+ ${LOCALBASE}/lib/eclipse/features/org.eclipse.emf_2.3.2.v200802051830/feature.xml:${PORTSDIR}/java/eclipse-emf
NO_BUILD= yes
NO_WRKSUBDIR= yes
@@ -29,12 +29,12 @@ JAVA_VERSION= 1.4+
JAVA_OS= native
do-install:
- @${MKDIR} ${PREFIX}/eclipse
- @${CP} -r ${WRKSRC}/eclipse/plugins ${PREFIX}/eclipse
- @${CP} -r ${WRKSRC}/eclipse/features ${PREFIX}/eclipse
- @(cd ${WRKSRC}; ${FIND} -s eclipse/features eclipse/plugins -not -type d) >> ${TMPPLIST}
+ @${MKDIR} ${PREFIX}/lib/eclipse
+ @${CP} -r ${WRKSRC}/eclipse/plugins ${PREFIX}/lib/eclipse
+ @${CP} -r ${WRKSRC}/eclipse/features ${PREFIX}/lib/eclipse
+ @(cd ${WRKSRC}; ${FIND} -s eclipse/features eclipse/plugins -not -type d) | ${SED} -e 's,^eclipse,lib/eclipse,' >> ${TMPPLIST}
@(cd ${WRKSRC}; ${FIND} -s -d eclipse/features eclipse/plugins -type d) \
| ${GREP} -vE 'eclipse/plugins$$|eclipse/features$$' \
- | ${SED} -ne 's,^,@dirrm ,p' >> ${TMPPLIST}
+ | ${SED} -ne 's,^,@dirrm lib/,p' >> ${TMPPLIST}
.include <bsd.port.mk>