aboutsummaryrefslogtreecommitdiff
path: root/java/eclipse-pmd/Makefile
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2004-09-03 20:29:33 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2004-09-03 20:29:33 +0000
commit67b40246dd1d3b221861530b6dbda651ec89b31b (patch)
treeeaee97b08bd12825bb8c56e2acf5f6c92866a017 /java/eclipse-pmd/Makefile
parent3648da397a379830543b2e6ec9f779bbf8d166c6 (diff)
downloadports-67b40246dd1d3b221861530b6dbda651ec89b31b.tar.gz
ports-67b40246dd1d3b221861530b6dbda651ec89b31b.zip
Notes
Diffstat (limited to 'java/eclipse-pmd/Makefile')
-rw-r--r--java/eclipse-pmd/Makefile50
1 files changed, 41 insertions, 9 deletions
diff --git a/java/eclipse-pmd/Makefile b/java/eclipse-pmd/Makefile
index f1dd6709b46d..f99bd89eef2f 100644
--- a/java/eclipse-pmd/Makefile
+++ b/java/eclipse-pmd/Makefile
@@ -1,40 +1,72 @@
# New ports collection makefile for: eclipse-pmd
# Date created: October 3, 2003
-# Whom: Bruno Van Den Bossche <bruno.van.den.bossche@pandora.be>
+# Whom: Bruno Van Den Bossche <brvdboss@spymac.com>
#
# $FreeBSD$
#
PORTNAME= pmd
-PORTVERSION= 1.1.2
+PORTVERSION= 2.0.5.v3
CATEGORIES= java devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= pmd
PKGNAMEPREFIX= eclipse-
-DISTNAME= pmd-eclipse-bin-${PORTVERSION}
+DISTNAME= pmd-eclipse3-site-2.0.5
DIST_SUBDIR= eclipse
MAINTAINER= java@FreeBSD.org
COMMENT= Scan Java source code and look for potential problems
-IGNORE= is too hard to adopt Eclipse 3.0
+RUN_DEPENDS= ${LOCALBASE}/bin/eclipse:${PORTSDIR}/java/eclipse
NO_BUILD= yes
NO_WRKSUBDIR= yes
USE_ZIP= yes
+USE_JAVA= yes
CPIO?= cpio --quiet -pdmu -R
-PLUGIN_DIR= "net.sourceforge.pmd.eclipse_${PORTVERSION}"
+PMDVERSION= 1.8.0.v3
-PLIST_SUB+= PLUGIN_DIR="${PLUGIN_DIR}"
+PLUGIN_CORE_DIR="net.sourceforge.pmd.core_${PMDVERSION}"
+PLUGIN_PMD_DIR= "net.sourceforge.pmd.eclipse_${PORTVERSION}"
+
+PLIST_SUB+= PLUGIN_PMD_DIR="${PLUGIN_PMD_DIR}" \
+ PLUGIN_CORE_DIR="${PLUGIN_CORE_DIR}"
+
+post-extract:
+ cd ${WRKDIR}/features && ${MKDIR} ${PLUGIN_PMD_DIR} \
+ && ${CP} ${PLUGIN_PMD_DIR}.jar ${PLUGIN_PMD_DIR} \
+ && cd ${PLUGIN_PMD_DIR} \
+ && ${JAR} xvf ${PLUGIN_PMD_DIR}.jar \
+ && ${RM} ${PLUGIN_PMD_DIR}.jar
+
+ cd ${WRKDIR}/plugins && ${MKDIR} ${PLUGIN_PMD_DIR} \
+ && ${CP} ${PLUGIN_PMD_DIR}.jar ${PLUGIN_PMD_DIR} \
+ && cd ${PLUGIN_PMD_DIR} \
+ && ${JAR} xvf ${PLUGIN_PMD_DIR}.jar \
+ && ${RM} ${PLUGIN_PMD_DIR}.jar
+
+ cd ${WRKDIR}/plugins && ${MKDIR} ${PLUGIN_CORE_DIR} \
+ && ${CP} ${PLUGIN_CORE_DIR}.jar ${PLUGIN_CORE_DIR} \
+ && cd ${PLUGIN_CORE_DIR} \
+ && ${JAR} xvf ${PLUGIN_CORE_DIR}.jar \
+ && ${RM} ${PLUGIN_CORE_DIR}.jar
do-install:
@${MKDIR} ${PREFIX}/eclipse
@${MKDIR} ${PREFIX}/eclipse/plugins
- @${MKDIR} ${PREFIX}/eclipse/plugins/${PLUGIN_DIR}
- cd ${WRKSRC}/${PLUGIN_DIR} && ${FIND} . \
+ @${MKDIR} ${PREFIX}/eclipse/plugins/${PLUGIN_PMD_DIR}
+ @${MKDIR} ${PREFIX}/eclipse/plugins/${PLUGIN_CORE_DIR}
+ @${MKDIR} ${PREFIX}/eclipse/features/${PLUGIN_PMD_DIR}
+ cd ${WRKDIR}/features/${PLUGIN_PMD_DIR} && ${FIND} . \
+ | ${CPIO} ${SHAREOWN}:${SHAREGRP} \
+ ${PREFIX}/eclipse/features/${PLUGIN_PMD_DIR}
+ cd ${WRKDIR}/plugins/${PLUGIN_PMD_DIR} && ${FIND} . \
+ | ${CPIO} ${SHAREOWN}:${SHAREGRP} \
+ ${PREFIX}/eclipse/plugins/${PLUGIN_PMD_DIR}
+ cd ${WRKDIR}/plugins/${PLUGIN_CORE_DIR} && ${FIND} . \
| ${CPIO} ${SHAREOWN}:${SHAREGRP} \
- ${PREFIX}/eclipse/plugins/${PLUGIN_DIR}
+ ${PREFIX}/eclipse/plugins/${PLUGIN_CORE_DIR}
.include <bsd.port.mk>