aboutsummaryrefslogtreecommitdiff
path: root/java/eclipse-webtools/Makefile
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2010-09-07 09:34:13 +0000
committerAlex Dupre <ale@FreeBSD.org>2010-09-07 09:34:13 +0000
commit3eb3831852d91a3891d36c693cc69ae8b829b1c5 (patch)
tree4b63d5d4f52bebb7c4ffcbe455ef22be1626419a /java/eclipse-webtools/Makefile
parentce765fb4a43fecd56b1901c2463916575c5affec (diff)
downloadports-3eb3831852d91a3891d36c693cc69ae8b829b1c5.tar.gz
ports-3eb3831852d91a3891d36c693cc69ae8b829b1c5.zip
Notes
Diffstat (limited to 'java/eclipse-webtools/Makefile')
-rw-r--r--java/eclipse-webtools/Makefile52
1 files changed, 17 insertions, 35 deletions
diff --git a/java/eclipse-webtools/Makefile b/java/eclipse-webtools/Makefile
index 79e559801e77..192c8a468d64 100644
--- a/java/eclipse-webtools/Makefile
+++ b/java/eclipse-webtools/Makefile
@@ -6,50 +6,32 @@
#
PORTNAME= webtools
-PORTVERSION= 2.0.3
-PORTREVISION= 3
+PORTVERSION= 3.1.2
CATEGORIES= java devel www
MASTER_SITES= ${MASTER_SITE_ECLIPSE:S,/eclipse/downloads/drops/,/webtools/downloads/drops/,}
-MASTER_SITE_SUBDIR= R2.0/R-${PORTVERSION}-20080710044639/
+MASTER_SITE_SUBDIR= R3.1.2/R-${PORTVERSION}-20100211202452
PKGNAMEPREFIX= eclipse-
-DISTNAME= wtp-R-${PORTVERSION}-20080710044639
+DISTNAME= wtp-R-${PORTVERSION}-20100211202452
DIST_SUBDIR= eclipse
-MAINTAINER= freebsd-eclipse@FreeBSD.org
+MAINTAINER= zhoushuqun@gmail.com
COMMENT= Webtools for eclipse
RUN_DEPENDS= eclipse:${PORTSDIR}/java/eclipse \
- ${LOCALBASE}/lib/eclipse/features/org.eclipse.emf_2.3.2.v200802051830/feature.xml:${PORTSDIR}/java/eclipse-emf \
- ${LOCALBASE}/lib/eclipse/features/org.eclipse.gef_3.3.2.v20080129/feature.xml:${PORTSDIR}/java/eclipse-gef
+ ${LOCALBASE}/share/eclipse/dropins/emf:${PORTSDIR}/java/eclipse-emf \
+ ${LOCALBASE}/share/eclipse/dropins/gef:${PORTSDIR}/java/eclipse-gef
-CONFLICTS= eclipse-lomboz-3.*
-
-NO_BUILD= yes
-NO_WRKSUBDIR= yes
+WRKSRC= ${WRKDIR}/eclipse
USE_ZIP= yes
-USE_JAVA= yes
-JAVA_VERSION= 1.5+
-JAVA_OS= native
-
-# remove files that already exist on the RUN_DEPENDS java/eclipse port
-REMOVE_DUPLICATE_FILES= \
- eclipse/plugins/javax.servlet.jsp_2.0.0.v200706191603.jar \
- eclipse/plugins/javax.servlet_2.4.0.v200706111738.jar \
- eclipse/plugins/org.apache.commons.el_1.0.0.v200706111724.jar \
- eclipse/plugins/org.apache.commons.logging_1.0.4.v200706111724.jar
-
-post-extract:
-.for file in ${REMOVE_DUPLICATE_FILES}
- @${RM} -f ${WRKSRC}/${file}
-.endfor
-
-do-install:
- @${MKDIR} ${PREFIX}/lib/eclipse
- @${CP} -r ${WRKSRC}/eclipse/plugins ${PREFIX}/lib/eclipse
- @${CP} -r ${WRKSRC}/eclipse/features ${PREFIX}/lib/eclipse
- @(cd ${WRKSRC}; ${FIND} -s eclipse/features eclipse/plugins -not -type d) | ${SED} -e 's,^eclipse,lib/eclipse,' >> ${TMPPLIST}
- @(cd ${WRKSRC}; ${FIND} -s -d eclipse/features eclipse/plugins -type d) \
- | ${GREP} -vE 'eclipse/plugins$$|eclipse/features$$' \
- | ${SED} -ne 's,^,@dirrm lib/,p' >> ${TMPPLIST}
+
+OPTIONS= DTP "Enable support for EJB and JPT development" on
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_DTP)
+RUN_DEPENDS+= ${LOCALBASE}/share/eclipse/dropins/datatools:${PORTSDIR}/java/eclipse-datatools
+.endif
+
+.include "${.CURDIR}/../eclipse/Makefile.plugins"
.include <bsd.port.mk>