aboutsummaryrefslogtreecommitdiff
path: root/java/eclipse-webtools/Makefile
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2005-10-15 13:54:45 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2005-10-15 13:54:45 +0000
commitfd0bc66f9f7c005ded9680b3cd589276febe8535 (patch)
tree35ed55325c76c935b562fad6f3be97055325b9b7 /java/eclipse-webtools/Makefile
parent12df1acc45d2df1b56bdf26e6dff47a490ede4b4 (diff)
downloadports-fd0bc66f9f7c005ded9680b3cd589276febe8535.tar.gz
ports-fd0bc66f9f7c005ded9680b3cd589276febe8535.zip
Notes
Diffstat (limited to 'java/eclipse-webtools/Makefile')
-rw-r--r--java/eclipse-webtools/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/java/eclipse-webtools/Makefile b/java/eclipse-webtools/Makefile
new file mode 100644
index 000000000000..8571e0b53c74
--- /dev/null
+++ b/java/eclipse-webtools/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: eclipse-webtools
+# Date created: October 14, 2005
+# Whom: markhobden@gmail.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= webtools
+PORTVERSION= 0.7
+CATEGORIES= java devel www
+MASTER_SITES= http://download.eclipse.org/webtools/downloads/drops/R-${PORTVERSION}-200507290654/
+PKGNAMEPREFIX= eclipse-
+DISTNAME= wtp-${PORTVERSION}
+DIST_SUBDIR= eclipse
+
+MAINTAINER= freebsd-eclipse@FreeBSD.org
+COMMENT= Webtools for eclipse
+
+RUN_DEPENDS= ${LOCALBASE}/bin/eclipse:${PORTSDIR}/java/eclipse \
+ ${LOCALBASE}/eclipse/features/org.eclipse.emf_2.1.1/feature.xml:${PORTSDIR}/java/eclipse-emf \
+ ${LOCALBASE}/eclipse/features/org.eclipse.gef_3.1.1/feature.xml:${PORTSDIR}/java/eclipse-gef \
+ ${LOCALBASE}/eclipse/features/org.eclipse.jem_1.1.0.1/feature.xml:${PORTSDIR}/java/eclipse-vep
+
+CONFLICTS= eclipse-lomboz-3.*
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+USE_ZIP= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+JAVA_OS= native
+
+do-install:
+ @${MKDIR} ${PREFIX}/eclipse
+ @${CP} -r ${WRKSRC}/eclipse/plugins ${PREFIX}/eclipse
+ @${CP} -r ${WRKSRC}/eclipse/features ${PREFIX}/eclipse
+ @(cd ${WRKSRC}; ${FIND} -s eclipse/features eclipse/plugins -not -type d) >> ${TMPPLIST}
+ @(cd ${WRKSRC}; ${FIND} -s -d eclipse/features eclipse/plugins -type d) \
+ | ${GREP} -vE 'eclipse/plugins$$|eclipse/features$$' \
+ | ${SED} -ne 's,^,@dirrm ,p' >> ${TMPPLIST}
+
+.include <bsd.port.mk>