aboutsummaryrefslogtreecommitdiff
path: root/java/eclipse/Makefile.plugins
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2019-04-14 12:07:04 +0000
committerKurt Jaeger <pi@FreeBSD.org>2019-04-14 12:07:04 +0000
commitb7a189e76aeb76859445ed949de8c016ff193393 (patch)
tree0365ec740e33f124b21a439d4a624e989ae3251e /java/eclipse/Makefile.plugins
parent8b76c85ac4be40b598ba238683abceaf6f8bc71b (diff)
downloadports-b7a189e76aeb76859445ed949de8c016ff193393.tar.gz
ports-b7a189e76aeb76859445ed949de8c016ff193393.zip
Notes
Diffstat (limited to 'java/eclipse/Makefile.plugins')
-rw-r--r--java/eclipse/Makefile.plugins3
1 files changed, 2 insertions, 1 deletions
diff --git a/java/eclipse/Makefile.plugins b/java/eclipse/Makefile.plugins
index 19a025d0551a..2b4e9ce21dfe 100644
--- a/java/eclipse/Makefile.plugins
+++ b/java/eclipse/Makefile.plugins
@@ -3,10 +3,11 @@ NO_BUILD= yes
USE_JAVA= yes
JAVA_VERSION= 1.8+
-REPO_DIRS?= features plugins
+REPO_DIRS?= features plugins
do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/share/eclipse/dropins/${PORTNAME}/eclipse
@(cd ${WRKSRC}; ${COPYTREE_SHARE} "${REPO_DIRS}" ${STAGEDIR}${PREFIX}/share/eclipse/dropins/${PORTNAME}/eclipse/)
@(cd ${STAGEDIR}${PREFIX}; ${FIND} -s share/eclipse/dropins/${PORTNAME} -not -type d) >> ${TMPPLIST}
@(cd ${STAGEDIR}${PREFIX}; ${FIND} -s -d share/eclipse/dropins/${PORTNAME} -type d -empty) | ${SED} -ne 's,^,@dir ,p' >> ${TMPPLIST}
+