aboutsummaryrefslogtreecommitdiff
path: root/java/eclipse/Makefile
diff options
context:
space:
mode:
authorAlexander Nedotsukov <bland@FreeBSD.org>2005-11-06 12:44:04 +0000
committerAlexander Nedotsukov <bland@FreeBSD.org>2005-11-06 12:44:04 +0000
commitb21cdf2cf2c096329cc0cd9c2b0d87415508b3f2 (patch)
treee5ba9fc53651c97da6b80d4fa552591b16c9cc19 /java/eclipse/Makefile
parent041b1fb76fd541fe586b561eb464dfff39106465 (diff)
Unbreak build with cairo 1.0.
Patch by: Andreas Kohn <andreas@syndrom23.de>
Notes
Notes: svn path=/head/; revision=147440
Diffstat (limited to 'java/eclipse/Makefile')
-rw-r--r--java/eclipse/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/java/eclipse/Makefile b/java/eclipse/Makefile
index b8be8dff58bc..1d557ff50a08 100644
--- a/java/eclipse/Makefile
+++ b/java/eclipse/Makefile
@@ -95,6 +95,7 @@ MAKE_ENV+= BROWSER=${BROWSER} \
PLIST_FILES= bin/eclipse share/applications/eclipse.desktop
+SWTCAIRO=${WRKSRC}/plugins/org.eclipse.swt/Eclipse SWT PI/cairo/library
SWTGTK=${WRKSRC}/plugins/org.eclipse.swt/Eclipse SWT PI/gtk/library
SWTMOTIF=${WRKSRC}/plugins/org.eclipse.swt/Eclipse SWT PI/motif/library
@@ -108,9 +109,16 @@ post-patch:
${FILESDIR}/manualpatch-plugins-swt-gtk-make_freebsd.mak
@${PATCH} ${PATCH_DIST_ARGS} "${SWTGTK}/build.sh" \
${FILESDIR}/manualpatch-plugins-swt-gtk-build.sh
- @${PATCH} ${PATCH_DIST_ARGS} "${SWTGTK}/os_custom.h" \
- ${FILESDIR}/manualpatch-plugins-swt-gtk-os_custom.h
-
+ @${PATCH} ${PATCH_DIST_ARGS} \
+ "plugins/org.eclipse.swt/Eclipse SWT PI/cairo/library/cairo.c" \
+ ${FILESDIR}/manualpatch-plugins-swt-cairo-library \
+ + "plugins/org.eclipse.swt/Eclipse SWT PI/cairo/library/cairo.h" \
+ + "plugins/org.eclipse.swt/Eclipse SWT PI/cairo/library/cairo_custom.c" \
+ + "plugins/org.eclipse.swt/Eclipse SWT PI/cairo/library/cairo_stats.c" \
+ + "plugins/org.eclipse.swt/Eclipse SWT PI/cairo/library/cairo_stats.h" \
+ + "plugins/org.eclipse.swt/Eclipse SWT PI/cairo/library/cairo_structs.c" \
+ + "plugins/org.eclipse.swt/Eclipse SWT PI/cairo/library/cairo_structs.h"
+
do-build:
@(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} \
./build -os ${ECLIPSE_OS} -ws ${ECLIPSE_WS} -arch ${ECLIPSE_ARCH} -compilelibs)