aboutsummaryrefslogtreecommitdiff
path: root/java/eclipse
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2010-09-07 08:40:13 +0000
committerAlex Dupre <ale@FreeBSD.org>2010-09-07 08:40:13 +0000
commit7afa2f3cd249bd5ba8762f12230ed9bf2c47a6d1 (patch)
tree59aba23cdaab8951ed531d6236a92522efafac80 /java/eclipse
parentc1c429e85f4829c5f3b7b879233afd73454ab632 (diff)
downloadports-7afa2f3cd249bd5ba8762f12230ed9bf2c47a6d1.tar.gz
ports-7afa2f3cd249bd5ba8762f12230ed9bf2c47a6d1.zip
Notes
Diffstat (limited to 'java/eclipse')
-rw-r--r--java/eclipse/Makefile1
-rw-r--r--java/eclipse/Makefile.plugins13
2 files changed, 14 insertions, 0 deletions
diff --git a/java/eclipse/Makefile b/java/eclipse/Makefile
index 77edc3d51006..6adf8c107643 100644
--- a/java/eclipse/Makefile
+++ b/java/eclipse/Makefile
@@ -222,6 +222,7 @@ do-install:
-@update-desktop-database
@(cd ${PREFIX}; ${FIND} -s lib/${PORTNAME} -not -type d) >> ${TMPPLIST}
@(cd ${PREFIX}; ${FIND} -s -d lib/${PORTNAME} -type d) | ${SED} -ne "s,^,@dirrm ,p" >> ${TMPPLIST}
+ @${ECHO_CMD} "@exec ${MKDIR} %D/share/${PORTNAME}/dropins 2> /dev/null || /usr/bin/true" >> ${TMPPLIST}
@${ECHO_CMD} "@unexec ${RMDIR} %D/share/${PORTNAME}/dropins 2>/dev/null || true " >> ${TMPPLIST}
@${ECHO_CMD} "@unexec ${RMDIR} %D/share/${PORTNAME} 2>/dev/null || true " >> ${TMPPLIST}
@${ECHO_CMD} "@exec ${PREFIX}/bin/update-desktop-database > /dev/null || /usr/bin/true" >> ${TMPPLIST}
diff --git a/java/eclipse/Makefile.plugins b/java/eclipse/Makefile.plugins
new file mode 100644
index 000000000000..73dc1993d181
--- /dev/null
+++ b/java/eclipse/Makefile.plugins
@@ -0,0 +1,13 @@
+NO_BUILD= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.6
+JAVA_OS= native
+
+REPO_DIRS?= features plugins
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/eclipse/dropins/${PORTNAME}/eclipse
+ @(cd ${WRKSRC}; ${COPYTREE_SHARE} "${REPO_DIRS}" ${PREFIX}/share/eclipse/dropins/${PORTNAME}/eclipse/)
+ @(cd ${PREFIX}; ${FIND} -s share/eclipse/dropins/${PORTNAME} -not -type d) >> ${TMPPLIST}
+ @(cd ${PREFIX}; ${FIND} -s -d share/eclipse/dropins/${PORTNAME} -type d) \
+ | ${SED} -ne 's,^,@dirrm ,p' >> ${TMPPLIST}