aboutsummaryrefslogtreecommitdiff
path: root/java/eclipse
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-07-11 21:56:01 +0000
committerJohn Marino <marino@FreeBSD.org>2014-07-11 21:56:01 +0000
commit855d8ebe1328713a315f9816951c5dcec3c125c9 (patch)
treeb4736fd060552b811810f82c84dc747fe8aee294 /java/eclipse
parent469ab7f8ac2afd712682562c0de60be68838576c (diff)
downloadports-855d8ebe1328713a315f9816951c5dcec3c125c9.tar.gz
ports-855d8ebe1328713a315f9816951c5dcec3c125c9.zip
java/eclipse: Fix dropins location
The new 4.3.2 Eclipse port doesn't look for dropins in the "standard" FreeBSD location (/usr/local/share/eclipse/dropins) as expected. The eclipse.ini file has been modified to make that happen. PR: 191766 Submitted by: maintainer (Jimmy Kelly)
Notes
Notes: svn path=/head/; revision=361589
Diffstat (limited to 'java/eclipse')
-rw-r--r--java/eclipse/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/java/eclipse/Makefile b/java/eclipse/Makefile
index f3bd95b5c3dc..3bdc50360bc3 100644
--- a/java/eclipse/Makefile
+++ b/java/eclipse/Makefile
@@ -3,6 +3,7 @@
PORTNAME= eclipse
PORTVERSION= 4.3.2
+PORTREVISION= 1
CATEGORIES= java devel
MASTER_SITES= https://googledrive.com/host/0B2kYpXHnC5LpSk01bU1ud0N5bXc/
DISTFILES= eclipse.platform.releng.aggregator-${PORTVERSION}.xz \
@@ -114,6 +115,8 @@ do-install:
@(cd ${STAGEDIR}${PREFIX}; ${FIND} -s -d lib/eclipse -type d) | ${SED} -ne "s,^,@dirrm ,p" >> ${TMPPLIST}
@${ECHO_CMD} "@exec ${MKDIR} %D/lib/eclipse/dropins > /dev/null || ${TRUE}" >> ${TMPPLIST}
@${ECHO_CMD} "@exec ${MKDIR} %D/share/eclipse/dropins > /dev/null || ${TRUE}" >> ${TMPPLIST}
+ @${ECHO_CMD} "@exec echo '-Dorg.eclipse.equinox.p2.reconciler.dropins.directory=%D/share/eclipse/dropins' >> %D/lib/eclipse/eclipse.ini" >> ${TMPPLIST}
+ @${ECHO_CMD} "@unexec ${SED} -i '' '/^-Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/d' %D/lib/eclipse/eclipse.ini" >> ${TMPPLIST}
@${ECHO_CMD} "@dirrm share/eclipse/dropins" >> ${TMPPLIST}
@${ECHO_CMD} "@dirrm share/eclipse" >> ${TMPPLIST}