aboutsummaryrefslogtreecommitdiff
path: root/java/eclipse
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2014-01-22 08:36:48 +0000
committerAlex Dupre <ale@FreeBSD.org>2014-01-22 08:36:48 +0000
commit1d3344e7ee7e9f1ad3146a72515889fccb6a34dc (patch)
treeb2829dad2baaadbd75e5d8adf343ffb900b665fd /java/eclipse
parentcc5cc06ce2750aac985592e50ea41e0ee87f8703 (diff)
downloadports-1d3344e7ee7e9f1ad3146a72515889fccb6a34dc.tar.gz
ports-1d3344e7ee7e9f1ad3146a72515889fccb6a34dc.zip
Notes
Diffstat (limited to 'java/eclipse')
-rw-r--r--java/eclipse/Makefile.plugins8
1 files changed, 4 insertions, 4 deletions
diff --git a/java/eclipse/Makefile.plugins b/java/eclipse/Makefile.plugins
index 73dc1993d181..de1e2ea1fcf2 100644
--- a/java/eclipse/Makefile.plugins
+++ b/java/eclipse/Makefile.plugins
@@ -6,8 +6,8 @@ JAVA_OS= native
REPO_DIRS?= features plugins
do-install:
- @${MKDIR} ${PREFIX}/share/eclipse/dropins/${PORTNAME}/eclipse
- @(cd ${WRKSRC}; ${COPYTREE_SHARE} "${REPO_DIRS}" ${PREFIX}/share/eclipse/dropins/${PORTNAME}/eclipse/)
- @(cd ${PREFIX}; ${FIND} -s share/eclipse/dropins/${PORTNAME} -not -type d) >> ${TMPPLIST}
- @(cd ${PREFIX}; ${FIND} -s -d share/eclipse/dropins/${PORTNAME} -type d) \
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/eclipse/dropins/${PORTNAME}/eclipse
+ @(cd ${WRKSRC}; ${COPYTREE_SHARE} "${REPO_DIRS}" ${STAGEDIR}${PREFIX}/share/eclipse/dropins/${PORTNAME}/eclipse/)
+ @(cd ${STAGEDIR}${PREFIX}; ${FIND} -s share/eclipse/dropins/${PORTNAME} -not -type d) >> ${TMPPLIST}
+ @(cd ${STAGEDIR}${PREFIX}; ${FIND} -s -d share/eclipse/dropins/${PORTNAME} -type d) \
| ${SED} -ne 's,^,@dirrm ,p' >> ${TMPPLIST}