aboutsummaryrefslogtreecommitdiff
path: root/java/eclipse
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2013-03-03 02:51:25 +0000
committerGreg Lewis <glewis@FreeBSD.org>2013-03-03 02:51:25 +0000
commita4674fe17793bf6f2fafe03f2da70c1fa9762059 (patch)
treea62a357bb5244e71815fdc51648cff587a509758 /java/eclipse
parent1a0966f6a07be723051ab659043ddd846126e180 (diff)
downloadports-a4674fe17793bf6f2fafe03f2da70c1fa9762059.tar.gz
ports-a4674fe17793bf6f2fafe03f2da70c1fa9762059.zip
Notes
Diffstat (limited to 'java/eclipse')
-rw-r--r--java/eclipse/Makefile6
-rw-r--r--java/eclipse/files/freebsd-support.patch21
2 files changed, 24 insertions, 3 deletions
diff --git a/java/eclipse/Makefile b/java/eclipse/Makefile
index 1a7eceaf6d12..2498d87a6069 100644
--- a/java/eclipse/Makefile
+++ b/java/eclipse/Makefile
@@ -2,7 +2,7 @@
PORTNAME= eclipse
PORTVERSION= 3.7.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= java devel
MASTER_SITES= http://download.eclipse.org/technology/linuxtools/eclipse-build/3.7.x_Indigo/:1 \
http://download.eclipse.org/tools/orbit/downloads/drops/R20110523182458/repository/plugins/:2 \
@@ -32,7 +32,8 @@ BUILD_DEPENDS= gpatch:${PORTSDIR}/devel/patch \
rsync:${PORTSDIR}/net/rsync \
unzip:${PORTSDIR}/archivers/unzip \
zip:${PORTSDIR}/archivers/zip
-LIB_DEPENDS= cairo.2:${PORTSDIR}/graphics/cairo
+LIB_DEPENDS= cairo.2:${PORTSDIR}/graphics/cairo \
+ webkitgtk-1.0.0:${PORTSDIR}/www/webkit-gtk2
OPTIONS_DEFINE= TESTS
TESTS_DESC= Build SDK test suite
@@ -40,7 +41,6 @@ TESTS_DESC= Build SDK test suite
ONLY_FOR_ARCHS= i386 amd64
USE_ANT= yes
-USE_GECKO= libxul19
USE_GL= glu
USE_GMAKE= yes
USE_GNOME= desktopfileutils gconf2 gtk20 gnomevfs2 libgnome libgnomeui
diff --git a/java/eclipse/files/freebsd-support.patch b/java/eclipse/files/freebsd-support.patch
index 90d530fd4805..a2315dab73b3 100644
--- a/java/eclipse/files/freebsd-support.patch
+++ b/java/eclipse/files/freebsd-support.patch
@@ -7459,3 +7459,24 @@ $FreeBSD$
else
echo "None of the following libraries were found: Mozilla/XPCOM, Firefox/XPCOM, or XULRunner/XPCOM"
echo " *** Mozilla embedding support will not be compiled."
+--- build/eclipse-3.7.1-src/plugins/org.eclipse.swt/Eclipse SWT PI/gtk/library/build.sh.orig 2012-12-25 21:01:56.000000000 -0600
++++ build/eclipse-3.7.1-src/plugins/org.eclipse.swt/Eclipse SWT PI/gtk/library/build.sh 2012-12-25 21:28:35.000000000 -0600
+@@ -491,7 +491,7 @@
+ export MOZILLA_INCLUDES
+ export MOZILLA_LIBS
+ MAKE_MOZILLA=make_mozilla
+- elif [ x`pkg-config --exists libxul && echo YES` = "xYES" ]; then
++ elif [ x`pkg-config --exists "libxul < 2" && echo YES` = "xYES" ]; then
+ XULRUNNER_INCLUDES=`pkg-config --cflags libxul`
+ XULRUNNER_LIBS=`pkg-config --libs libxul`
+ XULRUNNER_LIBS=`echo ${XULRUNNER_LIBS} -lxpcomglue`
+--- build/eclipse-3.7.1-src/plugins/org.eclipse.swt/Eclipse SWT PI/gtk/library/make_freebsd.mak.orig 2012-12-29 13:05:23.000000000 -0600
++++ build/eclipse-3.7.1-src/plugins/org.eclipse.swt/Eclipse SWT PI/gtk/library/make_freebsd.mak 2012-12-29 13:06:37.000000000 -0600
+@@ -27,6 +27,7 @@
+ MOZILLA_PREFIX = swt-mozilla$(GCC_VERSION)
+ XULRUNNER_PREFIX = swt-xulrunner
+ XPCOMINIT_PREFIX = swt-xpcominit
++WEBKIT_PREFIX = swt-webkit
+ GLX_PREFIX = swt-glx
+
+ SWT_LIB = lib$(SWT_PREFIX)-$(WS_PREFIX)-$(SWT_VERSION).so