aboutsummaryrefslogtreecommitdiff
path: root/java/eclipseme/Makefile
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2004-07-25 08:08:17 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2004-07-25 08:08:17 +0000
commit61021d95bf4f31d7488cbda008e81db8dacbcbaf (patch)
treeab07718a80312d279d00926c23376b2ed5849daa /java/eclipseme/Makefile
parent91522840e3daf065c1b0d6ea5e9e2b6294228176 (diff)
Notes
Diffstat (limited to 'java/eclipseme/Makefile')
-rw-r--r--java/eclipseme/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/java/eclipseme/Makefile b/java/eclipseme/Makefile
new file mode 100644
index 000000000000..7f1061892610
--- /dev/null
+++ b/java/eclipseme/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: eclipseme
+# Date created: July 22, 2004
+# Whom: past@ebs.gr
+#
+# $FreeBSD$
+#
+
+PORTNAME= eclipseme
+PORTVERSION= 0.4.5
+CATEGORIES= java devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+DIST_SUBDIR= eclipse
+
+MAINTAINER= past@ebs.gr
+COMMENT= Eclipse J2ME Plugin
+
+RUN_DEPENDS= ${LOCALBASE}/bin/eclipse:${PORTSDIR}/java/eclipse \
+ ${LOCALBASE}/bin/ktoolbar:${PORTSDIR}/java/sun-wtk
+
+NO_BUILD= yes
+USE_ZIP= yes
+NO_WRKSUBDIR= yes
+PKGMESSAGE= ${WRKDIR}/pkg-message
+APP_HOME= ${PREFIX}/eclipse/plugins/${PORTNAME}_${PORTVERSION}
+
+.if defined(WITH_PROGUARD)
+RUN_DEPENDS+= ${LOCALBASE}/share/proguard/lib/proguard.jar:${PORTSDIR}/java/proguard
+.endif
+
+do-install:
+ @${CP} -r ${WRKSRC}/${PORTNAME}_${PORTVERSION} ${PREFIX}/eclipse/plugins/
+
+post-install:
+ @${SED} -e 's,%%PREFIX%%,${APP_HOME},' \
+ < ${.CURDIR}/pkg-message > ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>