aboutsummaryrefslogtreecommitdiff
path: root/java/gnu-regexp
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-04-02 10:49:30 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-04-02 10:49:30 +0000
commit7190f8407777797706c915ce5085dd8e709e9823 (patch)
tree16354d5898e97cdafe5c10cbda36c5a17eea8b53 /java/gnu-regexp
parent1f24e613d20b55fa0e7d02194df45439e9c0d452 (diff)
downloadports-7190f8407777797706c915ce5085dd8e709e9823.tar.gz
ports-7190f8407777797706c915ce5085dd8e709e9823.zip
Notes
Diffstat (limited to 'java/gnu-regexp')
-rw-r--r--java/gnu-regexp/Makefile17
-rw-r--r--java/gnu-regexp/pkg-plist45
2 files changed, 11 insertions, 51 deletions
diff --git a/java/gnu-regexp/Makefile b/java/gnu-regexp/Makefile
index 25bc346cf836..274da765027a 100644
--- a/java/gnu-regexp/Makefile
+++ b/java/gnu-regexp/Makefile
@@ -15,16 +15,21 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A regexp library for Java
USE_JAVA= 1.1+
-
NO_BUILD= yes
-DOCDIR= ${PREFIX}/share/doc/${PORTNAME}
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
+
+PLIST_FILES= ${JAVAJARDIR:S,^${PREFIX}/,,}/gnu-regexp.jar
do-install:
- ${MKDIR} ${DOCDIR}
- cd ${WRKSRC}/docs && ${FIND} . \
- | ${CPIO} -pdmu -R ${DOCOWN}:${DOCGRP} ${DOCDIR}
${INSTALL_DATA} ${WRKSRC}/lib/${PORTNAME}-${PORTVERSION}.jar \
- ${PREFIX}/share/java/classes/${PORTNAME}.jar
+ ${JAVAJARDIR}/${PORTNAME}.jar
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC}/docs && ${FIND} . \
+ | ${CPIO} -pdmu -R ${DOCOWN}:${DOCGRP} ${DOCSDIR}
+.endif
.include <bsd.port.mk>
diff --git a/java/gnu-regexp/pkg-plist b/java/gnu-regexp/pkg-plist
deleted file mode 100644
index 861e817baaf5..000000000000
--- a/java/gnu-regexp/pkg-plist
+++ /dev/null
@@ -1,45 +0,0 @@
-share/doc/gnu-regexp/api/allclasses-frame.html
-share/doc/gnu-regexp/api/deprecated-list.html
-share/doc/gnu-regexp/api/gnu/regexp/CharIndexed.html
-share/doc/gnu-regexp/api/gnu/regexp/RE.html
-share/doc/gnu-regexp/api/gnu/regexp/REException.html
-share/doc/gnu-regexp/api/gnu/regexp/REFilterInputStream.html
-share/doc/gnu-regexp/api/gnu/regexp/REFilterReader.html
-share/doc/gnu-regexp/api/gnu/regexp/REMatch.html
-share/doc/gnu-regexp/api/gnu/regexp/REMatchEnumeration.html
-share/doc/gnu-regexp/api/gnu/regexp/RESyntax.html
-share/doc/gnu-regexp/api/gnu/regexp/UncheckedRE.html
-share/doc/gnu-regexp/api/gnu/regexp/package-frame.html
-share/doc/gnu-regexp/api/gnu/regexp/package-summary.html
-share/doc/gnu-regexp/api/gnu/regexp/package-tree.html
-share/doc/gnu-regexp/api/gnu/regexp/util/Egrep.html
-share/doc/gnu-regexp/api/gnu/regexp/util/Grep.html
-share/doc/gnu-regexp/api/gnu/regexp/util/REApplet.html
-share/doc/gnu-regexp/api/gnu/regexp/util/RETest.html
-share/doc/gnu-regexp/api/gnu/regexp/util/Tests.html
-share/doc/gnu-regexp/api/gnu/regexp/util/package-frame.html
-share/doc/gnu-regexp/api/gnu/regexp/util/package-summary.html
-share/doc/gnu-regexp/api/gnu/regexp/util/package-tree.html
-share/doc/gnu-regexp/api/help-doc.html
-share/doc/gnu-regexp/api/index-all.html
-share/doc/gnu-regexp/api/index.html
-share/doc/gnu-regexp/api/overview-frame.html
-share/doc/gnu-regexp/api/overview-summary.html
-share/doc/gnu-regexp/api/overview-tree.html
-share/doc/gnu-regexp/api/package-list
-share/doc/gnu-regexp/api/packages.html
-share/doc/gnu-regexp/api/serialized-form.html
-share/doc/gnu-regexp/api/stylesheet.css
-share/doc/gnu-regexp/changes.html
-share/doc/gnu-regexp/credits.html
-share/doc/gnu-regexp/faq.html
-share/doc/gnu-regexp/gnu-regexp-applet.jar
-share/doc/gnu-regexp/index.html
-share/doc/gnu-regexp/reapplet.html
-share/doc/gnu-regexp/syntax.html
-share/java/classes/gnu-regexp.jar
-@dirrm share/doc/gnu-regexp/api/gnu/regexp/util
-@dirrm share/doc/gnu-regexp/api/gnu/regexp
-@dirrm share/doc/gnu-regexp/api/gnu
-@dirrm share/doc/gnu-regexp/api
-@dirrm share/doc/gnu-regexp