aboutsummaryrefslogtreecommitdiff
path: root/java/icedtea-web/Makefile
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2012-07-24 16:55:48 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2012-07-24 16:55:48 +0000
commitc4fa45e259254995e7ca630334bb8959b1c7331b (patch)
treecfebd8508e6ed75b0ad6c3758a0629e9a5a52fc9 /java/icedtea-web/Makefile
parent2d31e9fdbcec01e5a31ab7ed65356014a3485006 (diff)
Notes
Diffstat (limited to 'java/icedtea-web/Makefile')
-rw-r--r--java/icedtea-web/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/java/icedtea-web/Makefile b/java/icedtea-web/Makefile
index da62ff699eae..4c1943239c18 100644
--- a/java/icedtea-web/Makefile
+++ b/java/icedtea-web/Makefile
@@ -24,6 +24,14 @@ JAVA_VENDOR= openjdk
JAVA_VERSION= 1.6
USE_XORG= x11
+OPTIONS_DEFINE= PLUGIN RHINO TEST
+OPTIONS_DEFAULT=PLUGIN
+PLUGIN_DESC= Enable the browser plug-in
+RHINO_DESC= Add support for Proxy Auto Config files
+TEST_DESC= Add support for running regression test
+
+.include <bsd.port.options.mk>
+
MAN1= itweb-javaws.1
PLIST_FILES= bin/itweb-javaws bin/itweb-settings \
share/applications/itweb-javaws.desktop \
@@ -38,17 +46,9 @@ RUN_DEPENDS+= ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash
CONFIGURE_ARGS+=--with-ecj=no --with-jdk-home="${JAVA_HOME}"
-.include <bsd.port.options.mk>
-
-OPTIONS_DEFINE= PLUGIN RHINO TEST
-OPTIONS_DEFAULT=PLUGIN
-PLUGIN_DESC= Enable the browser plug-in
-RHINO_DESC= Add support for Proxy Auto Config files
-TEST_DESC= Add support for running regression test
-
.include <bsd.port.pre.mk>
-.if defined(NOPORTDOCS)
+.if empty(PORT_OPTIONS:MDOCS)
CONFIGURE_ARGS+= --disable-docs
.endif