aboutsummaryrefslogtreecommitdiff
path: root/java/icedtea-web
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2013-10-10 16:56:42 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2013-10-10 16:56:42 +0000
commitc9b9f1628cc69aab41f96f2d6f74dacef732e88a (patch)
tree96269eec69d767572e84b59384d3a3bc2a415f78 /java/icedtea-web
parent738fcd72c1ecf9876f1ea6e027c33854867dc18f (diff)
downloadports-c9b9f1628cc69aab41f96f2d6f74dacef732e88a.tar.gz
ports-c9b9f1628cc69aab41f96f2d6f74dacef732e88a.zip
Notes
Diffstat (limited to 'java/icedtea-web')
-rw-r--r--java/icedtea-web/Makefile3
-rw-r--r--java/icedtea-web/distinfo4
-rw-r--r--java/icedtea-web/files/patch-netx-Boot.java21
-rw-r--r--java/icedtea-web/files/patch-netx-JNLPRuntime.java11
-rw-r--r--java/icedtea-web/files/patch-plugin-PluginMain.java22
5 files changed, 3 insertions, 58 deletions
diff --git a/java/icedtea-web/Makefile b/java/icedtea-web/Makefile
index 9279e36b3dd2..7401c85b5f89 100644
--- a/java/icedtea-web/Makefile
+++ b/java/icedtea-web/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= icedtea-web
-PORTVERSION= 1.4
-PORTREVISION= 1
+PORTVERSION= 1.4.1
CATEGORIES= java www
MASTER_SITES= http://icedtea.wildebeest.org/download/source/ \
http://icedtea.classpath.org/download/source/
diff --git a/java/icedtea-web/distinfo b/java/icedtea-web/distinfo
index 04029e17c689..1fa48e39e3fb 100644
--- a/java/icedtea-web/distinfo
+++ b/java/icedtea-web/distinfo
@@ -1,2 +1,2 @@
-SHA256 (icedtea-web-1.4.tar.gz) = e53a41fa132e086fa8d17cadf1e7e38cb3ab99577277949fbcae4ab8705245fb
-SIZE (icedtea-web-1.4.tar.gz) = 1364883
+SHA256 (icedtea-web-1.4.1.tar.gz) = 09100207396a09784e04f2ad40d65212930c1d43839e7fa63b9dffaf8567d77b
+SIZE (icedtea-web-1.4.1.tar.gz) = 1376133
diff --git a/java/icedtea-web/files/patch-netx-Boot.java b/java/icedtea-web/files/patch-netx-Boot.java
deleted file mode 100644
index fbdc39fef7fe..000000000000
--- a/java/icedtea-web/files/patch-netx-Boot.java
+++ /dev/null
@@ -1,21 +0,0 @@
---- netx/net/sourceforge/jnlp/runtime/Boot.java Tue Jun 18 15:57:01 2013 -0400
-+++ netx/net/sourceforge/jnlp/runtime/Boot.java Thu Jun 20 15:20:57 2013 +0200
-@@ -35,6 +35,8 @@
- import net.sourceforge.jnlp.cache.UpdatePolicy;
- import net.sourceforge.jnlp.security.viewer.CertificateViewer;
- import net.sourceforge.jnlp.services.ServiceUtil;
-+import sun.awt.AppContext;
-+import sun.awt.SunToolkit;
-
- /**
- * This is the main entry point for the JNLP client. The main
-@@ -113,6 +115,9 @@
- * Launch the JNLP file specified by the command-line arguments.
- */
- public static void main(String[] argsIn) {
-+ if (AppContext.getAppContext() == null) {
-+ SunToolkit.createNewAppContext();
-+ }
- args = argsIn;
-
- if (null != getOption("-viewer")) {
diff --git a/java/icedtea-web/files/patch-netx-JNLPRuntime.java b/java/icedtea-web/files/patch-netx-JNLPRuntime.java
deleted file mode 100644
index 6d2c67539d92..000000000000
--- a/java/icedtea-web/files/patch-netx-JNLPRuntime.java
+++ /dev/null
@@ -1,11 +0,0 @@
---- netx/net/sourceforge/jnlp/runtime/JNLPRuntime.java Tue Jun 18 15:57:01 2013 -0400
-+++ netx/net/sourceforge/jnlp/runtime/JNLPRuntime.java Thu Jun 20 15:20:57 2013 +0200
-@@ -234,7 +234,7 @@
- try {
- UIManager.setLookAndFeel(UIManager.getSystemLookAndFeelClassName());
- } catch (Exception e) {
-- // ignore it
-+ e.printStackTrace();
- }
-
- doMainAppContextHacks();
diff --git a/java/icedtea-web/files/patch-plugin-PluginMain.java b/java/icedtea-web/files/patch-plugin-PluginMain.java
deleted file mode 100644
index 17a254f9366a..000000000000
--- a/java/icedtea-web/files/patch-plugin-PluginMain.java
+++ /dev/null
@@ -1,22 +0,0 @@
---- plugin/icedteanp/java/sun/applet/PluginMain.java Tue Jun 18 15:57:01 2013 -0400
-+++ plugin/icedteanp/java/sun/applet/PluginMain.java Thu Jun 20 15:20:57 2013 +0200
-@@ -72,6 +72,8 @@
- import java.net.ProxySelector;
- import java.util.Enumeration;
- import java.util.Properties;
-+import sun.awt.AppContext;
-+import sun.awt.SunToolkit;
-
- import net.sourceforge.jnlp.config.DeploymentConfiguration;
- import net.sourceforge.jnlp.runtime.JNLPRuntime;
-@@ -94,6 +96,9 @@
- */
- public static void main(String args[])
- throws IOException {
-+ if (AppContext.getAppContext() == null) {
-+ SunToolkit.createNewAppContext();
-+ }
- if (args.length != 2 || !(new File(args[0]).exists()) || !(new File(args[1]).exists())) {
- System.err.println("Invalid pipe names provided. Refusing to proceed.");
- System.exit(1);
-