aboutsummaryrefslogtreecommitdiff
path: root/java/intellij-ultimate
diff options
context:
space:
mode:
authorDavid Naylor <dbn@FreeBSD.org>2017-06-18 18:09:16 +0000
committerDavid Naylor <dbn@FreeBSD.org>2017-06-18 18:09:16 +0000
commit9920d3ae657e820bce42911009136fc059210d0d (patch)
tree237480885bd130394dbcbc56f765540bba4416e2 /java/intellij-ultimate
parent4aeae92375bb57620d054d3cc88677ebba4f22bf (diff)
downloadports-9920d3ae657e820bce42911009136fc059210d0d.tar.gz
ports-9920d3ae657e820bce42911009136fc059210d0d.zip
qa: add check for NO_ARCH
If NO_ARCH is set then check that no FreeBSD elf(5) files are in $STAGEDIR. If an elf(5) file is bundles as part of the package, but is not meant to be run directly (i.e. the elf(5) file is a payload, and not compiled) then those files can be added to NO_ARCH_IGNORE to avoid the check from failing, Changes to ports: - Ports that have NO_ARCH set, but actually compile files have had NO_ARCH removed. - Ports that have elf(5) payloads have had those files added to NO_ARCH_IGNORE. - R-cran ports that do not set USES=cran:compiles have NO_ARCH set, PR: 218976 Reviewed by: antoine, mat Approved by: portmgr
Notes
Notes: svn path=/head/; revision=443845
Diffstat (limited to 'java/intellij-ultimate')
-rw-r--r--java/intellij-ultimate/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/java/intellij-ultimate/Makefile b/java/intellij-ultimate/Makefile
index 2016243b013c..6c4bd0cc0f9a 100644
--- a/java/intellij-ultimate/Makefile
+++ b/java/intellij-ultimate/Makefile
@@ -25,6 +25,8 @@ USE_JAVA= yes
JAVA_VERSION= 1.8+
NO_ARCH= yes
+NO_ARCH_IGNORE= libnative_auth.so libnative_console.so libnative_filesystem.so \
+ libnative_misc.so libnative_synchronization.so
NO_BUILD= yes
USE_LDCONFIG= ${IDEA_HOME}/plugins/tfsIntegration/lib/native/freebsd/x86_64/
USE_LDCONFIG32= ${IDEA_HOME}/plugins/tfsIntegration/lib/native/freebsd/x86/