aboutsummaryrefslogtreecommitdiff
path: root/java/jaf
diff options
context:
space:
mode:
authorHerve Quiroz <hq@FreeBSD.org>2004-09-03 03:29:23 +0000
committerHerve Quiroz <hq@FreeBSD.org>2004-09-03 03:29:23 +0000
commit980a124186b6400620f5184b12807382e5b59e21 (patch)
tree49a587c4ffecfd1413b10dbff4d48dae891933cc /java/jaf
parentfe5573db67a933e01b458d50ed8b03aa7b0588a2 (diff)
downloadports-980a124186b6400620f5184b12807382e5b59e21.tar.gz
ports-980a124186b6400620f5184b12807382e5b59e21.zip
Notes
Diffstat (limited to 'java/jaf')
-rw-r--r--java/jaf/Makefile49
-rw-r--r--java/jaf/distinfo3
-rw-r--r--java/jaf/pkg-plist90
3 files changed, 40 insertions, 102 deletions
diff --git a/java/jaf/Makefile b/java/jaf/Makefile
index 4fa357dbb61a..43d71a6c6166 100644
--- a/java/jaf/Makefile
+++ b/java/jaf/Makefile
@@ -7,33 +7,60 @@
PORTNAME= jaf
PORTVERSION= 1.0.2
-PORTREVISION= 1
-CATEGORIES= java
+PORTREVISION= 2
+CATEGORIES= java devel
MASTER_SITES= #
-DISTNAME= ${PORTNAME}-1_0_2
+DISTNAME= ${PORTNAME}-${PORTVERSION:S,.,_,g}-upd
MAINTAINER= java@freebsd.org
COMMENT= JavaBeansTM Activation Framework
USE_ZIP= YES
-USE_JAVA= 1.1+
+USE_JAVA= YES
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
NO_BUILD= yes
NO_CDROM= "See the license"
-TARGET_DIR= ${PREFIX}/share/java/${PKGNAME}
-PLIST_SUB+= T=${TARGET_DIR:S/^${PREFIX}\///}
DOWNLOAD_URL= http://javashoplm.sun.com/ECom/docs/Welcome.jsp?StoreId=22\&PartDetailId=7017-jaf-1.0.2-oth-JPR\&SiteId=JSC\&TransactionId=noreg
+.if !defined(NOPORTDOCS)
+DOCFILES1= JAF-1.0.pdf JAF-1.0.ps javadocs
+DOCFILES2= LICENSE.txt README.txt RELNOTES.txt
+PORTDOCS= ${DOCFILES1} ${DOCFILES2}
+.endif
+
+PLIST_FILES= %%JAVAJARDIR%%/activation.jar
+
.include <bsd.port.pre.mk>
.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
-IGNORE= "You must manually fetch the distribution from ${DOWNLOAD_URL} and place it in ${DISTDIR} then run make again"
+IGNORE= "You must manually fetch the distribution from ${DOWNLOAD_URL} and place it in ${DISTDIR} then run make again"
.endif
do-install:
- ${MKDIR} ${PREFIX}/share/java/classes
- ${MKDIR} ${TARGET_DIR}
- ${CP} -R ${WRKSRC}/* ${TARGET_DIR}
- ${LN} -sf ${TARGET_DIR}/activation.jar ${PREFIX}/share/java/classes/activation.jar
+ @${ECHO_MSG} -n ">> Installing demo files in ${EXAMPLESDIR}..."
+ @${MKDIR} ${EXAMPLESDIR}
+ @cd ${WRKSRC} && ${FIND} demo \
+ | ${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR} > /dev/null 2>&1
+ @${ECHO_MSG} " [ DONE ]"
+ @${ECHO_MSG} -n ">> Installing JAR file as ${JAVAJARDIR}/activation.jar..."
+ @${MKDIR} ${JAVAJARDIR}
+ @${INSTALL_DATA} ${WRKSRC}/activation.jar ${JAVAJARDIR}/
+ @${ECHO_MSG} " [ DONE ]"
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}..."
+ @${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC}/docs && ${FIND} ${DOCFILES1} \
+ | ${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR} > /dev/null 2>&1
+ @cd ${WRKSRC} && ${FIND} ${DOCFILES2} \
+ | ${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR} > /dev/null 2>&1
+ @${ECHO_MSG} " [ DONE ]"
+.endif
+
+post-install:
+ @${FIND} -s ${WRKSRC}/demo -not -type d 2>/dev/null \
+ | ${SED} -ne 's,^${WRKSRC},${EXAMPLESDIR:S,^${PREFIX}/,,},p' >> ${TMPPLIST}
+ @${FIND} -s -d ${WRKSRC}/demo -type d 2>/dev/null \
+ | ${SED} -ne 's,^${WRKSRC},@dirrm ${EXAMPLESDIR:S,^${PREFIX}/,,},p' >> ${TMPPLIST}
+ @${ECHO_CMD} '@dirrm ${EXAMPLESDIR:S,^${PREFIX}/,,}' >> ${TMPPLIST}
.include <bsd.port.post.mk>
diff --git a/java/jaf/distinfo b/java/jaf/distinfo
index 6f88eecfba7c..07d13c352196 100644
--- a/java/jaf/distinfo
+++ b/java/jaf/distinfo
@@ -1 +1,2 @@
-MD5 (jaf-1_0_2.zip) = 8517e8ef124f1eb8dbce667476b231ac
+MD5 (jaf-1_0_2-upd.zip) = d124f4f18985768dab71e61f82206713
+SIZE (jaf-1_0_2-upd.zip) = 356454
diff --git a/java/jaf/pkg-plist b/java/jaf/pkg-plist
deleted file mode 100644
index cfa169c83398..000000000000
--- a/java/jaf/pkg-plist
+++ /dev/null
@@ -1,90 +0,0 @@
-share/java/classes/activation.jar
-%%T%%/docs/javadocs/javax/activation/class-use/URLDataSource.html
-%%T%%/docs/javadocs/javax/activation/class-use/CommandMap.html
-%%T%%/docs/javadocs/javax/activation/class-use/MailcapCommandMap.html
-%%T%%/docs/javadocs/javax/activation/class-use/UnsupportedDataTypeException.html
-%%T%%/docs/javadocs/javax/activation/class-use/DataContentHandlerFactory.html
-%%T%%/docs/javadocs/javax/activation/class-use/DataContentHandler.html
-%%T%%/docs/javadocs/javax/activation/class-use/MimeTypeParseException.html
-%%T%%/docs/javadocs/javax/activation/class-use/ActivationDataFlavor.html
-%%T%%/docs/javadocs/javax/activation/class-use/FileTypeMap.html
-%%T%%/docs/javadocs/javax/activation/class-use/MimetypesFileTypeMap.html
-%%T%%/docs/javadocs/javax/activation/class-use/FileDataSource.html
-%%T%%/docs/javadocs/javax/activation/class-use/DataSource.html
-%%T%%/docs/javadocs/javax/activation/class-use/MimeTypeParameterList.html
-%%T%%/docs/javadocs/javax/activation/class-use/DataHandler.html
-%%T%%/docs/javadocs/javax/activation/class-use/MimeType.html
-%%T%%/docs/javadocs/javax/activation/class-use/CommandObject.html
-%%T%%/docs/javadocs/javax/activation/class-use/CommandInfo.html
-%%T%%/docs/javadocs/javax/activation/package-use.html
-%%T%%/docs/javadocs/javax/activation/package-summary.html
-%%T%%/docs/javadocs/javax/activation/package-tree.html
-%%T%%/docs/javadocs/javax/activation/package-frame.html
-%%T%%/docs/javadocs/javax/activation/CommandObject.html
-%%T%%/docs/javadocs/javax/activation/DataContentHandler.html
-%%T%%/docs/javadocs/javax/activation/DataContentHandlerFactory.html
-%%T%%/docs/javadocs/javax/activation/DataSource.html
-%%T%%/docs/javadocs/javax/activation/ActivationDataFlavor.html
-%%T%%/docs/javadocs/javax/activation/CommandInfo.html
-%%T%%/docs/javadocs/javax/activation/CommandMap.html
-%%T%%/docs/javadocs/javax/activation/DataHandler.html
-%%T%%/docs/javadocs/javax/activation/FileDataSource.html
-%%T%%/docs/javadocs/javax/activation/FileTypeMap.html
-%%T%%/docs/javadocs/javax/activation/MailcapCommandMap.html
-%%T%%/docs/javadocs/javax/activation/MimeType.html
-%%T%%/docs/javadocs/javax/activation/MimeTypeParameterList.html
-%%T%%/docs/javadocs/javax/activation/MimetypesFileTypeMap.html
-%%T%%/docs/javadocs/javax/activation/URLDataSource.html
-%%T%%/docs/javadocs/javax/activation/MimeTypeParseException.html
-%%T%%/docs/javadocs/javax/activation/UnsupportedDataTypeException.html
-%%T%%/docs/javadocs/overview-tree.html
-%%T%%/docs/javadocs/index-files/index-1.html
-%%T%%/docs/javadocs/index-files/index-2.html
-%%T%%/docs/javadocs/index-files/index-3.html
-%%T%%/docs/javadocs/index-files/index-4.html
-%%T%%/docs/javadocs/index-files/index-5.html
-%%T%%/docs/javadocs/index-files/index-6.html
-%%T%%/docs/javadocs/index-files/index-7.html
-%%T%%/docs/javadocs/index-files/index-8.html
-%%T%%/docs/javadocs/index-files/index-9.html
-%%T%%/docs/javadocs/index-files/index-10.html
-%%T%%/docs/javadocs/index-files/index-11.html
-%%T%%/docs/javadocs/index-files/index-12.html
-%%T%%/docs/javadocs/index-files/index-13.html
-%%T%%/docs/javadocs/index-files/index-14.html
-%%T%%/docs/javadocs/index-files/index-15.html
-%%T%%/docs/javadocs/index-files/index-16.html
-%%T%%/docs/javadocs/deprecated-list.html
-%%T%%/docs/javadocs/allclasses-frame.html
-%%T%%/docs/javadocs/index.html
-%%T%%/docs/javadocs/packages.html
-%%T%%/docs/javadocs/serialized-form.html
-%%T%%/docs/javadocs/package-list
-%%T%%/docs/javadocs/help-doc.html
-%%T%%/docs/javadocs/stylesheet.css
-%%T%%/docs/JAF-1.0.ps
-%%T%%/docs/JAF-1.0.pdf
-%%T%%/demo/CompViewer.java
-%%T%%/demo/DCHTest.java
-%%T%%/demo/DCHTest2.java
-%%T%%/demo/DHURL.java
-%%T%%/demo/FileView.java
-%%T%%/demo/JAFApp.java
-%%T%%/demo/MCTest.java
-%%T%%/demo/ODCHTest.java
-%%T%%/demo/PlainDCH.java
-%%T%%/demo/PrefTest.java
-%%T%%/demo/SimpleDCF.java
-%%T%%/demo/TextInternalizer.java
-%%T%%/activation.jar
-%%T%%/README.txt
-%%T%%/LICENSE.txt
-%%T%%/RELNOTES.txt
-@dirrm %%T%%/docs/javadocs/index-files/
-@dirrm %%T%%/docs/javadocs/javax/activation/class-use/
-@dirrm %%T%%/docs/javadocs/javax/activation/
-@dirrm %%T%%/docs/javadocs/javax/
-@dirrm %%T%%/docs/javadocs/
-@dirrm %%T%%/docs/
-@dirrm %%T%%/demo/
-@dirrm %%T%%/