aboutsummaryrefslogtreecommitdiff
path: root/java/jakarta-commons-beanutils
diff options
context:
space:
mode:
authorErnst de Haan <znerd@FreeBSD.org>2002-11-14 10:23:58 +0000
committerErnst de Haan <znerd@FreeBSD.org>2002-11-14 10:23:58 +0000
commitf4a22be2e23a20ecb8a8280c5a273bcceb9e7744 (patch)
tree2973e8921b5ffb542ccdccce03359f77c4001446 /java/jakarta-commons-beanutils
parenta2931284765e719e4f2623a8043c9336ae287351 (diff)
downloadports-f4a22be2e23a20ecb8a8280c5a273bcceb9e7744.tar.gz
ports-f4a22be2e23a20ecb8a8280c5a273bcceb9e7744.zip
Notes
Diffstat (limited to 'java/jakarta-commons-beanutils')
-rw-r--r--java/jakarta-commons-beanutils/Makefile52
-rw-r--r--java/jakarta-commons-beanutils/distinfo1
-rw-r--r--java/jakarta-commons-beanutils/files/LICENSE56
-rw-r--r--java/jakarta-commons-beanutils/pkg-comment1
-rw-r--r--java/jakarta-commons-beanutils/pkg-descr5
-rw-r--r--java/jakarta-commons-beanutils/pkg-plist22
6 files changed, 137 insertions, 0 deletions
diff --git a/java/jakarta-commons-beanutils/Makefile b/java/jakarta-commons-beanutils/Makefile
new file mode 100644
index 000000000000..6adddf98ae2c
--- /dev/null
+++ b/java/jakarta-commons-beanutils/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: Jakarta Commons Beanutils
+# Date created: November 14, 2002
+# Whom: Ernst de Haan <znerd@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= commons-beanutils
+PORTVERSION= 1.0
+CATEGORIES= java
+MASTER_SITES= http://jakarta.apache.org/builds/jakarta-commons/release/${PORTNAME}/v${PORTVERSION}/
+PKGNAMEPREFIX= jakarta-
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= znerd@FreeBSD.org
+
+BUILD_DEPENDS= ${ANT}:${PORTSDIR}/devel/jakarta-ant \
+ ${LOCALBASE}/share/java/classes/commons-collections.jar:${PORTSDIR}/java/jakarta-commons-collections
+
+USE_JAVA= 1.2+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-src/beanutils
+
+PLIST_SUB+= T=${TARGET_DIR:S/^${PREFIX}\///}
+ANT?= ${LOCALBASE}/bin/ant
+.if defined(NOPORTDOCS)
+ANT_TARGET= dist
+.else
+ANT_TARGET= dist
+.endif
+JAVASHAREDIR= ${PREFIX}/share/java
+JARDIR= ${JAVASHAREDIR}/classes
+JARFILE= ${PORTNAME}.jar
+DESTJARFILE= ${PORTNAME}.jar
+
+post-patch:
+ @${CP} ${FILESDIR}/LICENSE ${WRKDIR}/${PORTNAME}-${PORTVERSION}-src/
+do-build:
+ @cd ${WRKSRC} && ${ANT} ${ANT_TARGET}
+
+do-install:
+ @${ECHO} -n ">> Installing JAR as ${JARDIR}/${DESTJARFILE}..."
+ @${CP} ${WRKSRC}/dist/${JARFILE} ${JARDIR}/${DESTJARFILE}
+ @${ECHO} " [ DONE ]"
+
+.if !defined(NOPORTDOCS)
+ @${ECHO} -n ">> Installing documentation in ${DOCSDIR}..."
+ ${MKDIR} ${DOCSDIR}
+ ${CP} -r ${WRKSRC}/dist/docs/api/* ${DOCSDIR}
+ @${ECHO} " [ DONE ]"
+.endif
+
+.include <bsd.port.mk>
diff --git a/java/jakarta-commons-beanutils/distinfo b/java/jakarta-commons-beanutils/distinfo
new file mode 100644
index 000000000000..ab3042d8dda8
--- /dev/null
+++ b/java/jakarta-commons-beanutils/distinfo
@@ -0,0 +1 @@
+MD5 (commons-beanutils-1.0-src.tar.gz) = 99ef1422867f1fe9b2c9f9864d90a8e0
diff --git a/java/jakarta-commons-beanutils/files/LICENSE b/java/jakarta-commons-beanutils/files/LICENSE
new file mode 100644
index 000000000000..59a84f327478
--- /dev/null
+++ b/java/jakarta-commons-beanutils/files/LICENSE
@@ -0,0 +1,56 @@
+/*
+ * ====================================================================
+ *
+ * The Apache Software License, Version 1.1
+ *
+ * Copyright (c) 2001 The Apache Software Foundation. All rights
+ * reserved.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ *
+ * 1. Redistributions of source code must retain the above copyright
+ * notice, this list of conditions and the following disclaimer.
+ *
+ * 2. Redistributions in binary form must reproduce the above copyright
+ * notice, this list of conditions and the following disclaimer in
+ * the documentation and/or other materials provided with the
+ * distribution.
+ *
+ * 3. The end-user documentation included with the redistribution, if
+ * any, must include the following acknowlegement:
+ * "This product includes software developed by the
+ * Apache Software Foundation (http://www.apache.org/)."
+ * Alternately, this acknowlegement may appear in the software itself,
+ * if and wherever such third-party acknowlegements normally appear.
+ *
+ * 4. The names "The Jakarta Project", "Commons", and "Apache Software
+ * Foundation" must not be used to endorse or promote products derived
+ * from this software without prior written permission. For written
+ * permission, please contact apache@apache.org.
+ *
+ * 5. Products derived from this software may not be called "Apache",
+ * "Velocity" nor may "Apache" appear in their names without prior
+ * written permission of the Apache Group.
+ *
+ * THIS SOFTWARE IS PROVIDED ``AS IS'' AND ANY EXPRESSED OR IMPLIED
+ * WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
+ * OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+ * DISCLAIMED. IN NO EVENT SHALL THE APACHE SOFTWARE FOUNDATION OR
+ * ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+ * SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+ * LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF
+ * USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
+ * ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
+ * OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT
+ * OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+ * SUCH DAMAGE.
+ * ====================================================================
+ *
+ * This software consists of voluntary contributions made by many
+ * individuals on behalf of the Apache Software Foundation. For more
+ * information on the Apache Software Foundation, please see
+ * <http://www.apache.org/>.
+ *
+ */
diff --git a/java/jakarta-commons-beanutils/pkg-comment b/java/jakarta-commons-beanutils/pkg-comment
new file mode 100644
index 000000000000..e5a4d3ef88da
--- /dev/null
+++ b/java/jakarta-commons-beanutils/pkg-comment
@@ -0,0 +1 @@
+JavaBeans utility library
diff --git a/java/jakarta-commons-beanutils/pkg-descr b/java/jakarta-commons-beanutils/pkg-descr
new file mode 100644
index 000000000000..c16f3928e867
--- /dev/null
+++ b/java/jakarta-commons-beanutils/pkg-descr
@@ -0,0 +1,5 @@
+JavaBeans utility library. It provides wrappers around getters
+and setters for a property in an object for classes that conform
+to the JavaBeans naming standard.
+
+WWW: http://jakarta.apache.org/commons/beanutils.html
diff --git a/java/jakarta-commons-beanutils/pkg-plist b/java/jakarta-commons-beanutils/pkg-plist
new file mode 100644
index 000000000000..1dd3eaa3cb67
--- /dev/null
+++ b/java/jakarta-commons-beanutils/pkg-plist
@@ -0,0 +1,22 @@
+share/doc/commons-beanutils/org/apache/commons/beanutils/package-summary.html
+share/doc/commons-beanutils/org/apache/commons/beanutils/package-tree.html
+share/doc/commons-beanutils/org/apache/commons/beanutils/package-frame.html
+share/doc/commons-beanutils/org/apache/commons/beanutils/BeanUtils.html
+share/doc/commons-beanutils/org/apache/commons/beanutils/ConvertUtils.html
+share/doc/commons-beanutils/org/apache/commons/beanutils/PropertyUtils.html
+share/doc/commons-beanutils/serialized-form.html
+share/doc/commons-beanutils/packages.html
+share/doc/commons-beanutils/package-list
+share/doc/commons-beanutils/overview-tree.html
+share/doc/commons-beanutils/index.html
+share/doc/commons-beanutils/index-all.html
+share/doc/commons-beanutils/help-doc.html
+share/doc/commons-beanutils/deprecated-list.html
+share/doc/commons-beanutils/stylesheet.css
+share/doc/commons-beanutils/allclasses-frame.html
+share/java/classes/commons-beanutils.jar
+@dirrm share/doc/commons-beanutils/org/apache/commons/beanutils
+@dirrm share/doc/commons-beanutils/org/apache/commons
+@dirrm share/doc/commons-beanutils/org/apache
+@dirrm share/doc/commons-beanutils/org
+@dirrm share/doc/commons-beanutils