aboutsummaryrefslogtreecommitdiff
path: root/java/jboss5
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2007-03-28 05:47:17 +0000
committerXin LI <delphij@FreeBSD.org>2007-03-28 05:47:17 +0000
commit789e9ecac7b7596a03747ebd13fad0e5e8fc4cf5 (patch)
treef4d90cbcf844b3e9447453b2f221bb5c192ea4a6 /java/jboss5
parentd742ec2036de50307baa2e387073d69c183c9c92 (diff)
downloadports-789e9ecac7b7596a03747ebd13fad0e5e8fc4cf5.tar.gz
ports-789e9ecac7b7596a03747ebd13fad0e5e8fc4cf5.zip
Notes
Diffstat (limited to 'java/jboss5')
-rw-r--r--java/jboss5/Makefile98
-rw-r--r--java/jboss5/distinfo6
-rw-r--r--java/jboss5/files/daemonctl.1.in (renamed from java/jboss5/files/daemonctl.1)0
-rw-r--r--java/jboss5/files/daemonctl.c.in (renamed from java/jboss5/files/daemonctl.c)2
-rw-r--r--java/jboss5/files/jboss5.sh.in (renamed from java/jboss5/files/startup.sh)2
-rw-r--r--java/jboss5/files/patch-build-common.xml29
-rw-r--r--java/jboss5/files/patch-build.xml39
-rw-r--r--java/jboss5/files/patch-buildmagic.ent37
-rw-r--r--java/jboss5/files/patch-serial-autoinc86
-rw-r--r--java/jboss5/files/pkg-deinstall.in (renamed from java/jboss5/pkg-deinstall)2
-rw-r--r--java/jboss5/files/pkg-install.in (renamed from java/jboss5/pkg-install)2
-rw-r--r--java/jboss5/files/pkg-message.in (renamed from java/jboss5/files/pkg-message)0
-rw-r--r--java/jboss5/pkg-descr34
13 files changed, 170 insertions, 167 deletions
diff --git a/java/jboss5/Makefile b/java/jboss5/Makefile
index 5a86ecf48bc0..ec953be74cfe 100644
--- a/java/jboss5/Makefile
+++ b/java/jboss5/Makefile
@@ -1,28 +1,32 @@
-# ports collection makefile for: jboss2
-# Date created: 16 April 2002
-# Whom: Ernst de Haan <znerd@FreeBSD.org>
+# ports collection makefile for: jboss5
+# Date created: 7 May 2007
+# Whom: nemoliu@gmail.com <nemoliu@gmail.com>
#
# $FreeBSD$
#
PORTNAME= ${APP_TITLE:L}
-PORTVERSION= 4.0.5.GA
+PORTVERSION= 5.0.0.b1
PORTEPOCH= 1
CATEGORIES= java devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+DISTNAME= ${PORTNAME}-${PORTVERSION:R}.Beta1-src
-MAINTAINER= jonc@chen.org.nz
-COMMENT= Open-source J2EE application server (4.x family)
+MAINTAINER= nemoliu@gmail.com
+COMMENT= Open-source J2EE application server (5.x family)
BUILD_DEPENDS= ant:${PORTSDIR}/devel/apache-ant
-LATEST_LINK= jboss4
+LATEST_LINK= jboss5
USE_JAVA= yes
-JAVA_VERSION= 1.4+
+JAVA_VERSION= 1.5+
+USE_ANT= yes
-USE_RC_SUBR= YES
+MAKE_ARGS= -buildfile build/build.xml
+
+USE_RC_SUBR= jboss5.sh
+SUB_FILES= pkg-install pkg-deinstall pkg-message daemonctl.1 daemonctl.c
.if !defined(NOPORTDOCS)
PORTDOCS= *
@@ -48,55 +52,47 @@ PID_FILE= /var/run/${APP_SHORTNAME}.pid
JAVA_OPTS=
JAVA_CP= bin/run.jar:${JAVA_HOME}/lib/tools.jar
JAVA_MAIN= org.jboss.Main
-DAEMONCTL_DIR= ${FILESDIR}
-DAEMONCTL_FILES=daemonctl.c daemonctl.1 startup.sh pkg-message
MAN1= ${CONTROL_SCRIPT_NAME}.1
-JBOSSOUTPUT= ${WRKSRC}/build/output/${PORTNAME}-${PORTVERSION:S/.s/SP/}
+JBOSSOUTPUT= ${WRKSRC}/build/output/${PORTNAME}-${PORTVERSION:R}.Beta1
APP_HOME_FILES= bin client lib server
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
PLIST_FILES= ${CONTROL_SCRIPT:S,^${PREFIX}/,,} \
- ${STARTUP_SCRIPT:S,^${PREFIX}/,,} \
${STDOUT_LOG:S,^${PREFIX}/,,} \
${STDERR_LOG:S,^${PREFIX}/,,}
-PKGMESSAGE= ${WRKDIR}/pkg-message.fmt
+SUB_LIST= APP_HOME=${APP_HOME} \
+ APP_SHORTNAME=${APP_SHORTNAME} \
+ APP_TITLE=${APP_TITLE} \
+ CONTROL_SCRIPT=${CONTROL_SCRIPT} \
+ CONTROL_SCRIPT_MANPAGE_TITLE=${CONTROL_SCRIPT_MANPAGE_TITLE} \
+ CONTROL_SCRIPT_NAME=${CONTROL_SCRIPT_NAME} \
+ GROUP=${GROUP} \
+ JAVA=${JAVA} \
+ JAVA_CP=${JAVA_CP} \
+ JAVA_HOME=${JAVA_HOME} \
+ JAVA_MAIN=${JAVA_MAIN} \
+ JAVA_OPTS=${JAVA_OPTS} \
+ JAVA_PORT_VERSION=${JAVA_PORT_VERSION} \
+ JAVA_PORT_OS_DESCRIPTION=${JAVA_PORT_OS_DESCRIPTION} \
+ JAR_FILE=${JAR_FILE} \
+ LOG_DIR=${LOG_DIR} \
+ PID_FILE=${PID_FILE} \
+ PKGNAME=${PKGNAME} \
+ PORTNAME=${PORTNAME} \
+ PORTVERSION=${PORTVERSION} \
+ PREFIX=${PREFIX} \
+ STARTUP_SCRIPT=${STARTUP_SCRIPT} \
+ STDERR_LOG=${STDERR_LOG} \
+ STDOUT_LOG=${STDOUT_LOG} \
+ STOP_TIMEOUT=${STOP_TIMEOUT} \
+ USER=${USER}
.include <bsd.port.pre.mk>
-do-configure:
- @(cd ${DAEMONCTL_DIR} && ${CP} ${DAEMONCTL_FILES} ${WRKDIR})
- @(cd ${WRKDIR} && ${REINPLACE_CMD} \
- -e "s|%%RC_SUBR%%|${RC_SUBR}|g;" \
- -e "s|%%APP_HOME%%|${APP_HOME}|g;" \
- -e "s|%%APP_SHORTNAME%%|${APP_SHORTNAME}|g;" \
- -e "s|%%APP_TITLE%%|${APP_TITLE}|g;" \
- -e "s|%%CONTROL_SCRIPT%%|${CONTROL_SCRIPT}|g;" \
- -e "s|%%CONTROL_SCRIPT_MANPAGE_TITLE%%|${CONTROL_SCRIPT_MANPAGE_TITLE}|g;" \
- -e "s|%%CONTROL_SCRIPT_NAME%%|${CONTROL_SCRIPT_NAME}|g;" \
- -e "s|%%GROUP%%|${GROUP}|g;" \
- -e "s|%%JAVA%%|${JAVA}|g;" \
- -e "s|%%JAVA_CP%%|${JAVA_CP}|g;" \
- -e "s|%%JAVA_HOME%%|${JAVA_HOME}|g;" \
- -e "s|%%JAVA_MAIN%%|${JAVA_MAIN}|g;" \
- -e "s|%%JAVA_OPTS%%|${JAVA_OPTS}|g;" \
- -e "s|%%JAVA_PORT_VERSION%%|${JAVA_PORT_VERSION}|g;" \
- -e "s|%%JAVA_PORT_OS_DESCRIPTION%%|${JAVA_PORT_OS_DESCRIPTION}|g;" \
- -e "s|%%JAR_FILE%%|${JAR_FILE}|g;" \
- -e "s|%%LOG_DIR%%|${LOG_DIR}|g;" \
- -e "s|%%PID_FILE%%|${PID_FILE}|g;" \
- -e "s|%%PKGNAME%%|${PKGNAME}|g;" \
- -e "s|%%PORTNAME%%|${PORTNAME}|g;" \
- -e "s|%%PORTVERSION%%|${PORTVERSION}|g;" \
- -e "s|%%PREFIX%%|${PREFIX}|g;" \
- -e "s|%%STARTUP_SCRIPT%%|${STARTUP_SCRIPT}|g;" \
- -e "s|%%STDERR_LOG%%|${STDERR_LOG}|g;" \
- -e "s|%%STDOUT_LOG%%|${STDOUT_LOG}|g;" \
- -e "s|%%STOP_TIMEOUT%%|${STOP_TIMEOUT}|g;" \
- -e "s|%%USER%%|${USER}|g;" ${DAEMONCTL_FILES})
- @${FMT} -s 80 ${WRKDIR}/pkg-message >${PKGMESSAGE}
-
-post-configure:
+pre-patch:
@${ECHO_MSG} "Installation settings:"
@${ECHO_MSG} " Destination directory: ${APP_HOME}"
@${ECHO_MSG} " Control program location: ${CONTROL_SCRIPT}"
@@ -110,21 +106,17 @@ post-configure:
@${ECHO_MSG} " Starting after install: ${AUTO_START}"
@${ECHO_MSG} " Stop time-out: ${STOP_TIMEOUT} sec."
-do-build:
- (cd ${WRKDIR} && ${CC} ${CFLAGS} -o ${CONTROL_SCRIPT_NAME} daemonctl.c)
- (cd ${WRKSRC}/build && ${SETENV} JAVA_HOME="${JAVA_HOME}" PATH="${JAVA_HOME}/bin:${PATH}" ${SH} build.sh)
-
pre-install:
@${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
do-install:
+ cd ${WRKDIR} && ${CC} ${CFLAGS} -o ${CONTROL_SCRIPT_NAME} daemonctl.c
${MKDIR} ${APP_HOME} && ${CHOWN} ${USER}:${GROUP} ${APP_HOME}
${MKDIR} ${LOG_DIR} && ${CHOWN} ${USER}:${GROUP} ${LOG_DIR}
(cd ${JBOSSOUTPUT} && ${FIND} ${APP_HOME_FILES} |\
${CPIO} -pdmu -R ${USER}:${GROUP} ${APP_HOME})
${INSTALL} -o ${USER} -g ${GROUP} -m 06754\
${WRKDIR}/${CONTROL_SCRIPT_NAME} ${CONTROL_SCRIPT}
- ${INSTALL_SCRIPT} ${WRKDIR}/startup.sh ${STARTUP_SCRIPT}
${INSTALL} -o ${USER} -g ${GROUP} -m 0640 /dev/null ${STDOUT_LOG}
${INSTALL} -o ${USER} -g ${GROUP} -m 0640 /dev/null ${STDERR_LOG}
${INSTALL} -o ${USER} -g ${GROUP} -m 0640 /dev/null ${PID_FILE}
diff --git a/java/jboss5/distinfo b/java/jboss5/distinfo
index 08c15bfb5eb2..a1b5102246ea 100644
--- a/java/jboss5/distinfo
+++ b/java/jboss5/distinfo
@@ -1,3 +1,3 @@
-MD5 (jboss-4.0.5.GA-src.tar.gz) = d93ab59f52a5c196520673d272cb7a42
-SHA256 (jboss-4.0.5.GA-src.tar.gz) = 087aa32185d3867c993d3b318675dbb6c4ce71e410730d24e5d358e4206ae3d8
-SIZE (jboss-4.0.5.GA-src.tar.gz) = 78808549
+MD5 (jboss-5.0.0.Beta1-src.tar.gz) = 92365ed9bafae925c071e23e723216be
+SHA256 (jboss-5.0.0.Beta1-src.tar.gz) = f0916edce3053a3cc5e689559822b559e0d4b08582eeb606f0208ca7634ef1e5
+SIZE (jboss-5.0.0.Beta1-src.tar.gz) = 114347235
diff --git a/java/jboss5/files/daemonctl.1 b/java/jboss5/files/daemonctl.1.in
index 30547f449ef9..30547f449ef9 100644
--- a/java/jboss5/files/daemonctl.1
+++ b/java/jboss5/files/daemonctl.1.in
diff --git a/java/jboss5/files/daemonctl.c b/java/jboss5/files/daemonctl.c.in
index 215d5bcd50c3..7bcdc6b7f5e8 100644
--- a/java/jboss5/files/daemonctl.c
+++ b/java/jboss5/files/daemonctl.c.in
@@ -7,7 +7,7 @@
* Original by Ernst de Haan <znerd@freebsd.org>
* www/jakarta-tomcat4/files/daemonctl.c
*
- * $FreeBSD: /tmp/pcvs/ports/java/jboss5/files/Attic/daemonctl.c,v 1.3 2004-12-22 20:44:23 hq Exp $
+ * $FreeBSD$
*/
#include <assert.h>
diff --git a/java/jboss5/files/startup.sh b/java/jboss5/files/jboss5.sh.in
index ab89029ac91f..157a5947f826 100644
--- a/java/jboss5/files/startup.sh
+++ b/java/jboss5/files/jboss5.sh.in
@@ -2,7 +2,7 @@
#
# %%APP_TITLE%% startup script.
#
-# $FreeBSD: /tmp/pcvs/ports/java/jboss5/files/Attic/startup.sh,v 1.4 2006-06-13 17:43:14 glewis Exp $
+# $FreeBSD$
#
# PROVIDE: %%APP_SHORTNAME%%
diff --git a/java/jboss5/files/patch-build-common.xml b/java/jboss5/files/patch-build-common.xml
new file mode 100644
index 000000000000..fb2a1c8308c7
--- /dev/null
+++ b/java/jboss5/files/patch-build-common.xml
@@ -0,0 +1,29 @@
+--- ./tools/etc/buildmagic/build-common.xml.orig Sun Mar 25 20:25:52 2007
++++ ./tools/etc/buildmagic/build-common.xml Sun Mar 25 20:27:18 2007
+@@ -2,7 +2,7 @@
+
+ <!-- Make sure we have the right version of Ant -->
+ <property name="buildmagic.ant16.baseversion" value="1.6"/>
+-
++ <property name="buildmagic.ant17.baseversion" value="1.7"/>
+ <!--
+ | Add new conditions for other supported Ant versions when they
+ | become avaialble.
+@@ -12,13 +12,16 @@
+ <or>
+ <contains string="${ant.version}"
+ substring="Ant version ${buildmagic.ant16.baseversion}"/>
++ <contains string="${ant.version}"
++ substring="Ant version ${buildmagic.ant17.baseversion}"/>
+ </or>
+ </condition>
+
+ <fail unless="buildmagic.ant.compatible">
+ Unsupported Ant version:
+ ${ant.version}
+- Please install a version which is compatible with Ant ${buildmagic.ant16.baseversion}.
++ Please install a version which is compatible with Ant ${buildmagic.ant16.baseversion}
++ or ${buildmagic.ant17.baseversion}.
+ </fail>
+
+ <!-- JDK Detection -->
diff --git a/java/jboss5/files/patch-build.xml b/java/jboss5/files/patch-build.xml
new file mode 100644
index 000000000000..710f4c6145fa
--- /dev/null
+++ b/java/jboss5/files/patch-build.xml
@@ -0,0 +1,39 @@
+--- ./build/build.xml.orig Sun Mar 25 21:29:21 2007
++++ ./build/build.xml Sun Mar 25 21:30:56 2007
+@@ -40,6 +40,36 @@
+ -->
+
+ <target name="init" unless="init.disable" depends="_buildmagic:init">
++ <!-- Make sure we have the right version of Ant -->
++ <property name="buildmagic.ant15.baseversion" value="1.5"/>
++ <property name="buildmagic.ant16.baseversion" value="1.6"/>
++ <property name="buildmagic.ant17.baseversion" value="1.7"/>
++ <!--
++ | Add new conditions for other supported Ant versions when they
++ | become avaialble.
++ -->
++
++ <condition property="buildmagic.ant.compatible">
++ <or>
++ <contains string="${ant.version}"
++ substring="Ant version ${buildmagic.ant15.baseversion}"/>
++ <contains string="${ant.version}"
++ substring="Ant version ${buildmagic.ant16.baseversion}"/>
++ <contains string="${ant.version}"
++ substring="Ant version ${buildmagic.ant17.baseversion}"/>
++ </or>
++ </condition>
++
++ <fail unless="buildmagic.ant.compatible">
++
++ Unsupported Ant version:
++
++ ${ant.version}
++
++ Please install a version which is compatible with Ant ${buildmagic.ant15.baseversion} or ${buildmagic.ant16.baseversion}
++ or ${buildmagic.ant17.baseversion}.
++
++ </fail>
+ </target>
+
+
diff --git a/java/jboss5/files/patch-buildmagic.ent b/java/jboss5/files/patch-buildmagic.ent
new file mode 100644
index 000000000000..2e2eeb500927
--- /dev/null
+++ b/java/jboss5/files/patch-buildmagic.ent
@@ -0,0 +1,37 @@
+--- ./tools/etc/buildmagic/buildmagic.ent.orig Mon Nov 20 07:45:55 2006
++++ ./tools/etc/buildmagic/buildmagic.ent Sun Mar 25 21:28:14 2007
+@@ -7,34 +7,6 @@
+ <!-- Initialize the build system. -->
+ <target name="_buildmagic:init" unless="init.disable">
+
+- <!-- Make sure we have the right version of Ant -->
+- <property name="buildmagic.ant15.baseversion" value="1.5"/>
+- <property name="buildmagic.ant16.baseversion" value="1.6"/>
+-
+- <!--
+- | Add new conditions for other supported Ant versions when they
+- | become avaialble.
+- -->
+-
+- <condition property="buildmagic.ant.compatible">
+- <or>
+- <contains string="${ant.version}"
+- substring="Ant version ${buildmagic.ant15.baseversion}"/>
+- <contains string="${ant.version}"
+- substring="Ant version ${buildmagic.ant16.baseversion}"/>
+- </or>
+- </condition>
+-
+- <fail unless="buildmagic.ant.compatible">
+-
+- Unsupported Ant version:
+-
+- ${ant.version}
+-
+- Please install a version which is compatible with Ant ${buildmagic.ant15.baseversion} or ${buildmagic.ant16.baseversion}.
+-
+- </fail>
+-
+ <!-- JDK Detection -->
+ <available classname="java.lang.StackTraceElement" property="HAVE_JDK_1.4"/>
+ <available classname="java.lang.Enum" property="HAVE_JDK_1.5"/>
diff --git a/java/jboss5/files/patch-serial-autoinc b/java/jboss5/files/patch-serial-autoinc
deleted file mode 100644
index f39743e63678..000000000000
--- a/java/jboss5/files/patch-serial-autoinc
+++ /dev/null
@@ -1,86 +0,0 @@
-$FreeBSD$
-
-This patch allows JBoss to correctly create tables when
-using the auto-increment feature with Postgresql.
-
-diff -ruN ./server/src/etc/conf/default/standardjbosscmp-jdbc.xml /home/jonc/ports/jboss4/work/jboss-4.0.2-src/server/src/etc/conf/default/standardjbosscmp-jdbc.xml
---- ./server/src/etc/conf/default/standardjbosscmp-jdbc.xml Thu Jan 27 07:51:35 2005
-+++ /home/jonc/ports/jboss4/work/jboss-4.0.2-src/server/src/etc/conf/default/standardjbosscmp-jdbc.xml Tue May 17 16:13:34 2005
-@@ -1293,7 +1293,7 @@
- <row-locking-template>SELECT ?1 FROM ?2 WHERE ?3 ORDER BY ?4 FOR UPDATE</row-locking-template>
- <pk-constraint-template>CONSTRAINT ?1 PRIMARY KEY (?2)</pk-constraint-template>
- <fk-constraint-template>ALTER TABLE ?1 ADD CONSTRAINT ?2 FOREIGN KEY (?3) REFERENCES ?4 (?5)</fk-constraint-template>
-- <auto-increment-template>?1</auto-increment-template>
-+ <auto-increment-template>?1 serial</auto-increment-template>
- <alias-header-prefix>t</alias-header-prefix>
- <alias-header-suffix>_</alias-header-suffix>
- <alias-max-length>32</alias-max-length>
-@@ -1420,7 +1420,7 @@
- <row-locking-template>SELECT ?1 FROM ?2 WHERE ?3 ORDER BY ?4 FOR UPDATE</row-locking-template>
- <pk-constraint-template>CONSTRAINT ?1 PRIMARY KEY (?2)</pk-constraint-template>
- <fk-constraint-template>ALTER TABLE ?1 ADD CONSTRAINT ?2 FOREIGN KEY (?3) REFERENCES ?4 (?5)</fk-constraint-template>
-- <auto-increment-template>?1</auto-increment-template>
-+ <auto-increment-template>?1 serial</auto-increment-template>
- <alias-header-prefix>t</alias-header-prefix>
- <alias-header-suffix>_</alias-header-suffix>
- <alias-max-length>32</alias-max-length>
-@@ -1674,7 +1674,7 @@
- <row-locking-template/>
- <pk-constraint-template>CONSTRAINT ?1 PRIMARY KEY (?2)</pk-constraint-template>
- <fk-constraint-template>ALTER TABLE ?1 ADD CONSTRAINT ?2 FOREIGN KEY (?3) REFERENCES ?4 (?5)</fk-constraint-template>
-- <auto-increment-template>?1 IDENTITY</auto-increment-template>
-+ <auto-increment-template>?1 ?2 ?3 IDENTITY</auto-increment-template>
- <add-column-template>ALTER TABLE ?1 ADD COLUMN ?2 ?3</add-column-template>
- <drop-column-template>ALTER TABLE ?1 DROP COLUMN ?2</drop-column-template>
- <alias-header-prefix>t</alias-header-prefix>
-@@ -1973,7 +1973,7 @@
- <fk-constraint-template>ALTER TABLE ?1 ADD CONSTRAINT ?2 FOREIGN KEY (?3) REFERENCES ?4 (?5)</fk-constraint-template>
- -->
- <fk-constraint-template>ALTER TABLE ?1 ADD INDEX (?3), ADD CONSTRAINT ?2 FOREIGN KEY (?3) REFERENCES ?4 (?5)</fk-constraint-template>
-- <auto-increment-template>?1 auto_increment</auto-increment-template>
-+ <auto-increment-template>?1 ?2 ?3 auto_increment</auto-increment-template>
- <alter-column-template>ALTER TABLE ?1 MODIFY ?2 ?3</alter-column-template>
- <alias-header-prefix>t</alias-header-prefix>
- <alias-header-suffix>_</alias-header-suffix>
-@@ -2113,7 +2113,7 @@
- <row-locking-template>SELECT ?1 FROM ?2 with (updlock) WHERE ?3 ORDER BY ?4</row-locking-template>
- <pk-constraint-template>CONSTRAINT ?1 PRIMARY KEY (?2)</pk-constraint-template>
- <fk-constraint-template>ALTER TABLE ?1 ADD CONSTRAINT ?2 FOREIGN KEY (?3) REFERENCES ?4 (?5)</fk-constraint-template>
-- <auto-increment-template>?1 IDENTITY</auto-increment-template>
-+ <auto-increment-template>?1 ?2 ?3 IDENTITY</auto-increment-template>
- <alter-column-template>ALTER TABLE ?1 ALTER COLUMN ?2 ?3</alter-column-template>
- <alias-header-prefix>t</alias-header-prefix>
- <alias-header-suffix>_</alias-header-suffix>
-@@ -2245,7 +2245,7 @@
- <row-locking-template>SELECT ?1 FROM ?2 with (xlock) WHERE ?3 ORDER BY ?4</row-locking-template>
- <pk-constraint-template>CONSTRAINT ?1 PRIMARY KEY (?2)</pk-constraint-template>
- <fk-constraint-template>ALTER TABLE ?1 ADD CONSTRAINT ?2 FOREIGN KEY (?3) REFERENCES ?4 (?5)</fk-constraint-template>
-- <auto-increment-template>?1 IDENTITY</auto-increment-template>
-+ <auto-increment-template>?1 ?2 ?3 IDENTITY</auto-increment-template>
- <alias-header-prefix>t</alias-header-prefix>
- <alias-header-suffix>_</alias-header-suffix>
- <alias-max-length>32</alias-max-length>
-diff -ruN ./server/src/main/org/jboss/ejb/plugins/cmp/jdbc/JDBCStartCommand.java /home/jonc/ports/jboss4/work/jboss-4.0.2-src/server/src/main/org/jboss/ejb/plugins/cmp/jdbc/JDBCStartCommand.java
---- ./server/src/main/org/jboss/ejb/plugins/cmp/jdbc/JDBCStartCommand.java Tue Oct 26 22:28:23 2004
-+++ /home/jonc/ports/jboss4/work/jboss-4.0.2-src/server/src/main/org/jboss/ejb/plugins/cmp/jdbc/JDBCStartCommand.java Tue May 17 16:13:34 2005
-@@ -916,14 +916,18 @@
- // apply auto-increment template
- if(type.getAutoIncrement()[0])
- {
-- String columnClause = SQLUtil.getCreateTableColumnsClause(type);
- JDBCFunctionMappingMetaData autoIncrement =
- manager.getMetaData().getTypeMapping().getAutoIncrementTemplate();
- if(autoIncrement == null)
- {
- throw new IllegalStateException("auto-increment template not found");
- }
-- String[] args = new String[]{columnClause};
-+ String[] args = new String[]
-+ {
-+ type.getColumnNames () [0],
-+ type.getSQLTypes () [0],
-+ type.getNotNull () [0] ? " not null " : ""
-+ };
- autoIncrement.getFunctionSql(args, sqlBuffer);
- }
- else
diff --git a/java/jboss5/pkg-deinstall b/java/jboss5/files/pkg-deinstall.in
index 0521ad5fd496..72f7b922c69f 100644
--- a/java/jboss5/pkg-deinstall
+++ b/java/jboss5/files/pkg-deinstall.in
@@ -5,7 +5,7 @@
# * Checks if the JBoss PID file exists. If it does, it kills the
# JBoss process and removes the PID file.
#
-# $FreeBSD: /tmp/pcvs/ports/java/jboss5/Attic/pkg-deinstall,v 1.2 2003-07-14 10:03:13 des Exp $
+# $FreeBSD$
#
# Make sure we're in the right stage of the process
diff --git a/java/jboss5/pkg-install b/java/jboss5/files/pkg-install.in
index d8bfd400d779..687ec3fc1f9e 100644
--- a/java/jboss5/pkg-install
+++ b/java/jboss5/files/pkg-install.in
@@ -3,7 +3,7 @@
# Checks if the 'www' user and group exist. If they don't, then
# an attempt is made to create both.
#
-# $FreeBSD: /tmp/pcvs/ports/java/jboss5/Attic/pkg-install,v 1.1 2002-04-26 21:54:15 znerd Exp $
+# $FreeBSD$
#
# Make sure we're called during the 'make install' process
diff --git a/java/jboss5/files/pkg-message b/java/jboss5/files/pkg-message.in
index e48411f3028c..e48411f3028c 100644
--- a/java/jboss5/files/pkg-message
+++ b/java/jboss5/files/pkg-message.in
diff --git a/java/jboss5/pkg-descr b/java/jboss5/pkg-descr
index 881700f3267d..28764e8a3317 100644
--- a/java/jboss5/pkg-descr
+++ b/java/jboss5/pkg-descr
@@ -1,24 +1,16 @@
-JBoss AS 4 is an officially certified J2EE 1.4 application server. The
-certification guarantees that JBoss AS 4 conforms to the formal J2EE
-specification.
+JBoss AS 5 GA will be Java EE 5 certified and will include the following core
+technologies.
-- supports J2EE Web Services including JAX-RPC (Java API for XML for
-Remote Procedure Call) and the Web Services for J2EE Architecture.
-
-- implements the JMS (Java Messaging Service) 1.1 specification.
-
-- implements the JCA (Java Connector Architecture) 1.5 specification.
-The JCA 1.5 specification adds support for the life cycle management of
-resource adapters, worker thread management as well as transaction and
-message inflow from the resource adapter to the application server.
-
-- implements the Java Authorization Contract for Containers (JACC)
-specification.
-
-- implements the EJB 2.1 specification. The EJB 2.1 specification
-extends the message-driven bean contracts to support other messaging
-types in addition to JMS. It supports stateless session beans as web
-service endpoints. It also includes a new container managed service
-called the EJB timer service.
+ * JBoss Microcontainer - POJO based microcontainer removing the dependency
+ on JMX
+ * EJB 3.0 - Fully certified as part of the Java EE 5 compliant JBoss AS 5
+ * Hibernate 3.2 - JPA certified
+ * JBoss Messaging 1.2 - the next generation messaging platform from JBoss
+ with HA features.
+ * JBoss WebServices 2.0 - new custom built JAX-WS compliant WebServices
+ stack.
+ * JBoss Seam 1.1 - a powerful new application framework to build next
+ generation Web 2.0 applications by unifying and integrating popular
+ service oriented architecture (SOA) technologies
WWW: http://www.jboss.org/