aboutsummaryrefslogtreecommitdiff
path: root/java/jcckit
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-08-30 06:03:12 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-08-30 06:03:12 +0000
commitb74cf9717f2c2433516192fed0b967ec7e3f1c02 (patch)
treea66493411682102c4bb7b60d8a04a46a9b37c965 /java/jcckit
parent9be1eb18f2a7133ba9bf97d948845bb8974e3155 (diff)
downloadports-b74cf9717f2c2433516192fed0b967ec7e3f1c02.tar.gz
ports-b74cf9717f2c2433516192fed0b967ec7e3f1c02.zip
Notes
Diffstat (limited to 'java/jcckit')
-rw-r--r--java/jcckit/Makefile39
-rw-r--r--java/jcckit/distinfo2
-rw-r--r--java/jcckit/pkg-descr20
3 files changed, 61 insertions, 0 deletions
diff --git a/java/jcckit/Makefile b/java/jcckit/Makefile
new file mode 100644
index 000000000000..f4c818311d64
--- /dev/null
+++ b/java/jcckit/Makefile
@@ -0,0 +1,39 @@
+# ex:ts=8
+# Ports collection makefile for: jcckit
+# Date created: Aug 30, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= jcckit
+PORTVERSION= 1.0
+CATEGORIES= java
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Java Chart Construction Kit
+
+USE_ZIP= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.1+
+WRKSRC= ${WRKDIR}/JCCKit
+NO_BUILD= yes
+PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.jar ${JAVAJARDIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in LICENSE.txt README.html docs
+ ${CP} -R ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/java/jcckit/distinfo b/java/jcckit/distinfo
new file mode 100644
index 000000000000..29fe4bdf1186
--- /dev/null
+++ b/java/jcckit/distinfo
@@ -0,0 +1,2 @@
+MD5 (jcckit.zip) = c51e62e4f283e995370db9aa9dae8f26
+SIZE (jcckit.zip) = 1122353
diff --git a/java/jcckit/pkg-descr b/java/jcckit/pkg-descr
new file mode 100644
index 000000000000..3be6ae6461ac
--- /dev/null
+++ b/java/jcckit/pkg-descr
@@ -0,0 +1,20 @@
+The Java Chart Constuction Kit (JCCKit) is a small (< 100Kb) Java library and a
+very flexible framework for creating scientific charts and plots.
+
+The main purpose is to provide a flexible kit for writing Java applets and
+application with the need for visualizing scientific data. If you are looking
+for a lean scientific chart and plot library without all the unwanted bells and
+whistles of the heavy competitors try JCCKit.
+
+The key features of JCCKit are:
+ * small (< 100Kb jar file)
+ * highly configurable due to a sophisticated configuration concept
+ * extensible (1/3 of all classes are interfaces or abstract classes.)
+ * automatic updating if data changes
+ * easy programming of dynamic charts and plots
+ * automatic rescaling if canvas size changes
+ * out-of-the-box applet for presenting static data on a web page without
+ Java programming
+ * automatically generates a legend
+
+WWW: http://jcckit.sourceforge.net/