aboutsummaryrefslogtreecommitdiff
path: root/java/jcckit
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-05-31 13:46:04 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-05-31 13:46:04 +0000
commitb39633f69e60050c3d1d812db10da981a852e71a (patch)
treec9e9227bc5d57097298065e4472f3942340a7c24 /java/jcckit
parente91eb32c491e738e96e6e619405a9edb5aceb191 (diff)
downloadports-b39633f69e60050c3d1d812db10da981a852e71a.tar.gz
ports-b39633f69e60050c3d1d812db10da981a852e71a.zip
Notes
Diffstat (limited to 'java/jcckit')
-rw-r--r--java/jcckit/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/java/jcckit/Makefile b/java/jcckit/Makefile
index 7daa4a94edc7..a60372c29a12 100644
--- a/java/jcckit/Makefile
+++ b/java/jcckit/Makefile
@@ -15,20 +15,17 @@ USES= zip
USE_JAVA= yes
WRKSRC= ${WRKDIR}/JCCKit
NO_BUILD= yes
-PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar
-.if !defined(NOPORTDOCS)
+PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar
PORTDOCS= *
-.endif
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
do-install:
- ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.jar ${JAVAJARDIR}
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.jar ${STAGEDIR}${JAVAJARDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for file in LICENSE.txt README.html docs
- ${CP} -R ${WRKSRC}/${file} ${DOCSDIR}
+ ${CP} -R ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>