aboutsummaryrefslogtreecommitdiff
path: root/java/jdk13/Makefile
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2006-12-08 19:39:45 +0000
committerGreg Lewis <glewis@FreeBSD.org>2006-12-08 19:39:45 +0000
commit0b647d9e4bc658c55fc7d7f24a0571ca997fb69a (patch)
tree4cad205a48aa63c30cac40a4e435dd9eb614896d /java/jdk13/Makefile
parent19cf66df2a8d2fd30ffaa37e5771445878790467 (diff)
. Replace some hardwired /usr/X11R6 instances with X11BASE. [1]
. Replace one hardwired /usr/local instance with LOCALBASE. This wasn't a problem since the port Makefile overrode that variable anyway. . Small Makefile restructure to keep related variables in one place. Pointed out by: pointyhat (via kris) [1]
Notes
Notes: svn path=/head/; revision=179192
Diffstat (limited to 'java/jdk13/Makefile')
-rw-r--r--java/jdk13/Makefile27
1 files changed, 16 insertions, 11 deletions
diff --git a/java/jdk13/Makefile b/java/jdk13/Makefile
index 46459bebf0dd..0366ce84bb32 100644
--- a/java/jdk13/Makefile
+++ b/java/jdk13/Makefile
@@ -106,8 +106,17 @@ HOTSPOT_TARGETS=compiler1 compiler2
PLIST_SUB+= HOTSPOT:="@comment "
.endif
-LD_LIBRARY_PATH_FILES= ../src/solaris/javavm/runtime/javai_md.c \
- ../../hotspot1.3.1/src/os/linux/vm/os_linux.cpp
+LOCAL_FILES= ../src/solaris/javavm/runtime/javai_md.c \
+ ../../hotspot1.3.1/src/os/linux/vm/os_linux.cpp
+PTHREAD_FILES= common/Defs.gmk \
+ common/Program.gmk \
+ java/hpi/native/Makefile \
+ sun/cmm/Makefile \
+ ../ext/plugin/build/solaris/GNUmakefile \
+ ../../hotspot1.3.1/build/linux/platform_i486 \
+ ../../hotspot1.3.1/build/bsd/makefiles/gcc.make \
+ ../../hotspot1.3.1/build/linux/makefiles/vm.make
+X11_FILES= ../src/solaris/native/sun/awt/font/fontpath.c
.include <bsd.port.pre.mk>
@@ -126,14 +135,6 @@ BUILD_DEPENDS+= ${JDK13DIR}/bin/javac:${PORTSDIR}/java/jbootstrap
.endif
.endif
-PTHREAD_FILES= common/Defs.gmk \
- common/Program.gmk \
- java/hpi/native/Makefile \
- sun/cmm/Makefile \
- ../ext/plugin/build/solaris/GNUmakefile \
- ../../hotspot1.3.1/build/linux/platform_i486 \
- ../../hotspot1.3.1/build/bsd/makefiles/gcc.make \
- ../../hotspot1.3.1/build/linux/makefiles/vm.make
.if ${OSVERSION} < 460101 || ( ${OSVERSION} >= 500000 && ${OSVERSION} < 500038 )
EXTRACT_DEPENDS+= gtar:${PORTSDIR}/archivers/gtar
@@ -198,7 +199,7 @@ pre-patch:
post-patch:
@${FIND} -d ${WRKDIR} -name SCCS -exec ${RM} -rf {} \;
- @for file in ${LD_LIBRARY_PATH_FILES}; do \
+ @for file in ${LOCAL_FILES}; do \
${REINPLACE_CMD} -e "s:%%LOCALBASE%%:${LOCALBASE}:" \
${WRKSRC}/$${file}; \
done
@@ -208,6 +209,10 @@ post-patch:
-e "s:-lpthread:${PTHREAD_LIBS}:g" \
${WRKSRC}/$${file}; \
done
+ @for file in ${X11_FILES}; do \
+ ${REINPLACE_CMD} -e "s:%%X11BASE%%:${X11BASE}:" \
+ ${WRKSRC}/$${file}; \
+ done
pre-build:
.if defined(WITH_LINUX_BOOTSTRAP)